Форум русскоязычного сообщества Ubuntu


Автор Тема: bomi player проблемы с зависимостями  (Прочитано 915 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн voice_of_reason

  • Автор темы
  • Участник
  • *
  • Сообщений: 140
    • Просмотр профиля
bomi player проблемы с зависимостями
« : 16 Январь 2016, 10:49:28 »
До недавнего времени пользовался и проблем не знал, но как-то за последний месяц ubuntu начала сильно делать голову. То одно не работает, то второе, то третье. Пришлось откатиться systemback'ом до состояния близкого к послеустановочному. Так вот, обновился dist-upgrade'ом, добавил реп bomi, на что в ответ получил следующее:
(Нажмите, чтобы показать/скрыть)
Теперь для работы bomi, а так же для его компиляции в 14.04 требуются пакеты из vivid, которых нет в репах trusty. Aptitude помогает решить эту проблему, но предлагает выпилить часть системы и вероятно ломает один из метапакетов, что в прошлый раз привело к самовыпилу системы через dist-upgrade. Вот что требует bomi для компиляции
(Нажмите, чтобы показать/скрыть)
Очень понравился этот плеер, теперь жить без него не могу. Как быть-то?

Оффлайн voice_of_reason

  • Автор темы
  • Участник
  • *
  • Сообщений: 140
    • Просмотр профиля
Re: bomi player проблемы с зависимостями
« Ответ #1 : 24 Январь 2016, 06:48:53 »
Поднимаю тему. Всё ещё актуальна. Я не могу просто так взять и отказаться от этого чудесного, простого и элегантного плеера который просто создан для просмотра сериалов!
Проблема с зависимостями после одного из по следних обновлений. Пробовал ставить 15.10 проблема остаётся. Aptitude помогает решить проблему, но попутно ломая один из метапакетов в ubuntu и система после очередного dist-upgrade стремится сделать харакири и удалить порядка 500mb пакетов.
Можно ли как-то устанавливать софт в изолированную среду так, чтобы он работал как нативное, родное приложение?
Кто пользуется, кто победил? Помогите.

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2508
    • Просмотр профиля
Re: bomi player проблемы с зависимостями
« Ответ #2 : 24 Январь 2016, 06:55:10 »
voice_of_reason, откуда устанавливаешь?
Я никого не сторожил!

Оффлайн voice_of_reason

  • Автор темы
  • Участник
  • *
  • Сообщений: 140
    • Просмотр профиля
Re: bomi player проблемы с зависимостями
« Ответ #3 : 24 Январь 2016, 07:27:59 »
voice_of_reason, откуда устанавливаешь?

Оф реп, конечно же ppa:darklin20/bomi . Пакеты судя по всему нужны не новые, а старые, ибо как написал разработчик в твиттере в июле 15-го года он испытывает финансовые проблемы и пока не может заниматься разработкой bomi. Поэтому bomi использует старые зависимости gcc и ffmpeg и ещё нескольких пакетов даунгрейд которых ломает один из метапакетов ubuntu. Услышал о docker'е, вот, пробую сейчас через него. Но что-то мне подсказывает что на иксах это работать не будет.

Оффлайн ANIK-kun

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: bomi player проблемы с зависимостями
« Ответ #4 : 14 Апрель 2016, 07:26:23 »
Попробуйте так:
sudo add-apt-repository ppa:darklin20/bomisudo add-apt-repository ppa:ubuntu-toolchain-r/testsudo apt-get updatesudo apt-get install bomi
Работает 100%
« Последнее редактирование: 25 Апрель 2016, 19:56:50 от ANIK-kun »

Оффлайн Vlad.V

  • Активист
  • *
  • Сообщений: 478
    • Просмотр профиля
Re: bomi player проблемы с зависимостями
« Ответ #5 : 14 Апрель 2016, 21:17:41 »
А что если поставить FFMPEG из исходников? Удалить весь старый LIBAV (AVCONV/FFMPEG) и поставить свежак?

 

Страница сгенерирована за 0.055 секунд. Запросов: 24.