Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: [РЕШЕНО] после установки второго linux дистрибутива не грузится 15.10  (Прочитано 490 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн albatross

  • Автор темы
  • Любитель
  • *
  • Сообщений: 55
    • Просмотр профиля
Здравствуйте, прошу помочь!
Установлена 15.10 на sda2 ("/") и sda3 ("/home"). Поставил на разделы sda5, sda6 (соответственно / и /home) Slackware 14.1
при установке Slackware загрузчик не ставил, но после установки Ubuntu перестала грузиться. Что такого сделал уже не помню (((

Симптомы:
- после установки второй ОС бут меню не изменилось - все тот же Ubuntu (основная загрузка, мемтест и т.п...), но после попытки загрузки Ubuntu меню выдает экран загрузки Убунты (бегут точечки), но при этом никаких запросов на винт (индикатор работы винта не горит). Ждал минут 5-7 пару раз...
- сделал загрузку с лив-сд убунты (исо лежит на диске и был прописан в загрузочном меню, там и остался и с него лив Ubuntu грузится) и попробовал восстановить загрузчик (хоть и понял что не в нем дело) с помощью boot-repair. После чего в меню загрузки добавились пункты по загрузке Slackware, которая из этого меню грузится нормально. Все пункты загрузки Убунты остались но попытка загрузить Ubuntu дает такой же результат (бесконечный экран загрузки и не горит индикатор винчестера).
Вот отчет boot-repair http://paste.ubuntu.com/14592474/

разделы /dev/sda2 /dev/sda3, на которых была Ubuntu и домашний раздел вроде целы.

Помогите пожалуйста исправить проблему, если это возможно. Скажите пожалуйста, что посмотреть/содержание каких файлов выложить?

UPD: зашел из лив-сд на /dev/sda2 ("/") и увидел, что папкa /sys пустая (отдельно я ее не монтировал, она в корневом была) (((
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 24 Январь 2016, 02:01:46 от albatross »
KUbuntu 12.04 x64
Compiz
AMD Athlon II X2 240; RAM Kingston DDR2 800 2+2 Gb; MB Gigabyte M85MUS2H, onboard video Nvidia 8200, onboard audio Realtek ALC888; LCD LG Flatron W2253V

Оффлайн kofesutra

  • Активист
  • *
  • Сообщений: 282
    • Просмотр профиля
Другие ядра грузятся?

не скажу за утилитку boot-repair, но я неоднократно восстанавливал Grub с помощью chroot http://help.ubuntu.ru/wiki/%D0%B2%D0%BE%D1%81%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5_grub#восстановление_используя_chroot

alex_ander

  • Гость
если на "сплеш-крине" (тот самый экран с точечками нажать Esc, то возможно увидишь текст ошибки загрузки

иии, всё что пока заметил - у тебя помечена Ubuntu 14.04 на /dev/sda

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
albatross,
а я заметил что swap у тебя назначен загрузочным разделом. Может это и не критично, но 100% не по фен-Шую.

Оффлайн albatross

  • Автор темы
  • Любитель
  • *
  • Сообщений: 55
    • Просмотр профиля
Всем спасибо за советы!
Комп дома, буду смотреть вечером/завтра утром.
Но я кажется понял, на какие грабли наступил - при установке Slackware я указал тот же swap раздел, что и для убунты. Точно не помню, но вполне возможно что Slackware этот свап раздел форматнула при установке, а значит поменялся UUID свап раздела, а значит возможны проблемы с загрузкой.
В общем планирую проверить UUID свап раздела и сравнивать с тем что указан в sda2/etc/fstab и sda2/boot/grub/grub.cfg, и если изменился - подправить на текущий (с бекапами разумеется).
Вопрос - если UUID изменился - будет достаточно правки /etc/fstab и /boot/grub/grub.cfg или нужно еще что-то сделать?
« Последнее редактирование: 22 Январь 2016, 23:38:17 от albatross »
KUbuntu 12.04 x64
Compiz
AMD Athlon II X2 240; RAM Kingston DDR2 800 2+2 Gb; MB Gigabyte M85MUS2H, onboard video Nvidia 8200, onboard audio Realtek ALC888; LCD LG Flatron W2253V

Оффлайн Ampermetr

  • Активист
  • *
  • Сообщений: 491
    • Просмотр профиля
wajnon,
Если не ошибаюсь, то при загрузке с ливсд всегда свап показывается как загрузочный раздел.
Женский форум,топик "Плакала всю ночь, подскажите из-за чего?"
Линукс форум, топик "Всю ночь собирал генту, подскажите зачем?"

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
wajnon,
Если не ошибаюсь, то при загрузке с ливсд всегда свап показывается как загрузочный раздел.
хм.. странная фича.

Оффлайн jura12

  • Старожил
  • *
  • Сообщений: 1183
  • debian 9, manjaro
    • Просмотр профиля
я раздел /home делаю общим для несколько систем. только ввожу разных пользователей.
сопротивление бессполезно

Оффлайн albatross

  • Автор темы
  • Любитель
  • *
  • Сообщений: 55
    • Просмотр профиля
Докладываю:
UUID свап-раздела изменился, но мое шаманство с фстаб не помогло ))
Поскольку home раздел сохранен - счел нецелесообразным "терроризировать" уважаемое сообщество и просто переустановил систему.
Вопрос закрыт, всем отозвавшимся большое спасибо!
KUbuntu 12.04 x64
Compiz
AMD Athlon II X2 240; RAM Kingston DDR2 800 2+2 Gb; MB Gigabyte M85MUS2H, onboard video Nvidia 8200, onboard audio Realtek ALC888; LCD LG Flatron W2253V

 

Страница сгенерирована за 0.061 секунд. Запросов: 24.