Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Kubuntu 15.10 и волшебное отсутствие звука  (Прочитано 1081 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ghaydn

  • Автор темы
  • Новичок
  • *
  • Сообщений: 38
    • Просмотр профиля
(Нажмите, чтобы показать/скрыть)

Всем здрасте. Установил сегодня Kubuntu 15.10. Долго не хотел этого делать, так как, в принципе, сидел себе на минте, было ок. Однако из-за несовместимости базовых библиотек и последних версий нужного мне софта пришлось переползти. Не сразу я обнаружил свинью, которую мне подложил коварный волк-оборотень, а именно - вся звуковая система завязалась на loopback без всяких шансов её оттуда отвязать. Соответственно, звука не просто нема, а ещё не реагируют клавиши на боку ноута, предназначенные для быстрой регулировки громкости встроенной карты.

(Нажмите, чтобы показать/скрыть)

Конечно же, JACK работает прекрасно, так как он обращается напрямую к звуковой карте. Любопытно, что каким-то магическим образом система таки смогла издать несколько звуков... через USBшную карту. Звуки эти были не через какие-то приложения, а просто системные сигналы.
Есть мизерный шанс, что всё заглючило после установки репозиториев kxstudio, я просто не уверен, был ли звук до того, так как эти репы ставлю прям сразу же на чистую систему.
И да, юзер в группе аудио.
Вот как-то так. Гугл про 15.10 пока ещё мало знает, а ведь там, говорят, сильно переделали в кедах звуковую часть. Народ, помогите. Куда посмотреть, где что поправить? Нужно чтобы alsa по умолчанию по всем вопросам, связанным со звуком, обращалась к hw:PCH и больше ни к кому: не к hw:HDMI, не к hw:USB, ну и уж тем более не к loopback. Где что прописать?
— Доктор, меня не понимают…
— вРН БШ ЯЙЮГЮКХ?

Оффлайн τοΖεη

  • Заслуженный пользователь
  • Администратор
  • Старожил
  • *
  • Сообщений: 8603
    • Просмотр профиля
Re: Kubuntu 15.10 и волшебное отсутствие звука
« Ответ #1 : 01 Февраль 2016, 02:08:22 »
Ghaydn, давайте начнём с основного.
Покажите пож-ста alsamixer.
lspci??
Тут смотрели?
# find / -iname '*τοΖεη*'
# /God's_Universe/Book_Of_Life_aka_LordJC_protected/τοΖεη
Subject description -->> Not an ideal but s@ved 4eVer. Final destination -->> Kingdom Of Heaven

Оффлайн Ghaydn

  • Автор темы
  • Новичок
  • *
  • Сообщений: 38
    • Просмотр профиля
Re: Kubuntu 15.10 и волшебное отсутствие звука
« Ответ #2 : 01 Февраль 2016, 03:11:54 »
О, точно, lspci забыл. Почему-то перепутал его c aplay -l
(Нажмите, чтобы показать/скрыть)
Alsamixer внёс некоторую ясность. Звук на наушники был замьючен и убран, его удалось включить и добавить - музыку из Chrome получилось прослушать в наушниках. Тем не менее, система всё равно считает, что карта по умолчанию - loopback, с чипом loopback mixer, поэтому не работают кнопки регулировки звука, и виджет "Громкость" показывает пустое окно; плюс никак не реагирует на подключение/отключение наушников.

Настройка мультимедийной платформы Phonon, раздел "Звук и видео" - на воспроизведение звука доступно только одно устройство Default, на запись вообще нет никаких. Кстати, вебкамеры там тоже нет, хотя вроде должна быть.
« Последнее редактирование: 01 Февраль 2016, 03:19:34 от Ghaydn »
— Доктор, меня не понимают…
— вРН БШ ЯЙЮГЮКХ?

Оффлайн τοΖεη

  • Заслуженный пользователь
  • Администратор
  • Старожил
  • *
  • Сообщений: 8603
    • Просмотр профиля
Re: Kubuntu 15.10 и волшебное отсутствие звука
« Ответ #3 : 01 Февраль 2016, 03:26:10 »
Ghaydn,  покажите скрин alsamixer пож-ста.
По вэбке - проверьте реакцию на:
cheese
# find / -iname '*τοΖεη*'
# /God's_Universe/Book_Of_Life_aka_LordJC_protected/τοΖεη
Subject description -->> Not an ideal but s@ved 4eVer. Final destination -->> Kingdom Of Heaven

Оффлайн Ghaydn

  • Автор темы
  • Новичок
  • *
  • Сообщений: 38
    • Просмотр профиля
Re: Kubuntu 15.10 и волшебное отсутствие звука
« Ответ #4 : 01 Февраль 2016, 03:50:57 »
"Скрины" alsamixer - выше под спойлером. Продублирую, а то там разметку перекосило:
(Нажмите, чтобы показать/скрыть)

Попробовал установить cheese, но он потянул за собой половину Unity, и вместо него поставил первое попавшееся по запросу "kde webcam" - kamerka. И вот тут началась сущая магия, так как при запуске оного приложения (изображение с камеры, кстати, показывает; оно, как я понял, обращается напрямую к девайсу, минуя КДЕшную прослойку) всплывает сообщение:
Цитировать
Мультимедийная подсистема

The audio playback device HDA Intel PCH (ALC3236 Analog) does not work.
Falling back to Default.

Пользователь решил продолжить мысль [time]01 Февраль 2016, 15:18:32[/time]:
Поспал и вспомнил, как было дело в минте. Там звук отсутствовал потому что дефолтным устройством оно считало hw:HDMI. Точно не помню, в каком файле пришлось исправлять конфиги, но он лежал точно не в домашней папке.

Ещё любопытное наблюдение. В ~/.kde/share/config/phonondevicesrc все звуковые карты прописаны. Тем не менее, сам phonon отображает только устройство Default

(Нажмите, чтобы показать/скрыть)

Пользователь решил продолжить мысль 01 Февраль 2016, 16:16:31:
Причина действительно была в магии. В неведомой магии настроек kxstudio, которые применились после установки пакета kxstudio-default-settings (и запуска скрипта, им порождаемого) и затёрли нормально работающие конфиги 15.10. А всё из-за того, что этот пакет рассчитан на 14.04.
Переустановил систему, но не запускал этот скрипт, и всё со звуком нормально.
« Последнее редактирование: 01 Февраль 2016, 16:16:31 от Ghaydn »
— Доктор, меня не понимают…
— вРН БШ ЯЙЮГЮКХ?

 

Страница сгенерирована за 0.072 секунд. Запросов: 25.