Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Проблема с пакетным менеджером на 14.04  (Прочитано 1030 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн rus.kerimov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Привет.

Не могу установить некоторые пакеты, например, gimp, вот что пишет:
(Нажмите, чтобы показать/скрыть)

Причем указанная зависимость присутствует в индексе:
(Нажмите, чтобы показать/скрыть)

Помогите разобраться. Спасибо.

Оффлайн potatoes

  • Любитель
  • *
  • Сообщений: 77
    • Просмотр профиля
Re: Проблема с пакетным менеджером на 14.04
« Ответ #1 : 03 Февраль 2016, 19:40:06 »
Покажите свой source.list

Оффлайн rus.kerimov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Проблема с пакетным менеджером на 14.04
« Ответ #2 : 03 Февраль 2016, 20:08:44 »
source.list:
(Нажмите, чтобы показать/скрыть)

Оффлайн potatoes

  • Любитель
  • *
  • Сообщений: 77
    • Просмотр профиля
Re: Проблема с пакетным менеджером на 14.04
« Ответ #3 : 03 Февраль 2016, 21:53:59 »
Можно попробовать сменить ru зеркало на другое или, что надежнее, совсем без него, к примеру:

deb http://archive.ubuntu.com/ubuntu/ trusty main restricted universe
deb-src http://archive.ubuntu.com/ubuntu/ trusty main restricted universe

deb http://archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://archive.ubuntu.com/ubuntu/ trusty multiverse

Если не поможет, дайте вывод команды:

apt-get install libgegl-0.2-0 gimp

Оффлайн rus.kerimov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Проблема с пакетным менеджером на 14.04
« Ответ #4 : 04 Февраль 2016, 12:13:51 »
potatoes,
Замена урлов репозиториев не помогла.

Вывод:
(Нажмите, чтобы показать/скрыть)

Спустившись ниже по зависимостям нашёл следующее:
(Нажмите, чтобы показать/скрыть)

Т.е. требуется gcc-4.8-base=4.8.2-19ubuntu1, а стоит версия 4.8.4-2ubuntu1~14.04 , пробую удалить -- не выходит:
(Нажмите, чтобы показать/скрыть)

Оффлайн potatoes

  • Любитель
  • *
  • Сообщений: 77
    • Просмотр профиля
Re: Проблема с пакетным менеджером на 14.04
« Ответ #5 : 04 Февраль 2016, 12:35:27 »
Еще один вариант, не уверен, что поможет, это попробовать aptitude (если не установлен - установите), иногда он лучше с зависимостями разбирается:

sudo aptitude install gimp (в крайнем случае повторить "с самого низа" - sudo aptitude install libgfortran3)

apt-get clean и apt-get update делали, кстати?

Оффлайн rus.kerimov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Проблема с пакетным менеджером на 14.04
« Ответ #6 : 17 Февраль 2016, 11:46:39 »
potatoes, спасибо aptitude помог с gimp: предложил downgrade для пакета gcc-4.8-base и зависимых.

Но пробую установить skype, получаю такую портянку:
(Нажмите, чтобы показать/скрыть)
Т.е. предлагает удалить 380! пакетов, установить 569!

 

Страница сгенерирована за 0.058 секунд. Запросов: 25.