Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: проблеммы с установкой пакетов  (Прочитано 1097 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн warlock

  • Автор темы
  • Активист
  • *
  • Сообщений: 257
  • Linux Ubuntu 12.04
    • Просмотр профиля
Доброе время суток, Уважаемые
 при выполнении команды apt-get update наблюдается следующее
1-
sergey@sergey-desktop:~$ sudo apt-get update
Получено:1 http://security.ubuntu.com dapper-security Release.gpg [191B]
Ign http://security.ubuntu.com dapper-security/main [b]Translation-ru
Ign http://security.ubuntu.com dapper-security/restricted [b]Translation-ru
Получено:2 http://archive.canonical.com gutsy Release.gpg [191B]                                           
Получено:3 http://security.ubuntu.com gutsy-security Release.gpg [191B]                                             
Ign http://security.ubuntu.com gutsy-security/main Translation-ru                                                   
Ign http://security.ubuntu.com gutsy-security/restricted Translation-ru                                   
Ign http://security.ubuntu.com gutsy-security/universe Translation-ru                                     
Ign http://security.ubuntu.com gutsy-security/multiverse Translation-ru                                   
В кеше http://security.ubuntu.com dapper-security Release                                                 
В кеше http://security.ubuntu.com gutsy-security Release                                                             
В кеше http://security.ubuntu.com dapper-security/main Packages                                                     
В кеше http://security.ubuntu.com dapper-security/restricted Packages                                               
В кеше http://security.ubuntu.com gutsy-security/main Packages                                                       
В кеше http://security.ubuntu.com gutsy-security/restricted Packages                                                 
В кеше http://security.ubuntu.com gutsy-security/universe Packages                                                   
В кеше http://security.ubuntu.com gutsy-security/multiverse Packages                                                 
Ign http://archive.canonical.com gutsy/partner Translation-ru                                                       
В кеше http://archive.canonical.com gutsy Release                                                         
В кеше http://archive.canonical.com gutsy/partner Packages                             
В кеше http://archive.canonical.com gutsy/partner Sources         
99% [Соединение с ru.archive.ubuntu.com (77.88.19.68)]   
                                                           

после этого всё удачно зависает и никаких действий.
что в этом случае делать и почему всё что касается русского обновления игнорируется Ign http://archive.canonical.com gutsy/partner Translation-ru   
да и ещё в синаптике в локализациях только обновления для "en" для ru  его нет!

2- при установке какого либо другого дистрибутива выводиь следующее
sudo apt-get install opera
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Reading state information... Готово                       
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.

Так как вы просили выполнить только одну операцию, то вероятнее всего, что
пакет просто не может быть установлен из-за ошибок в самом пакете.
Необходимо послать отчёт об этой ошибке.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
  opera: Зависит: libqt3-mt (>= 3:3.3.8really3.3.7) но он не будет установлен
E: Сломанные пакеты
как я понимаю  libqt3-mt (>= 3:3.3.8really3.3.7) говорит о том? что мой пакет старой версии. как его зобновить
« Последнее редактирование: 13 Май 2008, 14:04:18 от warlock »

Оффлайн ziv

  • Активист
  • *
  • Сообщений: 403
    • Просмотр профиля
Re: проблеммы с установкой пакетов
« Ответ #1 : 13 Май 2008, 14:16:03 »
Доброе время суток, Уважаемые
 при выполнении команды apt-get update наблюдается следующее
1-
sergey@sergey-desktop:~$ sudo apt-get update
Получено:1 http://security.ubuntu.com dapper-security Release.gpg [191B]
Ign http://security.ubuntu.com dapper-security/main [b]Translation-ru
Ign http://security.ubuntu.com dapper-security/restricted [b]Translation-ru
Получено:2 http://archive.canonical.com gutsy Release.gpg [191B]                                           
Получено:3 http://security.ubuntu.com gutsy-security Release.gpg [191B]                                             
Ign http://security.ubuntu.com gutsy-security/main Translation-ru                                                   
Ign http://security.ubuntu.com gutsy-security/restricted Translation-ru                                   
Ign http://security.ubuntu.com gutsy-security/universe Translation-ru                                     
Ign http://security.ubuntu.com gutsy-security/multiverse Translation-ru                                   
В кеше http://security.ubuntu.com dapper-security Release                                                 
В кеше http://security.ubuntu.com gutsy-security Release                                                             
В кеше http://security.ubuntu.com dapper-security/main Packages                                                     
В кеше http://security.ubuntu.com dapper-security/restricted Packages                                               
В кеше http://security.ubuntu.com gutsy-security/main Packages                                                       
В кеше http://security.ubuntu.com gutsy-security/restricted Packages                                                 
В кеше http://security.ubuntu.com gutsy-security/universe Packages                                                   
В кеше http://security.ubuntu.com gutsy-security/multiverse Packages                                                 
Ign http://archive.canonical.com gutsy/partner Translation-ru                                                       
В кеше http://archive.canonical.com gutsy Release                                                         
В кеше http://archive.canonical.com gutsy/partner Packages                             
В кеше http://archive.canonical.com gutsy/partner Sources         
99% [Соединение с ru.archive.ubuntu.com (77.88.19.68)]   
                                                           

после этого всё удачно зависает и никаких действий.
что в этом случае делать и почему всё что касается русского обновления игнорируется Ign http://archive.canonical.com gutsy/partner Translation-ru   
да и ещё в синаптике в локализациях только обновления для "en" для ru  его нет!

Не обязательно зависает. Возможно, сервер сильно загружен или вообще не отвечает.
Попробуй в настройках Синаптика указать официальный сервер (archive.ubuntu.com). Он хоть и тоже загружен, но с него все-таки обычно качается, хоть и медленно.

2- при установке какого либо другого дистрибутива выводиь следующее
sudo apt-get install opera
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Reading state information... Готово                       
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.

Так как вы просили выполнить только одну операцию, то вероятнее всего, что
пакет просто не может быть установлен из-за ошибок в самом пакете.
Необходимо послать отчёт об этой ошибке.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
  opera: Зависит: libqt3-mt (>= 3:3.3.8really3.3.7) но он не будет установлен
E: Сломанные пакеты
как я понимаю  libqt3-mt (>= 3:3.3.8really3.3.7) говорит о том? что мой пакет старой версии. как его зобновить

Думаю, это из-за того, что твоя система не может получить обновленную информацию о пакетах с сервера - т.е. из-за пункта 1.

Оффлайн warlock

  • Автор темы
  • Активист
  • *
  • Сообщений: 257
  • Linux Ubuntu 12.04
    • Просмотр профиля
Re: проблеммы с установкой пакетов
« Ответ #2 : 13 Май 2008, 14:34:15 »
сменил на archive.ubuntu.com (( всё без изменений!!! :'(
Получено:1 http://archive.ubuntu.com gutsy Release.gpg [191B]
В кеше http://archive.ubuntu.com gutsy/main Translation-ru
В кеше http://archive.ubuntu.com gutsy/restricted Translation-ru
В кеше http://archive.ubuntu.com gutsy/universe Translation-ru
В кеше http://archive.ubuntu.com gutsy/multiverse Translation-ru
Получено:2 http://archive.ubuntu.com gutsy-updates Release.gpg [191B]
Ign http://archive.ubuntu.com gutsy-updates/main Translation-ru
Ign http://archive.ubuntu.com gutsy-updates/restricted Translation-ru
Ign http://archive.ubuntu.com gutsy-updates/universe Translation-ru
Ign http://archive.ubuntu.com gutsy-updates/multiverse Translation-ru
Ign http://archive.ubuntu.com gutsy Release.gpg
Ign http://archive.ubuntu.com gutsy/partner Translation-ru
Получено:3 http://archive.ubuntu.com gutsy-security Release.gpg [191B]
Ign http://archive.ubuntu.com gutsy-security/main Translation-ru
Ign http://archive.ubuntu.com gutsy-security/restricted Translation-ru
Ign http://archive.ubuntu.com gutsy-security/universe Translation-ru
Ign http://archive.ubuntu.com gutsy-security/multiverse Translation-ru
В кеше http://archive.ubuntu.com gutsy Release
В кеше http://archive.ubuntu.com gutsy-updates Release
Ign http://archive.ubuntu.com gutsy Release
В кеше http://archive.ubuntu.com gutsy-security Release         
Ign http://archive.ubuntu.com gutsy/partner Packages


да и ещё уважаемые если возможно выложите  sources.list для 7.10 пожалуйста))
« Последнее редактирование: 13 Май 2008, 14:35:53 от warlock »

Оффлайн Syward

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
    • syward.ru
Re: проблеммы с установкой пакетов
« Ответ #3 : 15 Май 2008, 02:06:53 »
да и ещё уважаемые если возможно выложите  sources.list для 7.10 пожалуйста))
syward@citadel:~$ cat /etc/apt/sources.list
deb http://ru.archive.ubuntu.com/ubuntu/ gutsy main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ gutsy main restricted

deb http://ru.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted
deb-src http://ru.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted

deb http://ru.archive.ubuntu.com/ubuntu/ gutsy universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ gutsy universe
deb http://ru.archive.ubuntu.com/ubuntu/ gutsy-updates universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ gutsy-updates universe

deb http://ru.archive.ubuntu.com/ubuntu/ gutsy multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ gutsy multiverse
deb http://ru.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse

deb http://ru.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
deb-src http://ru.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse

deb http://archive.canonical.com/ubuntu gutsy partner
deb-src http://archive.canonical.com/ubuntu gutsy partner

deb http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb http://security.ubuntu.com/ubuntu gutsy-security universe
deb-src http://security.ubuntu.com/ubuntu gutsy-security universe
deb http://security.ubuntu.com/ubuntu gutsy-security multiverse
deb http://security.ubuntu.com/ubuntu/ gutsy-security restricted main universe multiverse
deb http://mirror.yandex.ru/ubuntu/ gutsy-updates restricted main universe multiverse
deb http://mirror.yandex.ru/ubuntu/ gutsy-proposed restricted main universe multiverse
deb-src http://security.ubuntu.com/ubuntu gutsy-security multiverse
deb http://www.verlihub-project.org/debian binary/
deb http://mirror.yandex.ru/ubuntu/ gutsy main universe restricted multiverse
deb-src http://www.verlihub-project.org/debian source/

Оффлайн Bkmz

  • Участник
  • *
  • Сообщений: 212
  • Linux рулеZZZ....
    • Просмотр профиля
Пакеты
« Ответ #4 : 15 Май 2008, 04:14:47 »
У меня точно также было! Когда я не с оффициальнго серва обновления качал.

Оффлайн Vistss

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: проблеммы с установкой пакетов
« Ответ #5 : 20 Май 2008, 14:45:59 »
У меня при обновлении выскакивает сообщение:

W: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/p/python-defaults/python_2.5.1-0ubuntu3_all.deb
  407 Proxy Authentication Required

или

http://ua.archive.ubuntu.com/ubuntu/dists/feisty/multiverse/binary-i386/Packages.gz: 407 Proxy Authentication Required
http://ua.archive.ubuntu.com/ubuntu/dists/feisty/main/binary-i386/Packages.gz: 407 Proxy Authentication Required

В Debian в папке /etc/apt/ есть файлик apt.conf в котором прописывается прокси, порт, логин и пароль. Есть ли такая штуkа в Ubuntu 7.04 и где она? Если нет, то как в целом исправить ошибку?
« Последнее редактирование: 20 Май 2008, 17:04:53 от Vistss »

 

Страница сгенерирована за 0.14 секунд. Запросов: 23.