Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: The following packages cannot be authenticated Ubuntu-Server 14.04  (Прочитано 1161 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sling

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Ubuntu-server 14.04
Поставил на Hyper-V. Установил openssh, LAMP. Теперь цель - поставить и настроить vsftpd.
Пишет:
WARNING: The following packages cannot be authenticated!
  vsftpd
Install these packages without verification? [y/N] y
Err http://ru.archive.ubuntu.com/ubuntu/ trusty-updates/main vsftpd amd64 3.0.2-1ubuntu2.14.04.1
  Could not resolve 'ru.archive.ubuntu.com'
E: Failed to fetch http://ru.archive.ubuntu.com/ubuntu/pool/main/v/vsftpd/vsftpd_3.0.2-1ubuntu2.14.04.1_amd64.deb  Could not resolve 'ru.archive.ubuntu.com'

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Прокси-сервера нет, в sources.list вроде все в порядке. Кто знает, в чем трабл? :o

Оффлайн vip.lohmatiy

  • Активист
  • *
  • Сообщений: 555
  • RealScanFoto
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #1 : 20 Февраль 2016, 09:57:22 »
Sling, попробовать не "ru" а основной сервер ?
CPU-1.1G , RAM-640M , VGA-16M , рядом Матэ белка.

Оффлайн Sling

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #2 : 20 Февраль 2016, 10:05:27 »
sudo apt-get install vsftpd
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package vsftpd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'vsftpd' has no installation candidate

Оффлайн τοΖεη

  • Заслуженный пользователь
  • Администратор
  • Старожил
  • *
  • Сообщений: 8610
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #3 : 20 Февраль 2016, 10:09:42 »
Sling, зачем?
Вам же подсказали поменять сервер обновлений.
# find / -iname '*τοΖεη*'
# /God's_Universe/Book_Of_Life_aka_LordJC_protected/τοΖεη
Subject description -->> Not an ideal but s@ved 4eVer. Final destination -->> Kingdom Of Heaven

Оффлайн Sling

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #4 : 20 Февраль 2016, 10:12:04 »
Я поменял в sources.list с ru на en.
Или я перепутал?) Подскажите, как правильно?

Оффлайн τοΖεη

  • Заслуженный пользователь
  • Администратор
  • Старожил
  • *
  • Сообщений: 8610
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #5 : 20 Февраль 2016, 10:13:33 »
sudo apt-get updateпосле смены сервера делали?
# find / -iname '*τοΖεη*'
# /God's_Universe/Book_Of_Life_aka_LordJC_protected/τοΖεη
Subject description -->> Not an ideal but s@ved 4eVer. Final destination -->> Kingdom Of Heaven

Оффлайн Sling

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #6 : 20 Февраль 2016, 10:21:06 »
Делал. Что "до", что "после", одно и то же

Оффлайн τοΖεη

  • Заслуженный пользователь
  • Администратор
  • Старожил
  • *
  • Сообщений: 8610
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #7 : 20 Февраль 2016, 10:36:49 »
Sling, покажите sources.list пожалуйста.
Такое ощущение, что активны только обновления безопасности.
Проблема  с установкой исключительно данного приложения?
Можно попробовать установить и дэбку.
http://packages.ubuntu.com/trusty/vsftpd
Но лучше было бы-таки починить источники.
Если крутили sources.list, то ниже линк на генератор дэфолтного конфига.
https://repogen.simplylinux.ch
« Последнее редактирование: 20 Февраль 2016, 10:50:10 от τοΖεη »
# find / -iname '*τοΖεη*'
# /God's_Universe/Book_Of_Life_aka_LordJC_protected/τοΖεη
Subject description -->> Not an ideal but s@ved 4eVer. Final destination -->> Kingdom Of Heaven

Оффлайн Sling

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #8 : 20 Февраль 2016, 11:44:37 »
# deb cdrom:[Ubuntu-Server 14.04.4 LTS _Trusty Tahr_ - Release amd64 (20160217.1)]/ trusty main restricted

#deb cdrom:[Ubuntu-Server 14.04.4 LTS _Trusty Tahr_ - Release amd64 (20160217.1)]/ trusty main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://en.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://en.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://en.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
deb-src http://en.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://ru.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ trusty universe
deb http://ru.archive.ubuntu.com/ubuntu/ trusty-updates universe
deb-src http://ru.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://en.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://en.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://en.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
deb-src http://en.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://en.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
deb-src http://en.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

deb http://en.security.ubuntu.com/ubuntu trusty-security main restricted
deb-src http://en.security.ubuntu.com/ubuntu trusty-security main restricted
deb http://en.security.ubuntu.com/ubuntu trusty-security universe
deb-src http://en.security.ubuntu.com/ubuntu trusty-security universe
deb http://en.security.ubuntu.com/ubuntu trusty-security multiverse
deb-src http://en.security.ubuntu.com/ubuntu trusty-security multiverse

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14922
  • Я не слышу.
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #9 : 20 Февраль 2016, 12:10:55 »
apt-cache policy vsftpd
~.o

Оффлайн Sling

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #10 : 20 Февраль 2016, 12:24:05 »
apt-cache policy vsftpd
vsftpd:
  Installed: (none)
  Candidate: (none)
  Version table:

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14922
  • Я не слышу.
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #11 : 20 Февраль 2016, 12:33:56 »
Sling,
а кто вытирает /etc/apt/sources.list ?
~.o

Оффлайн Sling

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #12 : 20 Февраль 2016, 13:02:56 »
Можно подробнее, что значит "вытирает"? Я его выше скидывал

Оффлайн τοΖεη

  • Заслуженный пользователь
  • Администратор
  • Старожил
  • *
  • Сообщений: 8610
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #13 : 20 Февраль 2016, 13:33:05 »
Sling, странно это всё.
Единственное, что ещё приходит на ум - это подключить репозитории Canonical Partners.
Но вообще-то, должно было установиться и без них.
Добавьте строки в sources.list:
Код: Text
  1. deb http://archive.canonical.com/ubuntu trusty partner
  2. deb-src http://archive.canonical.com/ubuntu trusty partner
sudo apt-get update ; sudo apt-get install vsftpd??
# find / -iname '*τοΖεη*'
# /God's_Universe/Book_Of_Life_aka_LordJC_protected/τοΖεη
Subject description -->> Not an ideal but s@ved 4eVer. Final destination -->> Kingdom Of Heaven

Оффлайн Sling

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Re: The following packages cannot be authenticated Ubuntu-Server 14.04
« Ответ #14 : 20 Февраль 2016, 13:41:02 »
sudo apt-get update ; sudo apt-get install vsftpd
[sudo] password for trapeznikov:
Err http://en.archive.ubuntu.com trusty InRelease

Err http://en.archive.ubuntu.com trusty-updates InRelease

Err http://en.archive.ubuntu.com trusty-backports InRelease

Err http://ru.archive.ubuntu.com trusty InRelease

Err http://ru.archive.ubuntu.com trusty-updates InRelease

Err http://en.security.ubuntu.com trusty-security InRelease

Err http://en.security.ubuntu.com trusty-security Release.gpg
  Could not resolve 'en.security.ubuntu.com'
Err http://ru.archive.ubuntu.com trusty Release.gpg
  Could not resolve 'ru.archive.ubuntu.com'
Err http://ru.archive.ubuntu.com trusty-updates Release.gpg
  Could not resolve 'ru.archive.ubuntu.com'
Err http://en.archive.ubuntu.com trusty Release.gpg
  Could not resolve 'en.archive.ubuntu.com'
Err http://en.archive.ubuntu.com trusty-updates Release.gpg
  Could not resolve 'en.archive.ubuntu.com'
Err http://en.archive.ubuntu.com trusty-backports Release.gpg
  Could not resolve 'en.archive.ubuntu.com'
Err http://archive.canonical.com trusty InRelease

Err http://archive.canonical.com trusty Release.gpg
  Could not resolve 'archive.canonical.com'
Reading package lists... Done
W: Failed to fetch http://archive.canonical.com/ubuntu/dists/trusty/InRelease

W: Failed to fetch http://en.archive.ubuntu.com/ubuntu/dists/trusty/InRelease

W: Failed to fetch http://en.archive.ubuntu.com/ubuntu/dists/trusty-updates/InRelease

W: Failed to fetch http://ru.archive.ubuntu.com/ubuntu/dists/trusty/InRelease

W: Failed to fetch http://ru.archive.ubuntu.com/ubuntu/dists/trusty-updates/InRelease

W: Failed to fetch http://en.archive.ubuntu.com/ubuntu/dists/trusty-backports/InRelease

W: Failed to fetch http://en.security.ubuntu.com/ubuntu/dists/trusty-security/InRelease

W: Failed to fetch http://en.archive.ubuntu.com/ubuntu/dists/trusty/Release.gpg  Could not resolve 'en.archive.ubuntu.com'

W: Failed to fetch http://en.archive.ubuntu.com/ubuntu/dists/trusty-updates/Release.gpg  Could not resolve 'en.archive.ubuntu.com'

W: Failed to fetch http://en.archive.ubuntu.com/ubuntu/dists/trusty-backports/Release.gpg  Could not resolve 'en.archive.ubuntu.com'

W: Failed to fetch http://ru.archive.ubuntu.com/ubuntu/dists/trusty/Release.gpg  Could not resolve 'ru.archive.ubuntu.com'

W: Failed to fetch http://ru.archive.ubuntu.com/ubuntu/dists/trusty-updates/Release.gpg  Could not resolve 'ru.archive.ubuntu.com'

W: Failed to fetch http://en.security.ubuntu.com/ubuntu/dists/trusty-security/Release.gpg  Could not resolve 'en.security.ubuntu.com'

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/trusty/Release.gpg  Could not resolve 'archive.canonical.com'

W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package vsftpd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'vsftpd' has no installation candidate
:-\

 

Страница сгенерирована за 0.06 секунд. Запросов: 25.