Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Как установить более позднюю версию программы (библиотеки) в Synaptic?  (Прочитано 838 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Xyanight

  • Автор темы
  • Забанен
  • Участник
  • *
  • Сообщений: 147
  • Это просто какой-то Python!
    • Просмотр профиля
Обновил репозитории с помощью apt-get update. Зашел в Synaptic, увидел новую версию Kivy 1.9.1 (установлена 1.9.0), установил... Все приложения, связанные с Kivy упали. Я понимаю, что новая версия фреймворка Kivy требует новые версии зависимых библиотек, но в процессе установки ничего об этом сказано не было, что я считаю халатностью и криворукостью разроботчиков, которые предлагают установить новую версию приложения, не уведомляя о том, что это приложение требует обновить сопутствующие ему пакеты.

Отсюда вопрос...
Как откатиться до версии приложения (библиотеки), например, от 1.2 до 0.1?

ТС не появлялся на Форуме более полугода по состоянию на 13/07/2019 (последняя явка: 22/06/2018). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 13 Июля 2019, 22:33:26 от zg_nico »
Это просто какой-то Python!

Онлайн F12

  • Администратор
  • Старожил
  • *
  • Сообщений: 4693
    • Просмотр профиля
К сожалению, а может к счастью (мнения на этот счет разделились), в Ubuntu нет штатного механизма отката, как системы в целом, так и отдельных пакетов, к предыдущему состоянию...

Но не все так плохо... есть, на мой взгляд, вполне приемлемые сторонние разработки, одна из которых описана вот тут

Но в твоем, Xyanight, случае это уже вряд-ли поможет... единственное, что приходит на ум, посмотреть содержимое /var/cache/apt/archives, если систему не чистил, то там можно найти уйму установочных пакетов, в том числе разных версий одного и того же... ::)

Оффлайн КНВ

  • Активист
  • *
  • Сообщений: 705
    • Просмотр профиля
В Синаптике можно указать версию пакета из всех подключенных PPA. Если там нет — скачай и установи через GDebi.
« Последнее редактирование: 05 Марта 2016, 16:24:02 от КНВ »

 

Страница сгенерирована за 0.139 секунд. Запросов: 23.