Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: пакет pips-sot30  (Прочитано 321 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн hikikomori4

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
  • Начинающий пингвин
    • Просмотр профиля
пакет pips-sot30
« : 08 Март 2016, 08:25:30 »
При установке или обновлении системы консоль постоянно ругается на pips-sot30, с которым я ничего не могу поделать.
Это возникло после установки драйвера принтера, см. тему.

Настраивается пакет pips-sot30 (3.5.0-1) …
dpkg: error processing package pips-sot30 (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1

Попытка удалить его или переустановить облегчения не принесла. Жить вроде не сильно мешает, но напрягает ошибками... Что можно сделать?? Вот вывод консоли:

(Нажмите, чтобы показать/скрыть)

(Нажмите, чтобы показать/скрыть)

При регистрации Вы знакомились с Правилами форума. Просьба соблюдать.
Цитата:
Правила форума
1. Основные положения
1.4. Листинги и содержимое текстовых файлов следует добавлять в сообщение с помощью тега [spоiler]...[/spоiler], либо прикреплять к сообщению в виде отдельного файла.
Подправил.
-- it0r


Спасибо! Торопился, чай остывал, извините)
« Последнее редактирование: 08 Март 2016, 08:37:25 от hikikomori4 »
Ubuntu 14.04.2 LTS desktop I-386.

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
Re: пакет pips-sot30
« Ответ #1 : 08 Март 2016, 11:15:16 »
hikikomori4,
Цитировать
подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Цитировать
подпроцесс установлен сценарий pre-removal возвратил код ошибки 1
покажи эти сценарии. Найти их можно в /var/lib/dpkg/info или в .deb пакете pips-sot30 (3.5.0-1).

Пользователь решил продолжить мысль 08 Март 2016, 11:17:35:
hikikomori4,
+ укажи какая система.
« Последнее редактирование: 08 Март 2016, 11:17:35 от wajnon »

Оффлайн hikikomori4

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
  • Начинающий пингвин
    • Просмотр профиля
Re: пакет pips-sot30
« Ответ #2 : 08 Март 2016, 21:55:47 »
А что мне там искать? Файлов post-installation и pre-removal у меня на винте нет... locate искал и в папке /var/lib/dpkg/info
Видимо эти сценарии внутри файла, что тут: http://download.ebz.epson.net/dsc/du/02/DriverDownloadInfo.do?LG2=EN&CN2=&DSCMI=16143&DSCCHK=10bcba31c93256662229ad6e589eda750acde707

Система Ubuntu 14.04.LTS

*******************

Поискал: $ locate pips-sot30

(Нажмите, чтобы показать/скрыть)
/var/lib/dpkg/info/pips-sot30.postrm
/var/lib/dpkg/info/pips-sot30.prerm


Похоже?
« Последнее редактирование: 08 Март 2016, 22:09:19 от hikikomori4 »
Ubuntu 14.04.2 LTS desktop I-386.

Оффлайн hikikomori4

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
  • Начинающий пингвин
    • Просмотр профиля
Re: пакет pips-sot30
« Ответ #3 : 21 Март 2016, 02:58:16 »
По-прежнему остаётся ошибка, помогите пожалуйтста!

(Нажмите, чтобы показать/скрыть)

(Нажмите, чтобы показать/скрыть)

(Нажмите, чтобы показать/скрыть)


Вероятно речь идёт о команде:
$ '/var/lib/dpkg/info/pips-sot30.postinst' -configure

(Нажмите, чтобы показать/скрыть)



Как я понял этот файл выполняет следующие команды:

(Нажмите, чтобы показать/скрыть)

(Нажмите, чтобы показать/скрыть)


sudo dpkg -L pips-sot30 | grep 'epson9.ppd epson24.ppd deskjet.ppd zebra.ppd'

(Нажмите, чтобы показать/скрыть)

Ещё поизучал скрипт.

cupsdefault_ppdfiles="epson9.ppd epson24.ppd deskjet.ppd zebra.ppd"
for cupsdefaultppd in $cupsdefault_ppdfiles; do
cupsppddir=`$Get_cups_filelist | grep $cupsdefaultppd 2`

Вывод:
grep: 2: Нет такого файла или каталога
« Последнее редактирование: 21 Март 2016, 04:14:59 от hikikomori4 »
Ubuntu 14.04.2 LTS desktop I-386.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26090
    • Просмотр профиля
Re: пакет pips-sot30
« Ответ #4 : 21 Март 2016, 12:10:53 »
А его и не может быть…
Дурдом а не команда.
Возможно, они имели в виду "2> /dev/null" ?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн hikikomori4

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
  • Начинающий пингвин
    • Просмотр профиля
Re: пакет pips-sot30
« Ответ #5 : 21 Март 2016, 14:32:05 »
Пардон, это я забыл стереть. убирал в скрипте пустой вывод, чтобы посмотреть что происходит.

В оригинале    cupsppddir=`$Get_cups_filelist | grep $cupsdefaultppd 2>/dev/null`   

И разумеется тот же эффект.
Ubuntu 14.04.2 LTS desktop I-386.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26090
    • Просмотр профиля
Re: пакет pips-sot30
« Ответ #6 : 21 Март 2016, 15:05:00 »
Добавьте в начале скрипта
set -x
и смотрите, что реально происходит.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн hikikomori4

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
  • Начинающий пингвин
    • Просмотр профиля
Re: пакет pips-sot30
« Ответ #7 : 21 Март 2016, 15:26:53 »
(Нажмите, чтобы показать/скрыть)

postinst failed to install PPD file

Только мне это мало говорит, что делать.(
Ubuntu 14.04.2 LTS desktop I-386.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26090
    • Просмотр профиля
Re: пакет pips-sot30
« Ответ #8 : 21 Март 2016, 15:45:29 »
Похоже, это ч[удо] пытается поставить то, чего у него нет.
И почему /usr/local?
Если тебе этот пакет не нужен, или есть более новая версия, я бы заблокировал prerem скрипт, вписав в начале exit 0, и убил пакет через --purge
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн hikikomori4

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
  • Начинающий пингвин
    • Просмотр профиля
Re: пакет pips-sot30
« Ответ #9 : 21 Март 2016, 19:41:01 »
Этот пакет поставился драйвером принтера. Принтер работает, но пакет при каждом обращении к обновлениям сообщзает о своей ошибке... Раньше этого не было.
А как убить пакет через пурж? Хвостов не останется?
Ubuntu 14.04.2 LTS desktop I-386.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26090
    • Просмотр профиля
Re: пакет pips-sot30
« Ответ #10 : 21 Март 2016, 19:58:49 »
apt-get remove --purge
Нет, хвостов после этого обычно не остаётся.
Судя по тому, что вы уже пытались удалять, и он за собой ничего не потянул, пакет не является обязательным.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн hikikomori4

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
  • Начинающий пингвин
    • Просмотр профиля
Re: пакет pips-sot30
« Ответ #11 : 21 Март 2016, 20:05:54 »
(Нажмите, чтобы показать/скрыть)

И всё, выход в консоль без каких-либо сбщ. Все файлы на месте. Вероятно, он всё же должен отработать?
Ubuntu 14.04.2 LTS desktop I-386.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26090
    • Просмотр профиля
Re: пакет pips-sot30
« Ответ #12 : 21 Март 2016, 20:11:54 »
Ну тогда ищите, куда поставить заглушку…
У меня этого пакета нет в репах, ничем помочь не могу.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн hikikomori4

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
  • Начинающий пингвин
    • Просмотр профиля
Re: пакет pips-sot30
« Ответ #13 : 21 Март 2016, 20:16:38 »
Ubuntu 14.04.2 LTS desktop I-386.

 

Страница сгенерирована за 0.061 секунд. Запросов: 24.