Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: В Ubuntu 16.04 не будет проприетарного драйвера AMD.  (Прочитано 10029 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pilot6

  • Автор темы
  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
http://www.phoronix.com/scan.php?page=news_item&px=Ubuntu-16.04-Dropping-fglrx

Интересно почему? И будут большие проблемы у новичков.
Установка из файлов достаточно проблемна.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Tamer4

  • Активист
  • *
  • Сообщений: 696
    • Просмотр профиля
По-моему эта ситуация возникла из-за отсутствия поддержки АМД, возможно до 21 апреля АМД еще исправят ситуацию. А может уже будет разделение открытого драйвера и проприетарных настроек как обещали.

Оффлайн Pilot6

  • Автор темы
  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Там пишут, что АМД проделала большую работу над свободным драйвером. И даже будет Catalyst для свободных. Но не сейчас, и не со всем функционалом.

Это при том, что будут драйверы на сайте АМД. Зачем же проблемы создавать?
Я все равно никогда не буду связываться с этими адаптерами, но как-то странно. Неужели так сложно собрать из драйверов на сайте в репозиторий?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1476
  • ubuntu 18.04
    • Просмотр профиля
Неужели так сложно собрать из драйверов на сайте в репозиторий?
Это как раз самое простое.
А вот отвечать за получившийся глюкодром...

Оффлайн thunderamur

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 6748
  • Ubuntu 16.04
    • Просмотр профиля
И по делом, блоб глючный. Нужен только из-за большего ФПС в играх, пусть свободный допиливают.

В 16.04 не будет ещё по этой причине:

Цитировать
Одной из причин, которые помешают просто установить драйвер с официального сайта, станет тот факт, что Ubuntu 16.04 имеет X-server 1.18 и ядро Linux версии 4.4, тогда как официальные Linux-драйверы от AMD поддерживают максимум X-server 1.17 и ядра до 3.19. Таким образом, поддержка банально не имеет смысла. Кроме этого, поддержка старых видеокарт скоро будет удалена из драйвера. Планируется удалить драйверы, связанные с Radeon HD 8000 (HD 8400 и ниже), Radeon HD 7000 Series (HD 7600 и ниже), Radeon HD 6000, Radeon HD 5000 и другими картами, которые не используют архитектуру GCN.

Отметим, что в открытых драйверах пока тоже не всё гладко — отсутствует поддержка OpenGL 4.5 (есть только OpenGL 4.1), ниже производительность, неполная поддержка OpenCL и отсутствие CrossFire multi-GPU.

С другой стороны, это явно укладывается в стратегию GPUOpen от AMD, которая подразумевает постепенный отказ от проприетарных драйверов. Возможно такой подход будет оправдан в будущем, когда тот же API Vulkan станет стандартом де-факто.

http://www.3dnews.ru/929739

Источник, конечно,  так себе. Сам не проверял инфу, но как минимум про ядро не совсем так, на 4.2 точно блоб ставится, хотя на сайте AMD действительно заявлено о поддержке максимум до 3.19. А вот из-за xserver более нового действительно могут быть траблы.

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1476
  • ubuntu 18.04
    • Просмотр профиля
По-моему эта ситуация возникла из-за отсутствия поддержки АМД, возможно до 21 апреля АМД еще исправят ситуацию. А может уже будет разделение открытого драйвера и проприетарных настроек как обещали.
К лету AMD обещает. Ну и да, с того момента как AMD исправит ситуацию, Canonical не может оперативно и сразу среагировать. Олсо, заморозка нововведений для ubuntu 16.04 где-то щас и произошла.
« Последнее редактирование: 13 Март 2016, 17:29:06 от soarin »

Оффлайн lin_user

  • Старожил
  • *
  • Сообщений: 1292
    • Просмотр профиля
Я два раза с интервалом в несколько лет пытался использовать карты AMD и проклял всё на свете. У меня есть сомнения, что AMD в обозримом будущем допилит драйвер до состояния вменяемости и высокой производительности. Не понимаю, что все эти годы мешает им сделать полноценный драйвер, сравнимый с блобом невидии.

Оффлайн Tamer4

  • Активист
  • *
  • Сообщений: 696
    • Просмотр профиля
lin_user,
Драйвер то они начали пилить хороший, только для винды. Я вот год не пользовался, вот пришлось поставить, так в некторых играх в сравнении с драйверами 2015 года +20-50 фпс, а линукс может хотят как заявляли раньше запилить сначала открытый драйвер (который в 16.04 работает отлично), а потом уже свои закрытые надстройки будут делать. Посмотрим.

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1182
  • Ubuntu 14.04 LTS
    • Просмотр профиля
Если опенсорсный драйвер будут дорабатывать, то для сравнительно новых карт. Пользователи старых моделей вряд ли получат нормальный открытый драйвер в новых версиях ОС. У меня сейчас Ubuntu установлена на старом ноуте с HD3200 на открытых драйверах Gallium 0.4. Вроде как работают, но ноут жарится до 95-100 градусов. А проприетарный уже не поставишь. Всё, финиш. А когда-то Linux был тем и хорош, что мог оживить старое железо.

Оффлайн Tamer4

  • Активист
  • *
  • Сообщений: 696
    • Просмотр профиля
С открытым драйвером вроде стало лучше в мелочах, например Unity 7 стала намного отзывчивее, в firefox в полноэкранном режиме интерфейс html5 плеера перестал тормозить, перестали появляться артефакты иногда во всплывающих окнах.
Но его не понимают многие игры, считающие, что драйвер поддерживает только OpenGL 3.0. Хотя 4.1 работает, только в CS:GO. Кстати fps тоже вырос с 80-120 на проприетарном в 14.04 до 150-170 на свободном в 16.04 на максимальных настройках.
War Thunder вылетает, хотя это может из-за бета версии Ubuntu.
Dying Light предупреждает, что у меня OpenGL 3.0, а ему нужно минимум 3.3, запускается, но с черным экраном, есть звук, (можно на ощупь запустить игровой процесс).
Кстати может кто знает как играм нужную строчку из glxinfo подсунуть?
Цитировать
tamer@tamer-linux:~$ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD TAHITI (DRM 2.43.0, LLVM 3.9.0)
OpenGL core profile version string: 4.1 (Core Profile) Mesa 11.3.0-devel (padoka PPA)
OpenGL core profile shading language version string: 4.10
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 11.3.0-devel (padoka PPA)
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 11.3.0-devel (padoka PPA)
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

Оффлайн hardir

  • Участник
  • *
  • Сообщений: 124
  • open source рулит
    • Просмотр профиля
    • маленький блог бедного программера
Подтверждая War Thunder вылетает. Ядро обновлял до 4.6 - ничего не изменилось.
Короче - прощайте гульки... :(

Оффлайн Tamer4

  • Активист
  • *
  • Сообщений: 696
    • Просмотр профиля
Добавили поддержку OpenGL 4.2
tamer@tamer-desktop:~$ glxinfo | grep core
    Preferred profile: core (0x1)
    Max core profile version: 4.2
OpenGL core profile version string: 4.2 (Core Profile) Mesa 11.3.0-devel (padoka PPA)
OpenGL core profile shading language version string: 4.20
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:

Оффлайн thunderamur

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 6748
  • Ubuntu 16.04
    • Просмотр профиля
Tamer4, куда добавили? ядро 4.6?

Пользователь добавил сообщение 10 Май 2016, 06:05:04:
Я сейчас в Euro Truck Simulator 2 катаю иногда, т.к. на свободном он сейчас прекрасно работает.

Оффлайн Tamer4

  • Активист
  • *
  • Сообщений: 696
    • Просмотр профиля
thunderamur, В Mesa добавили, версия 11.3. Ядро 4.4.

Пользователь добавил сообщение 10 Май 2016, 06:17:22:
Хотя может и в предыдущие тоже, я Mesa беру с отдельного репозитория padoka PPA
« Последнее редактирование: 10 Май 2016, 06:17:22 от Tamer4 »

Оффлайн BaaTLT

  • Заслуженный пользователь
  • Локальный модератор
  • Активист
  • *
  • Сообщений: 540
  • Выключи компьютер и ЖИВИ !!!
    • Просмотр профиля
Очень странный файл  создан АМД.

Для установки и оптимальной работы проприетарного графического драйвера AMD Catalyst™ для ОС Linux необходимо установить следующие пакеты:
gimp-help-en
gimp-help-common.....

Как эти пакеты связаны с драйвером? Что разработчики курили?

Системные требования
Перед установкой проприетарного графического драйвера AMD Catalyst™ для ОС Linux необходимо установить следующее программное обеспечение:
Xorg/Xserver версии 7.4 и выше (до 1.17)
Ядро Linux 2.6 или выше (до 3.19)
glibc версии 2.2 или 2.3
Для работы 3D-приложений требуется поддержка общей памяти POSIX (/dev/shm)

Для 16.04 не подходит.
« Последнее редактирование: 10 Май 2016, 07:27:54 от BaaTLT »

 

Страница сгенерирована за 0.07 секунд. Запросов: 25.