Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Артефакты и самопроизвольная перезагрузка системы  (Прочитано 922 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн yots2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Привет всем. После 10-летнего использования Windows-XP решил установить Ubuntu, выделив для этого отдельные логические тома для / -root, swap и /home, в соответствии со всеми рекомендациями, указанными в разделе помощи. После первого же запуска и нескольких минут работы на экране появились "артефакты" в виде горизонтальных полос на весь экран, так что разглядеть практически ничего невозможно. Методом тыка определил, что если нажать на то место, где "Поиск на компьютере и в интернете", данное явление полностью или почти полностью пропадает. Иногда, сразу же за появлением артефактов следует перезагрузка компьютера. Закономерности во времени появления данных глюков не прослеживается. Погуглив несколько дней, я пришел к выводу, что это связано с видеокартой, а именно с драйверами к ней, но что делать, ума не приложу, так как мои знания в Linux приближаются к нулю. Если кто-то знает, как решить проблему, дайте ссылку на инструкцию. Вот мои параметры системы:

Hardware:
Processor: Intel Pentium D @ 3.00GHz (2 Cores), Motherboard: Intel D945GCL, Chipset: Intel 82945G/GZ/P/PL + ICH7, Memory: 2048MB, Disk: 165GB Hitachi HDT722516DLA380 + 2000GB TOSHIBA DT01ACA2, Graphics: Intel 82945G/GZ IGP, Audio: SigmaTel STAC9221 A1, Network: Intel PRO/100

Software:
OS: Ubuntu 14.04, Kernel: 4.2.0-30-generic (x86_64), Desktop: Unity 7.2.6, Display Server: X Server 1.17.2, Display Driver: intel 2.99.917, Compiler: GCC 4.8, File-System: ext4, Screen Resolution: 1280x1024

Версия Ubuntu:
No LSB modules are available.
Distributor ID:   Ubuntu
Description:   Ubuntu 14.04.4 LTS
Release:   14.04
Codename:   trusty

Ядро:
4.2.0-30-generic

Сетевая карта:
04:08.0 Ethernet controller [0200]: Intel Corporation PRO/100 VE Network Connection [8086:1094] (rev 01)
   Subsystem: Intel Corporation Device [8086:0001]
   Kernel driver in use: e100

Видеокарта:
00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)
   Subsystem: Intel Corporation Device [8086:4c43]
   Kernel driver in use: i915

Звуковая карта:
00:1b.0 Audio device [0403]: Intel Corporation NM10/ICH7 Family High Definition Audio Controller [8086:27d8] (rev 01)
   Subsystem: Intel Corporation Device [8086:0204]
   Kernel driver in use: snd_hda_intel

Ошибки из журнала Xorg (насколько я понял, надо использовать комманду:
cat /var/log/Xorg.0.log | egrep -i "(WW|EE|NI)"):
(Нажмите, чтобы показать/скрыть)

Ошибки из системного журнала (я указываю за последний день):
(Нажмите, чтобы показать/скрыть)

P.S. Пока писал это сообщение, компьютер перегрузился раза 2-3, и несколько раз колбасило изображение. Ввиду этого логи указал только за сегодня,- думаю, этого вполне достаточно.
« Последнее редактирование: 14 Март 2016, 16:28:08 от yots2 »

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
yots2,
судя по симптомам дело в видеокарте.

Оффлайн yots2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Думаете, приказала долго жить материнская плата (видеокарта встроенная), или можно подобрать более оптимальные драйвера?

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
yots2,
дело в том что в дистрибутив УЖЕ включенные драйвера для Интел. Google говорит что эта карта не только у вас имеет проблемы:
https://www.google.com/search?q=82945G%2FGZ+Integrated+Graphics+Controller+8086%3A2772+freeze+ubuntu&ie=utf-8&oe=utf-8&client=ubuntu&channel=fs&gfe_rd=cr&ei=ItDmVu7-FI2BsAGzurX4Aw&gws_rd=ssl

Оффлайн DimanBG

  • Старожил
  • *
  • Сообщений: 1033
    • Просмотр профиля
wajnon, ты хотя бы смотрел сколько лет этим постам и в каких версиях Ubuntu?
yots2,
Оптимально будет дистр 32х 12.04 Попробуй, конечно 14.04 но с ядром не выше 3.19

Оффлайн yots2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
DimanBG, 32х 12.04 LTS работает у меня уже час, глюков никаких не наблюдаю. Спасибо большое за помощь.


Пользователь решил продолжить мысль 15 Март 2016, 16:34:10:
Вот, блин, нормально же всё работало несколько часов. Установил Chromium, Opera, Krusader, Skype. Всё как по нотам, без нареканий. Нажал в Опере "Инспектировать элемент", чтоб скопировать класс элемента страницы, как БАЦ!... и перезагрузка. Так пробовал несколько раз, и каждый раз то же самое в том же месте. Может, у меня действительно что-то с материнской платой (10 лет, всё-таки). Спасибо всем, кто не пройдёт мимо.

Hardware (тут без изменений):
Processor: Intel Pentium D @ 3.00GHz (2 Cores), Motherboard: Intel D945GCL, Chipset: Intel 82945G/GZ/P/PL + ICH7, Memory: 2048MB, Disk: 165GB HDT722516DLA380 + 2000GB TOSHIBA DT01ACA2, Graphics: Intel 82945G/GZ IGP, Audio: SigmaTel STAC9221 A1, Network: Intel PRO/100

Software (установил версию постарше, полностью заново диска):
OS: Ubuntu 12.04, Kernel: 3.13.0-83-generic (i686), Desktop: Unity 5.20.0, Display Server: X Server 1.15.1, Display Driver: intel 2.99.910, Compiler: GCC 4.6, File-System: ext4, Screen Resolution: 1280x1024

фрагмент SYSLOG:
Mar 15 14:35:07 user-desktop gnome-session[1542]: Gdk-WARNING: gnome-session: Fatal IO error 11 (Ресурс временно недоступен) on X server :0.#012
Mar 15 14:35:09 user-desktop kernel: [ 1967.036091] gnome-settings-[2696]: segfault at 0 ip b4795c40 sp bfd37c30 error 4 in libxsettings.so[b4792000+9000]

XORG:
[  2712.406] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  2712.406] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[  2712.406] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[  2712.406] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[  2712.406] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[  2712.517] (WW) Falling back to old probe method for modesetting
[  2712.517] (WW) Falling back to old probe method for fbdev
[  2712.553] (WW) Falling back to old probe method for vesa
« Последнее редактирование: 15 Март 2016, 16:34:11 от yots2 »

Оффлайн yots2

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Закрываю тему. Такое наблюдается только в Опере, поэтому считаю это багом Оперы.

 

Страница сгенерирована за 0.061 секунд. Запросов: 24.