Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Перестал видеть Wi-fi адаптер и сетевую карту  (Прочитано 1097 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Shevcov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Возникла такая проблема. Ноут Acer aspire 5315. Стоит система Ubuntu 14.04 lts. Всё работало и было нормально. Потом отвалилось вай-фай соединение и в инет перестал, соответственно, выходить. Полезли разбираться. Система не видит оборудования. При подаче команды в терминале ifconfig -a видит только петлю и ничего больше. При подаче команды lspci  видит кучу оборудования и в том числе обе сетевые карты и проводную и беспроводную. Беспроводная Broadcom BCM4312, а проводная BCM5932. Итог такой. Пробывал устанавливать для вай-фай адаптера разные версии bc43-installer.deb - не помогло. Скачал с офф сайта драва на bcm4312, но скомпилировать не смог их, выдаёт ошибку и никак не может найти какой-то файл, которого и в помине в папке с дровами и нет. В общем, прошу подсказать как оживить обе броадкомовские карты, которые взяли и легли не понятно с чего.

alex_ander

  • Гость
со старым ядром не пробовал загрузиться?
есть подозрение что обновилось ядро и слетели драйверы

тебе надо:
1. Попасть в grub. ЕСли у тебя только Ubuntu на компе, то нажми и удерживай Shift в начале загрузки
2. Выбрать вторую строку - "Другие варианты загрузки Ubuntu"
3. Выбрать там какое либо из предидущих ядер
4. Нажать Enter

Если я угадал и тебе повезёт - заработает вай-фай

Оффлайн Shevcov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Да, спасибо. Помогло. Но как теперь поставить по умолчанию в grub загрузку с предыдущей версией ядра?

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Shevcov,
Можно просто удалить последнее ядро. Но это плохое решение проблемы.
Дело скорее всего не в ядре, а в том что драйвер под новое ядро не собирается.
Дайте вывод

lspci -knn | grep Net -A2

и сообщите что за ядра с которым запускается и с которым нет.

Еще дайте вывод

dkms status

Пользователь решил продолжить мысль 19 Март 2016, 14:49:04:
На самом деле что произошло понятно. bcmwl заблеклистил проводную карту, а потом под новое ядро не собрался.
Что-то типа этого.
« Последнее редактирование: 19 Март 2016, 14:49:04 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26086
    • Просмотр профиля
Да, спасибо. Помогло. Но как теперь поставить по умолчанию в grub загрузку с предыдущей версией ядра?
Какая именно предыдущая и с какой не работает?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Shevcov

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Не работали сетевые адаптеры при загрузке (как оказалось позднее на ядре 3.13.0-71). Пошел по пути наименьшего сопротивления и, как посоветовали, поменял ядро при загрузке в GRUB. Загрузился с версии 3.13.0-68. Всё заработало обратно, в смысле оба адаптера и проводной и беспроводной. Удалил через Synaptic ядро 3.13.0-71 и тем самым выставилось по умолчанию загрузка с 3.13.0-68. Думаю, тему можно закрывать, так проблему разрешил. Спасибо за помощь.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Ничего вы толком не решили. Надо просто драйвер обновить видимо под новое ядро. Но дело ваше.
Я в личке не консультирую. Вопросы задавайте на форуме.

alex_ander

  • Гость
Shevcov,
дело в том, что Pilot6 абсолютно прав, это абсолютно не решение.
1. При ближайшем обновлении ядро поставится вновь. Поэтому необходимо по крайней мере зафиксировать версию пакета ядра.
2. Но это тоже не лучший вариант. И очень вероятно, что уважаемый Pilot6 поможет оешить тебе проблему, если ты будешь отвечать на его вопросы.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26086
    • Просмотр профиля
3,13 на 14.04 ? Хотя бы 3,19 уже что ли. Лучше вообще 4.2 или выше.
Велика вероятность, что там дрова более сухие.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.056 секунд. Запросов: 24.