Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Pulseaudio, или ещё одна кривая попытка его удалить с последствиями.  (Прочитано 1647 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 12345

  • Автор темы
  • Новичок
  • *
  • Сообщений: 26
    • Просмотр профиля
#стыдобища
Началось всё с попытки настроить wine, чтобы тот работал. Один товарищ выложил список нужного для установки при помощи winetricks. Среди всего прочего значился проигрыватель windows, который и установился без проблем. Однако звук пропал весь. Вместо того, чтобы почитать форума, я тупанула и удалила пульсаудио, чтобы его, пульсаудио, переустановить. К чему это приводит я, увы, не прочитала. Звук не починился, естественно, в настройках системы почти всё попропадало. Настройки системы починила, написав sudo apt-get install ubuntu-desktop . Установила пульсаудио, но звук не появлялся. Пробовала пофиксить систему командами sudo apt-get updateи sudo apt-get update --fix-missing Тоже не помогло. Пыталась искать на форумах, как вернуть обратно звук, но ничего сработавшего не нашла. Наверное, плохо искала. Резервные копии не делала, есть livecd-флешка, с которой была произведена установка.
Есть варианты, что делать? Ubuntu 14.04 LTS.


Конфигурация
(Нажмите, чтобы показать/скрыть)

Звук
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 25 Март 2016, 22:52:20 от 12345 »

Оффлайн .human

  • Участник
  • *
  • Сообщений: 146
    • Просмотр профиля
сделайте так


sudo nano /etc/asound.conf


и вставьте туда это

defaults.pcm.card 1
defaults.pcm.device 0


сохраните и перезагрузитесь и должно быть вам счастье

Оффлайн 12345

  • Автор темы
  • Новичок
  • *
  • Сообщений: 26
    • Просмотр профиля
Увы, счастье не настало. Сделала, строчек там действительно не было, после исправления-сохранения-перезагрзки звука по-прежнему нет Есть варианты, что по-прежнему мешает виндовсовый плеер, всё ещё висящий в системе. Впрочем, я не специалист, посему после инцендента туда и не лезла и больше ничего не удаляла.
« Последнее редактирование: 26 Март 2016, 00:06:42 от 12345 »

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
12345,
с гостя есть?

Оффлайн .human

  • Участник
  • *
  • Сообщений: 146
    • Просмотр профиля
у вас установлен пакет alsa-base?
если нет ,то установите и там нужно посмотреть в alsamixer что у вас включено
« Последнее редактирование: 26 Март 2016, 00:35:27 от .human »

Оффлайн 12345

  • Автор темы
  • Новичок
  • *
  • Сообщений: 26
    • Просмотр профиля
Нет, на госте тоже звука нет.
Alsa-base установлен.
А вот смотреть, что там, не умею.

Написала что могла:
(Нажмите, чтобы показать/скрыть)

Пользователь решил продолжить мысль 26 Март 2016, 13:33:12:
И тишина...
« Последнее редактирование: 26 Март 2016, 13:33:12 от 12345 »

Оффлайн .human

  • Участник
  • *
  • Сообщений: 146
    • Просмотр профиля
вот мой скрин с ноута



по крайней мере две крайние позиции слева у вас должны быть включены,если вкл и не помогает можно переустановить пакет pulse полностью,но для начала установите пакет pavucontrol и проверьте  звук,если не появиться,переустановите пакет pulse,после чего по идее должен появиться звук ,если нет,то в  pavucontrol выберете свой канал  вывода звука .(для примера у меня на стационаре выбран аналоговый выход).А вообще здесь тема в этом плане интересная ,уже очень давно ставлю Ubuntu только с нетинсталл и часто бывает что приходится применять разные приемы для заведения звука.Иногда обходишься только пакетом alsabase+/etc/asound,а иногда приходится ставить пакеты pavucontrol и pulse ,чтобы все завести.Так что пробуйте и посмотрим что будет.
« Последнее редактирование: 26 Март 2016, 14:48:53 от .human »

Оффлайн 12345

  • Автор темы
  • Новичок
  • *
  • Сообщений: 26
    • Просмотр профиля
« Последнее редактирование: 26 Март 2016, 14:52:55 от 12345 »

Оффлайн .human

  • Участник
  • *
  • Сообщений: 146
    • Просмотр профиля
пробуем как я вам написал

Оффлайн 12345

  • Автор темы
  • Новичок
  • *
  • Сообщений: 26
    • Просмотр профиля
Ок, сейчас, у меня интернет медленный =)
Master и headphone включены, если именно это означает значок mm, a звука нет. Если включены - это 00, то звука всё равно нет. Pavucontrol установлен. Канал для вывода звука у меня оказался ну оч интересный: Port: HDMI/Display port (unplugged)
« Последнее редактирование: 26 Март 2016, 15:07:45 от 12345 »

Оффлайн .human

  • Участник
  • *
  • Сообщений: 146
    • Просмотр профиля
вот скрин pavucontrol








« Последнее редактирование: 26 Март 2016, 15:05:51 от .human »

Оффлайн 12345

  • Автор темы
  • Новичок
  • *
  • Сообщений: 26
    • Просмотр профиля
Master и headphone включены, если именно это означает значок mm, a звука нет. Если включены - это 00, то звука всё равно нет. Pavucontrol установлен. Канал для вывода звука у меня оказался ну оч интересный: Port: HDMI/Display port (unplugged)

Как КОРРЕКТНО переустановить pulseaudio?

Пользователь решил продолжить мысль [time]26 Март 2016, 16:18:11[/time]:
Вот что показано на вкладке "Проигрывание":


Пользователь решил продолжить мысль 26 Март 2016, 15:19:49:
А вот что - в "Устройствах вывода":
« Последнее редактирование: 26 Март 2016, 15:19:52 от 12345 »

Оффлайн .human

  • Участник
  • *
  • Сообщений: 146
    • Просмотр профиля
да как и обычно sudo aptitude reinstall pulseaudio

Оффлайн 12345

  • Автор темы
  • Новичок
  • *
  • Сообщений: 26
    • Просмотр профиля
sudo: aptitude: command not found

При замене aptitude на apt-get говорит:

E: Неверная операция reinstall

Оффлайн .human

  • Участник
  • *
  • Сообщений: 146
    • Просмотр профиля
тогда apt-get install pulseaudio тем более кажется вы его удаляли

Пользователь решил продолжить мысль 26 Март 2016, 15:30:45:
aptitude  у вас видно не установлен
« Последнее редактирование: 26 Март 2016, 15:30:45 от .human »

 

Страница сгенерирована за 0.057 секунд. Запросов: 24.