Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: 15.10 (4.4.6) не видит TP-LINK WN727N  (Прочитано 1185 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн madd.ru

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
15.10 (4.4.6) не видит TP-LINK WN727N
« : 26 Март 2016, 12:00:33 »
Привет. Помогите плз.

Есть
Ubuntu 15.10  и старая добрая ASUS WiFi-G (модель не помню, дальше в логах понятно будет)
Всё работает, но захотелось чтобы вафля побыстрее работала... прикупил свисток TP-LINK WN727N


Обновил ядро:

Linux Desktop-Home 4.4.6-040406-generic #201603161231 SMP Wed Mar 16 16:59:04 UTC 2016 i686 i686 i686 GNU/Linux


но этот свисток так и не подхватывается как ВиФИ... в Винде работает (к тому что свисток рабочий).

Вот что в показывает система...

lsusb
(Нажмите, чтобы показать/скрыть)


lsmod
(Нажмите, чтобы показать/скрыть)


iwconfig
(Нажмите, чтобы показать/скрыть)




помогите завести свисток в линухах...

« Последнее редактирование: 26 Март 2016, 12:04:09 от madd.ru »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Re: 15.10 (4.4.6) не видит TP-LINK WN727N
« Ответ #1 : 26 Март 2016, 12:12:57 »
madd.ru,
Ядро обновлять на mainline смысла не было. Я бы посоветовал его удалить и оставить родное ядро 4.2
Нужно драйвер поставить вот так

sudo apt-get install git build-essential
git clone https://github.com/Myria-de/mt7610u_wifi_sta_v3002_dpo_20130916.git
cd mt7610u_wifi_sta_v3002_dpo_20130916
sudo make install
sudo cp RT2870STA.dat  /etc/Wireless/RT2870STA/RT2870STA.dat

После каждого обновления ядра придется выполнять

cd mt7610u_wifi_sta_v3002_dpo_20130916
sudo make install

если только не собрать dkms пакет.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн madd.ru

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: 15.10 (4.4.6) не видит TP-LINK WN727N
« Ответ #2 : 26 Март 2016, 12:26:42 »
Pilot6,
Спасибо посмотрю, но не хотелось бы какие-то костыли использовать. Ведь прилетит обновление ядра и всё... привет.. опять ставить драйвер.

я похожую установку уже делал, много в сети вопрос-ответ как запустить этот свисток. Но в оф.драйвере написано
(Нажмите, чтобы показать/скрыть)


А вообще хотелось бы чтобы "из коробки" заводилось.... почему не подтягивается? если ли нормальный путь?

Пользователь решил продолжить мысль 26 Март 2016, 12:30:53:
Pilot6,
кстати 4.4.6 уже stable
« Последнее редактирование: 26 Март 2016, 12:30:53 от madd.ru »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Re: 15.10 (4.4.6) не видит TP-LINK WN727N
« Ответ #3 : 26 Март 2016, 12:36:54 »
madd.ru,
Цитировать
Спасибо посмотрю, но не хотелось бы какие-то костыли использовать. Ведь прилетит обновление ядра и всё... привет.. опять ставить драйвер.
Можете не ставить. Тогда свисток работать не будет ))) Ядро этот чип не поддерживает, и вряд ли будет поддерживать в обозримом будущем.
Если не хотите ставить драйвер руками, то устанвоите его с помощью dkms.  Тогда он при обновлении будет сам собираться, как это делают другие сторонние драйверы.

Цитировать
кстати 4.4.6 уже stable
Вот вы себе сами противоречите. С одной стороны, не хотите ставить сторонний драйвер, чтобы руками его не переустановливать.
С другой стороны, ставите не поддерживаемое в Ubuntu ядро и хотие его постоянно руками обновлять.

В Ubuntu другая политика с ядрами. Важные обновления безопасности, исправления багов, добавление нового железе в разумных пределах производится путем бэкпортирования патчей из ядер в mainline. Таким образом, имея штатное ядро 4.2, вы будете получать нужные фиксы из более поздних ядер. При этом будете получать эти обновления нормальным образом.

Цитировать
Но в оф.драйвере написано
На заботе тоже написано.

Пользователь решил продолжить мысль [time]26 Март 2016, 12:39:27[/time]:
Посмотрел в исходники ядра. Действительно появился этот драйвер в 4.2. Скорее всего дело в firmware.
Сейчас посмотрю что там и как.

Пользователь решил продолжить мысль [time]26 Март 2016, 12:44:32[/time]:
Был не прав. Достаточно положить файл mt7601u.bin в /lib/firmware

Файл сами найдете? Он есть, например в пакете linux-firmware для xenial. В пакет для 15.10 пока не положили.
« Последнее редактирование: 26 Март 2016, 12:45:23 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн madd.ru

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: 15.10 (4.4.6) не видит TP-LINK WN727N
« Ответ #4 : 26 Март 2016, 12:49:17 »
Pilot6,
Спасибо!
я найду, но если есть возможность положите ссылочку здесь, чтобы другим помощь была.

Ещё раз спасибо!

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Re: 15.10 (4.4.6) не видит TP-LINK WN727N
« Ответ #5 : 26 Март 2016, 12:51:13 »
madd.ru,
Ну можно просто скачать пакет linux-firmware

http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.157_all.deb

и достать оттуда этот файл. Ну или просто сам пакет поставить, но могут быть нюансы, так как он предназначен для 16.04. Где-то могли измениться имена файлов, пути, номера версий и т.п. Но проблемы маловероятны. Я бы просто файл достал.
Я в личке не консультирую. Вопросы задавайте на форуме.

 

Страница сгенерирована за 0.066 секунд. Запросов: 24.