Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: После обновления до 16.04 черный экран HD 7480D  (Прочитано 4709 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн aleks-nl5

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
    • Просмотр профиля
Добрый день!
Друзья, прошу помощи - после обновления с 15.10 до 16.04 драйвер видеокарты перестал корректно работать, читал про прекращение поддержки fglrx, но его я не использовал на 15.10 и соответственно не ожидал проблем с видео после обновления (AMD APU A4-4000, HD 7480D).
Теперь при загрузке - чёрный экран, воспроизводится звук логина Ubuntu и больше ничего, на tty1-6 также черный экран даже курсора нет.
При добавлении параметра загрузки "nomodeset" - Ubuntu загружается, соответственно с жуткими тормозами и нагрузкой на процессор под 90%.
Если же загрузиться со старым ядром - всё летает  :)

вывод lspci -vnn | grep VGA -A 12 на старом ядре
(Нажмите, чтобы показать/скрыть)

вывод lspci -vnn | grep VGA -A 12 на новом ядре
(Нажмите, чтобы показать/скрыть)


Xorg.0.log - на старом ядре
(Нажмите, чтобы показать/скрыть)

Xorg.0.log - на новом ядре
(Нажмите, чтобы показать/скрыть)

PS. Во время одного из ребутов на новом ядре ОС завелась нормально, но перезагрузив снова (для уверенности) получил ту же проблему  :(
« Последнее редактирование: 22 Апрель 2016, 17:45:22 от aleks-nl5 »
Use Free, Be Free

Оффлайн aleks-nl5

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
    • Просмотр профиля
Решил попытать счастье и переустановил ОС с сохранением /home:
в live режиме всё работало отлично, но при первой же загрузке стало понятно, что ситуация та же, помогало добавление в строку загрузки ядра "nomodeset", но естественно система ужасно тормозила.
Решил обновить ядро при помощи UKUU, установил самое свежее стабильное ядро - 4.5.4-040504 и всё стало работать нормально, перезагружал ПК с десяток раз.
« Последнее редактирование: 17 Май 2016, 22:41:48 от aleks-nl5 »
Use Free, Be Free

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 1708
  • Kubuntu 12.04, 16.04, 18.04, 19.04
    • Просмотр профиля
... установил самое свежее стабильное ядро - 4.5.4-040504 и всё стало работать нормально, перезагружал ПК с десяток раз.

Интересно, как это объяснить? Чего такого появилось в ядре 4.5.4, чего не оказалось в ядре 4.4, но ранее в ядре 4.2 присутствовало?

Какие будут мнения у уважаемых гуру?
Я странен, а не странен кто ж? (С)

Оффлайн aleks-nl5

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
    • Просмотр профиля
Решил обновить ядро при помощи UKUU, установил самое свежее стабильное ядро - 4.5.4-040504 и всё стало работать нормально, перезагружал ПК с десяток раз.

Ради эксперимента обновился до ядра 4.6.0-040600, так же всё замечательно.

Интересно, как это объяснить? Чего такого появилось в ядре 4.5.4, чего не оказалось в ядре 4.4, но ранее в ядре 4.2 присутствовало?

Какие будут мнения у уважаемых гуру?

Я явно не гуру, но добавлю, что возможно это в какой-то степени связано с отказом от Каталиста или регрессией открытого драйвера. Видимо тут нужно листать чэнджлоги ядер, в чём я не силён...
Use Free, Be Free

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 1708
  • Kubuntu 12.04, 16.04, 18.04, 19.04
    • Просмотр профиля
Я явно не гуру, но добавлю, что возможно это в какой-то степени связано с отказом от Каталиста или регрессией открытого драйвера.
Тут явное противоречие — отказ от Каталиста был вызван как раз прогрессом открытого драйвера, как они сами (отказники) считают (я нет) и отсутствием необходимости разрабатывать новую версию Каталиста под Xserver 1.18.
Потому я о обратился к гуру — ну должен же быть на форуме хоть один человек, способный объяснить на пыльцах, что происходит. А если его НЕТ, нет Каталиста и система не заводится на текущем ядре — совсем ПЕЧАЛЬ.
Я странен, а не странен кто ж? (С)

Оффлайн alch16

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Ситуация почти такая же. Установил Ubuntu 16.04 LTS с нуля на новый диск. Графика Radeon HD 6550D. После запуска - черный экран. Помогает nomodeset в параметрах загрузки системы. Но в этом случае графика жутко тормозит.
В логах видно, что драйвер radeon система на подхватывает.
Посмотрел версию ядра - 4.4.0-хх (UKUU показывает 4.4-wily).
С помощью UKUU установил сначала 4.4.9-xenial, затем 4.4.14-xenial.
Оба ядра отлично работают - графика ожила.

Я не гуру, спецы прокомментируйте...  :idiot2:

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 1708
  • Kubuntu 12.04, 16.04, 18.04, 19.04
    • Просмотр профиля
В логах видно, что драйвер radeon система на подхватывает.

Совершенно верно - это потому, что с параметром nomodeset графика грузится на драйвере vesa, потому и жутко тормозит.
Я странен, а не странен кто ж? (С)

 

Страница сгенерирована за 0.07 секунд. Запросов: 24.