Форум русскоязычного сообщества Ubuntu


Автор Тема: При установке пакета Fpc_3.0.0 произошло "нарушение зависимостей"  (Прочитано 348 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн delphik

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Установил GDebi и через него пытался установить Lazarus.
При установке пакета Fpc_3.0.0 произошло "нарушение зависимостей" и сейчас я не могу ни какую программу поставить, ни обновиться (даже через терминал)
что делать?...

ТС не появлялся на Форуме более полугода по состоянию на 14/07/2019 (последняя явка: 16/09/2018). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 14 Июль 2019, 00:48:59 от zg_nico »

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5264
    • Просмотр профиля
скопируйте вывод выполнения под спойлером
sudo apt-get update
sudo apt-get -f install

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26618
    • Просмотр профиля
Установил GDebi и через него пытался установить Lazarus.
При установке пакета Fpc_3.0.0 произошло "нарушение зависимостей" и сейчас я не могу ни какую программу поставить, ни обновиться (даже через терминал)
что делать?...
Удалить установленный пакет. И больше не пытаться насильно впихнуть в систему пакеты от старых версий.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн delphik

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
скопируйте вывод выполнения под спойлером
sudo apt-get update
sudo apt-get -f install
Спасибо за помощь не помогло.
Пришлось периустановить ОС и заметил что "нарушение взаимосвязей" произошло после обновлений, поэтому после установки Lazarus пришлось в Synaptic заблокировать версии пакетов (чтобы не обновлялись). Теперь все норм.. 

Пользователь добавил сообщение 07 Май 2016, 06:06:17:
Удалить установленный пакет. И больше не пытаться насильно впихнуть в систему пакеты от старых версий.
Меня не устраивают приложения предложенные в «Ubuntu Software»  особенно в последней его интерпретации, когда количество приложений уменьшилось (каждый должен иметь право выбора, а это не доработка разработчиков). Да кстати в прошлых версиях «Ubuntu Software» программный пакет Lazarus входил в официально поддерживаемые пакеты.
« Последнее редактирование: 07 Май 2016, 06:06:17 от delphik »

 

Страница сгенерирована за 0.061 секунд. Запросов: 22.