Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Как поставить по дефолту Power Mizer: Max Performance в Nvidia?  (Прочитано 1782 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kalonord

  • Автор темы
  • Любитель
  • *
  • Сообщений: 86
    • Просмотр профиля
После перезагрузки постоянно слетает power mizer на auto. Это не так страшно, но всё же.

xorg.conf я у себя на нашёл (смотрел по пути /etc/X11/xorg.conf)

Можно ли сделать так, чтобы Power Mizer: Max Performance был по умолчанию, даже после перезагрузки системы?

Оффлайн τοΖεη

  • Заслуженный пользователь
  • Администратор
  • Старожил
  • *
  • Сообщений: 8615
    • Просмотр профиля
kalonord, скрипт в автозапуск?
Не знаю, как там будет в Unity, у меня это было бы примерно так:
(sleep 20 && DISPLAY=":0.0" nvidia-settings -a [gpu:0]/GPUPowerMizerMode=1) &
Вобщем, копайте в эту сторону.
# find / -iname '*τοΖεη*'
# /God's_Universe/Book_Of_Life_aka_LordJC_protected/τοΖεη
Subject description -->> Not an ideal but s@ved 4eVer. Final destination -->> Kingdom Of Heaven

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2515
    • Просмотр профиля
А у меня примерно так:

Option "RegistryDwords" "PowerMizerEnable=0x1;PerfLevelSrc=0x3322;PowerMizerDefaultAC=0x1"

Это нужно добавить в конфигурационный файл.
Я никого не сторожил!

Оффлайн kalonord

  • Автор темы
  • Любитель
  • *
  • Сообщений: 86
    • Просмотр профиля
alang, где этот конфиг находится?

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2515
    • Просмотр профиля
kalonord, /etc/X11/xorg.conf.d/20-nvidia.conf, если он там есть. Если нет, сам создай. Или запусти nvidia-settings с правами суперпользователя
sudo nvidia-settings
тогда изменения сохранятся и слетать не будут.
Я никого не сторожил!

Оффлайн kalonord

  • Автор темы
  • Любитель
  • *
  • Сообщений: 86
    • Просмотр профиля
alang, sudo nvidia-setting - не помогло.

А после создания директории с этим файлом, в который я вписал ранее вами представленную строку - после перезагрузки ловил тупо тёмный экран.

Хорошо, что смог попать в консоль и вспомнить команду rm. Удалил файл, ОС запустилась.

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2515
    • Просмотр профиля
kalonord, одной строки мало.

Section "Device"
Identifier  "Videocard0"
Driver      "nvidia"
Option     "RegistryDwords" "PowerMizerEnable=0x1;PerfLevelSrc=0x3322;PowerMizerDefaultAC=0x1"
EndSection

Примерно так.
Я никого не сторожил!

Оффлайн kalonord

  • Автор темы
  • Любитель
  • *
  • Сообщений: 86
    • Просмотр профиля
alang, Система загрузилась, но нет, не сработало.

Оффлайн Azure

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5665
  • elementaryOS 0.4 Loki, i3wm on Debian9
    • Просмотр профиля
Я решил проблему такcat ~/.xinitrc
nvidia-settings -a :0[gpu:0]/GPUPowerMizerMode=1
cat ../.config/autostart/custom-command1.desktop
[Desktop Entry]
Name[ru]=Настроить параметры GPU
Comment[ru]=Установить максимальное быстродействие
Exec=bash /home/az/.xinitrc
Icon=application-default-icon
X-GNOME-Autostart-enabled=true
Type=Application
Можно и через nvidia-settings сохранить конфигурацию и в автостарт поставить её загрузку nvidia-settings -l --config=~/.nvidia-settings-rc(но не все версии nvidia-settings сохраняют параметр GPUPowerMizerMode)
« Последнее редактирование: 13 Май 2016, 10:34:02 от Azure »
В Линукс можно сделать ВСЁ что угодно, достаточно знать КАК !

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2515
    • Просмотр профиля
kalonord, ну, поиграйся с параметрами: PerfLevelSrc=0x2222 или PowerMizerDefaultAC= 0x3 - я просто не помню навскидку, как должно быть для максимума.
Я никого не сторожил!

 

Страница сгенерирована за 0.063 секунд. Запросов: 24.