Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Не запускается ubuntu с ядром 4.4  (Прочитано 1809 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн xyprx

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
    • Просмотр профиля
Не запускается ubuntu с ядром 4.4
« : 21 Май 2016, 18:53:59 »
Создавал тему в "Установка и обновление", но когда выяснилась, что проблема в видеодрайвере - переношу сюда, может тут сидят более знающие конкретно проблему с видеодрайверами люди.
Имеется ноутбук с процессором Intel Celeron N3050. Встроенное видео. Ubuntu 14.04 с ядром Linux 4.4 не загружается (черный экран без подсветки). С nomodeset в Grub - загружается до экрана логина, дальше - только терминал. Ubuntu 16.04 - не загружалась в live-режиме (с nomodeset еще не проверял).
На сколько я понимаю, драйвер Intel HD должен быть встроен в ядро (mesa?) и несвободного драйвера Intel нет.
В связи с этим есть следущие вопросы:
Как запустить Ubuntu 14.04 с ядром 4.4, какой нужно скачать драйвер/пакет для запуска?
Как запустить и установить Ubuntu 16.04? Можно ли в него встроить "правильный" видеодрайвер?
Пока что основной вопрос - первый, заранее спасибо за помощь.

Пользователь добавил сообщение 21 Май 2016, 23:46:38:
Очень бы хотел еще спросить. У меня в системе не установлен xserver-xorg-video-intel и не хочет устанавливаться. Так и должно быть или что-то не так?
« Последнее редактирование: 21 Май 2016, 23:46:38 от xyprx »

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 1801
    • Просмотр профиля
Re: Не запускается ubuntu с ядром 4.4
« Ответ #1 : 21 Май 2016, 23:53:52 »
Если можно войти в терминале, то посмотрите /var/log/Xorg.0.log,
там должна быть указана причина, по которой не загрузился графический режим.
Пётр.

Оффлайн xyprx

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
    • Просмотр профиля
Re: Не запускается ubuntu с ядром 4.4
« Ответ #2 : 22 Май 2016, 00:16:31 »
Peter_I, вот логи загрузки и запуска Xorg.
[    60.151] (EE) FBDEV(0): FBIOBLANK: Invalid argument Что бы это могло означать? :idiot2:


Пользователь добавил сообщение 22 Май 2016, 00:29:51:
И еще, что самое странное, сайт проекта драйверов Intel для Intel HD говорит о том, что драйверов на 16.04 пока что нет "Ubuntu 16.04 - The Graphic Stack (i915) is up to date", и рабочие драйвера для самого свежего дистрибутива - только для Fedora 23. А Ubuntu 14.04 вообще лишился поддержки Intel... Хотя с другой стороны ряд людей свободно устанавливали 16.04 на мой процессор и радовались повышению производительности... https://01.org/linuxgraphics/downloads/intel-graphics-installer-linux-1.4.0
Есть ли смысл ждать релиза официального драйвера или стоит покапаться в проблеме запуска еще?
« Последнее редактирование: 22 Май 2016, 00:29:51 от xyprx »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 1529
    • Просмотр профиля
Re: Не запускается ubuntu с ядром 4.4
« Ответ #3 : 22 Май 2016, 06:00:23 »
Ubuntu 16.04, ядро 4.4.*, система инициализации systemd.
Ubuntu 14.04, ядро 3.16*-4.2.*, система инициализации в основном init+upstart и некоторые элементы systemd.
Мне кажется ubuntu 14.04 не запускается с ядром 4.4 из-за отсутствия у нее всех компонентов systemd.
Вы пишете, что система загрузилась до экрана логина. Посмотрите, над полем для ввода пароля возможно есть надпись что система что-то еще грузит.
Попробуйте установить ubuntu 16.04 с параметром nomodeset. Можно попробовать с параметром i915.modeset=1.

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 1801
    • Просмотр профиля
Re: Не запускается ubuntu с ядром 4.4
« Ответ #4 : 22 Май 2016, 09:45:40 »
Драйвер должент быть в пакете xserver-xorg-video-intel, при установке системы
устанавливаются все пакеты xserver-xorg-video-*, так что, если драйвер
из этого пакета не работает, то надо ждать, пока он появится в репозитарии или
на сайте Intel. Но он должен работать, вы же говорите, что другие устанавливали
Ubuntu-16.04 на этот процессор.
В Xorg.0.log гораздо хуже другое - что нет /dev/dri/card0.
Это значит, что драйвер не поддерживает ваш чипсет. Узнайте, какой у вас
графический чипсет и есть ли он в этом списке:
(Нажмите, чтобы показать/скрыть)
С другой стороны, если установить систему на плату с Intel и драйвер i915
не поддерживает видеочипсет, то графический режим всё равно должен запуститься,
но не помню, с каким драйвером, vesa или fbчто-то, я на одном компьютере это
наблюдаю. Смогу уточнить завтра.
« Последнее редактирование: 22 Май 2016, 16:11:42 от Peter_I »
Пётр.

Оффлайн xyprx

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
    • Просмотр профиля
Re: Не запускается ubuntu с ядром 4.4
« Ответ #5 : 22 Май 2016, 11:03:11 »
Peter_I,
Цитировать
Драйвер должент быть в пакете xserver-xorg-video-intel, при установке системы
устанавливаются все пакеты xserver-xorg-video-*, так что, если драйвер
из этого пакета не работает, то надо ждать, пока он появится в репозитарии или
на сайте Intel.
Да, xserver-xorg-video-intel установлен. И на сайте Intel указанно, что стек еще не готов... Наверное, мне не стоит так торопиться с установкой 16.04, пока Intel окончательно не выпустят стек... Но как-то странно, что некоторые обновлялись на моем-же процессоре (хоть и есть ряд людей с таким-же процессором и проблемами).
Цитировать
Узнайте, какой у вас графический чипсет и есть ли он в этом списке
Как это узнать? Вот что пишет lshw:
*-display
             описание: VGA compatible controller
             продукт: Intel Corporation
             производитель: Intel Corporation
             физический ID: 2
             сведения о шине: pci@0000:00:02.0
             версия: 21
             разрядность: 64 bits
             частота: 33MHz
             возможности: pm msi vga_controller bus_master cap_list rom
             кофигурация: [b]driver=i915[/b] latency=0
i915 судя по всему?
Цитировать
то графический режим всё равно должен запуститься
Провел эксперимент - установил Ubuntu 16.04, все в режиме "nomodeset" - установилось успешно и даже запустилось (опять-же, только в nomodeset)

Оффлайн РыжийПёс

  • Активист
  • *
  • Сообщений: 549
  • 好红狼
    • Просмотр профиля
Re: Не запускается ubuntu с ядром 4.4
« Ответ #6 : 22 Май 2016, 11:29:48 »
Более новое (ядро или вся система) ещё не означает более лучшее!
Не так давно (я уже писал об этом на форуме), после обновления 14.04 на ядро 4.2 у меня "отвалился" ТВ-тюнер. А у Вас вот отвалилась графика.
С обновлением ядра в системе появляется поддержка одних устройств, но может испортится или пропасть совсем поддержка других.
В своё время я намучился устанавливая Xubuntu на компьютер эпохи пентиум-3, пробовал и 12.04 и 10.04, а проблема была в том что система наотрез отказывалась цеплять звуковую карту, перепробовал несколько карт эпохи 90-х - ни одна не подошла (хотя и в "древних" линуксах, и даже в WinXP они цеплялись без проблем), в итоге пришлось ставить относительно новую звуковуху на PCI-слот.
Ну а в Вашем же случае, почему бы не использовать 14.04 с её родным ядром? Она будет поддерживаться ещё три года.
Увы, но у линуксов, есть одно печальное свойство - и система и железо должны быть примерно из одной эпохи, это следствие того, что большая часть драйверов уже зашита в ядре. С одной стороны - это большой плюс, но с другой, как видите, минус.
Что же касается 16.04, то возможно впоследствии (16.04.1, 16.04.2, и так далее) это проблема и будет решена, и система будет и грузиться с live-CD и устанавливаться нормально. А если нет, то может быть всё опять заработает в последующих релизах (16.10, 17.04, ...), так однажды после установки одной из подверсий панголина (кажется, 12.04.2) мой основной на тот момент компьютер тоже поприветствовал меня чёрным экраном, я тогда разозлился, и вернулся на 10.04, но в 13.04 всё уже опять заработало как надо (сейчас там 14.04).
Каждый отдельно взятый человек, перешедший на GNU Linux, приближает всё остальное человечество к Светлому Будущему.

Оффлайн xyprx

  • Автор темы
  • Новичок
  • *
  • Сообщений: 44
    • Просмотр профиля
Re: Не запускается ubuntu с ядром 4.4
« Ответ #7 : 22 Май 2016, 13:11:12 »
РыжийПёс,
Цитировать
Увы, но у линуксов, есть одно печальное свойство - и система и железо должны быть примерно из одной эпохи, это следствие того, что большая часть драйверов уже зашита в ядре.
в том-то и дело, что процессор у меня прошлого года... По идее все должно идеально поддерживаться, а тут - такое разочарование.
А в целом вы правы - остается надеятся, что это исправят в следущих пакетах обновления или LTS-релизах системы... Не хотелось бы, чтобы абсолютно новый ноутбук лишился поддержки системы всего-лишь через три года...

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 1801
    • Просмотр профиля
Re: Не запускается ubuntu с ядром 4.4
« Ответ #8 : 22 Май 2016, 16:33:26 »
i915 - это драйвер, в Xorg.0.log перечислены чипсеты, им поддерживаемые.
У этого процессора Series - Intel HD Graphics 400.
У меня AMD, я не знаю сейчас, что надо запустить, чтобы оно показало Series.
Попробуйте от root hwinfo и ту же lshw. hwinfo, возможно, надо будет установить.
Пакет, кажется, так и называется - hwinfo.
Но всё равно, если i915 не поддерживает какой-то чипсет, графический режим
должен запуститься с драйвером vesa, fbdev или ещё каким-то.
Пётр.

 

Страница сгенерирована за 0.058 секунд. Запросов: 24.