Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Откат PHP 5.5 на 5.3  (Прочитано 922 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mr.Neo

  • Автор темы
  • Участник
  • *
  • Сообщений: 162
    • Просмотр профиля
Откат PHP 5.5 на 5.3
« : 22 Май 2016, 23:01:46 »
Здравствуйте. Обновил Ubuntu 12 на 14, сайт перестал работать. Нужен старый PHP 5.3. Порылся в инете есть несколько способов, но что то как то не получается. Пробовал заменить sources.list от 12 версии, удалил php5 и потом поставил заново, но php -v все равно показывает 5.5.9. Подскажите есть рабочий способ откатится? Спасибо.
Lenovo S10-2 ubuntu-10.04 Gnome, Lenovo S110 ubuntu 12.04 Unity
Я новичок.

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14921
  • Я не слышу.
    • Просмотр профиля
Re: Откат PHP 5.5 на 5.3
« Ответ #1 : 22 Май 2016, 23:10:18 »
Цитировать
12 на 14
apache2 конфиг уже другая, должно добавить.
Require all granted
~.o

Оффлайн mr.Neo

  • Автор темы
  • Участник
  • *
  • Сообщений: 162
    • Просмотр профиля
Re: Откат PHP 5.5 на 5.3
« Ответ #2 : 22 Май 2016, 23:34:20 »
Цитировать
12 на 14
apache2 конфиг уже другая, должно добавить.
Require all granted

А куда это добавлять? Ща вообще все поломал. Сделал sudo apt-get remove --purge php* потом сменил sources.list от 12 далее sudo apt-get install php5 и все, до этого хоть работала cacti и loganaliser, только один сайт не работал, ему нужно было php 5.3. Теперь все не работает и phpmyadmin перестал открываться, вместо сайтов я так понимаю открываются какие то конфиги на php (начинаются с <?php). Что делать то? Помогайте парни.
Lenovo S10-2 ubuntu-10.04 Gnome, Lenovo S110 ubuntu 12.04 Unity
Я новичок.

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14921
  • Я не слышу.
    • Просмотр профиля
Re: Откат PHP 5.5 на 5.3
« Ответ #3 : 23 Май 2016, 00:11:36 »
mr.Neo, где ты создал файл в конфиг для apache2?
~.o

Оффлайн mr.Neo

  • Автор темы
  • Участник
  • *
  • Сообщений: 162
    • Просмотр профиля
Re: Откат PHP 5.5 на 5.3
« Ответ #4 : 23 Май 2016, 00:16:10 »
mr.Neo, где ты создал файл в конфиг для apache2?

Лично я его не где не создавал. А где он должен быть? Где посмотреть?
Lenovo S10-2 ubuntu-10.04 Gnome, Lenovo S110 ubuntu 12.04 Unity
Я новичок.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26062
    • Просмотр профиля
Re: Откат PHP 5.5 на 5.3
« Ответ #5 : 23 Май 2016, 00:16:32 »
Не проще поправить сайт?
Всего одну функцию чуть-чуть поправить.
А этот клоун вам сейчас насоветует. Он же даже не понял, что вы спросили.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн mr.Neo

  • Автор темы
  • Участник
  • *
  • Сообщений: 162
    • Просмотр профиля
Re: Откат PHP 5.5 на 5.3
« Ответ #6 : 23 Май 2016, 00:20:28 »
Не проще поправить сайт?
Всего одну функцию чуть-чуть поправить.
А этот клоун вам сейчас насоветует. Он же даже не понял, что вы спросили.
Я бы с удовольствием поправил если знал где и что, но у меня теперь и phpmyadmin не открывается и пара других сайтов. Графики cacti и сбор логов rsyslog. Как восстановить то? а потом уж буду думать как быть с тем сайтом которому нужен php 5.3.
Lenovo S10-2 ubuntu-10.04 Gnome, Lenovo S110 ubuntu 12.04 Unity
Я новичок.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26062
    • Просмотр профиля
Re: Откат PHP 5.5 на 5.3
« Ответ #7 : 23 Май 2016, 00:22:35 »
Нет 5,3 уже.
Даже 5,4 нет.
Не знаете - смотрите логи. В 5,4 убрали поддержку ereg*, надо заменить все вызовы этих функций на аналогичные preg_*
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн mr.Neo

  • Автор темы
  • Участник
  • *
  • Сообщений: 162
    • Просмотр профиля
Re: Откат PHP 5.5 на 5.3
« Ответ #8 : 23 Май 2016, 00:26:13 »
Нет 5,3 уже.
Даже 5,4 нет.
Не знаете - смотрите логи. В 5,4 убрали поддержку ereg*, надо заменить все вызовы этих функций на аналогичные preg_*
Я сейчас уже не про откат, а про то как восстановить работу того что работало после обновления с ubuntu 12 на 14, то есть пусть будет php 5.5.9 и все что есть в ubuntu 14, главное что бы заработал phpmeadmin и пару сайтов которые работали на 14.
Lenovo S10-2 ubuntu-10.04 Gnome, Lenovo S110 ubuntu 12.04 Unity
Я новичок.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26062
    • Просмотр профиля
Re: Откат PHP 5.5 на 5.3
« Ответ #9 : 23 Май 2016, 00:39:28 »
А по-моему вы потрепаться пришли.
Где логи?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн mr.Neo

  • Автор темы
  • Участник
  • *
  • Сообщений: 162
    • Просмотр профиля
Re: Откат PHP 5.5 на 5.3
« Ответ #10 : 23 Май 2016, 00:48:20 »
А по-моему вы потрепаться пришли.
Где логи?
Если бы потрепаться, в такое время, делать больше не чего. Я в этом как свинья в апельсинах. Пришел за помощью, понимаю, что Вы не сможете понять в чем дело не увидев каких то логов, каких то выводов команд, но я не знаю, что и где взять, что бы Вам показать. Было бы намного быстрее если бы Вы меня носом ткнули где взять эти логи, что бы Вам их показать. Я так понимаю, нужно как то переустановить заново apache2, php5, phpmyadmin и наверное mysql, но с базой наверное не так все просто, там же есть уже базы, их при переустановки не удалит?
Lenovo S10-2 ubuntu-10.04 Gnome, Lenovo S110 ubuntu 12.04 Unity
Я новичок.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26062
    • Просмотр профиля
Re: Откат PHP 5.5 на 5.3
« Ответ #11 : 23 Май 2016, 01:08:08 »
Тогда позовите в этот топик вашего системного администратора…
С вами разговаривать бессмысленно, вы даже не знаете, где у компьютера кнопка питания.

Системные логи в линуксе лежат все в одном месте.
/var/log/ далее по обстоятельствам.
Но это системные логи.

Логи сайтов могут быть вообще где угодно, как настроите.
Я физически не могу сказать вам, где они У ВАС лежат.
Это ваше дело - знать такие вещи.
« Последнее редактирование: 23 Май 2016, 01:09:54 от AnrDaemon »
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн mr.Neo

  • Автор темы
  • Участник
  • *
  • Сообщений: 162
    • Просмотр профиля
Re: Откат PHP 5.5 на 5.3
« Ответ #12 : 23 Май 2016, 01:22:54 »
Тогда позовите в этот топик вашего системного администратора…

Если бы он был, я бы с Вами тут не разговаривал. Он бы все и делал. Мне это не для работы, а для личного использования, поэтому пытаюсь разобраться сам в меру своих способностей и помощи с форумов.

С вами разговаривать бессмысленно, вы даже не знаете, где у компьютера кнопка питания.

Это я знаю где. :)

Системные логи в линуксе лежат все в одном месте.
/var/log/ далее по обстоятельствам.
Но это системные логи.

Там их много. Черт ногу сломает. Кикие именно смотреть?

Логи сайтов могут быть вообще где угодно, как настроите.
Я физически не могу сказать вам, где они У ВАС лежат.
Это ваше дело - знать такие вещи.

Ни чего специально не настраивал, что бы логи класть в какое то другое место.
Я просто подумал, что этого будет достаточно, что при попытке открыть localhost/phpmyadmin браузер показывает текст кода php. Вместо приглашения для входа. Попробовал поставить заново apache2, php5, phpmyadmin, mysql-sever, но ни чего не получилось пишет, что эти программы уже стоят.
Lenovo S10-2 ubuntu-10.04 Gnome, Lenovo S110 ubuntu 12.04 Unity
Я новичок.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26062
    • Просмотр профиля
Re: Откат PHP 5.5 на 5.3
« Ответ #13 : 23 Май 2016, 03:34:15 »
dpkg --list '*php5'
apache2ctl -M
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.072 секунд. Запросов: 24.