Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Не пролучается настроить 3g модем ZTE MF190  (Прочитано 1344 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sobir

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Привет!
Я новичок в Линукс.
У меня возникла проблема с настройкой модема ZTE MF190.
Пытался содать подключение через Network Manager, но оно не пашет.
Вот что выдаёт lsusb:
Bus 001 Device 002: ID 19d2:2003 ZTE WCDMA Technologies MSM
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Установил usb_modeswitch.
В конфигах нет записи с vid:pid - 19d2:2003.
:~$ tar -tf /usr/share/usb_modeswitch/configPack.tar.gz | grep 19d2:2003
:~$

Что делать?

Оффлайн wolfser2701

  • Участник
  • *
  • Сообщений: 180
    • Просмотр профиля
https://forum.ubuntu.ru/index.php?topic=275208.0
Почитай здесь, и ссылки интересные внутри есть.

Оффлайн mahinist

  • Модератор форума
  • Старожил
  • *
  • Сообщений: 2979
  • Ubuntu-18.04 , Archlinux , BlackArch , Gentoo
    • Просмотр профиля
Sobir
Цитировать
Пытался содать подключение через Network Manager, но оно не пашет.
Вот что выдаёт lsusb:
Bus 001 Device 002: ID 19d2:2003 ZTE WCDMA Technologies MSM
Установил usb_modeswitch.
В конфигах нет записи с vid:pid - 19d2:2003.
 Что делать?

Для начала , какая ОС установлена (версия) .
Что за железо - ПК , ноутбук , в  какой разъем подсоединяете модем .
Опишите каким образом создавали соединение , и как не "пашет" .
 Также перед созданием темы необходимо читать  - Правила и рекомендации по оформлению тем в разделе Поддержки
« Последнее редактирование: 26 Май 2016, 07:50:41 от mahinist »
31-регион

Оффлайн Sobir

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Sobir
Цитировать
Пытался содать подключение через Network Manager, но оно не пашет.
Вот что выдаёт lsusb:
Bus 001 Device 002: ID 19d2:2003 ZTE WCDMA Technologies MSM
Установил usb_modeswitch.
В конфигах нет записи с vid:pid - 19d2:2003.
 Что делать?

Для начала , какая ОС установлена (версия) .
Что за железо - ПК , ноутбук , в  какой разъем подсоединяете модем .
Опишите каким образом создавали соединение , и как не "пашет" .
 Также перед созданием темы необходимо читать  - Правила и рекомендации по оформлению тем в разделе Поддержки

Прошу прощения.
Железо-ноутбук.
Установлена ОС- Ubuntu 14.04, работает как виртуальная машина на VirtualBox.
Модем подключаю к разъёму USB 3.0

Что я делаю?
1) втыкаю устройство(3g usb modem ZTE MF190 с сим картой Megafon на борту) в разъём USB 3.0
2)Запускаю команду lsusb
:~$ lsusb
Bus 001 Device 003: ID 19d2:2003 ZTE WCDMA Technologies MSM
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
:~$
3)Запускаю  dmesg | tail
:~$ dmesg | tail
[ 2653.255382] option 1-1:1.3: device disconnected
[ 2653.559296] usb 1-1: reset high-speed USB device number 3 using ehci-pci
[ 2664.265542] option 1-1:1.0: GSM modem (1-port) converter detected
[ 2664.268304] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
[ 2664.268509] option 1-1:1.1: GSM modem (1-port) converter detected
[ 2664.270277] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
[ 2664.270469] option 1-1:1.2: GSM modem (1-port) converter detected
[ 2664.272902] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2
[ 2664.273051] option 1-1:1.3: GSM modem (1-port) converter detected
[ 2664.273208] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB3
:~$
Из этого делаю вывод что устройство село как модем а не как виртуальный CD-ROM
но команда dmesg | grep ZTE выводит:
:~$ dmesg | grep ZTE
[ 1440.974586] usb 1-1: Product: ZTE WCDMA Technologies MSM
[ 1440.974588] usb 1-1: Manufacturer: ZTE,Incorporated
[ 1440.974589] usb 1-1: SerialNumber: MF1900ZTED010000
[ 1442.189100] scsi 3:0:0:0: CD-ROM            ZTE      USB SCSI CD-ROM  2.31 PQ: 0 ANSI: 2
[ 2616.073844] usb 1-1: Product: ZTE WCDMA Technologies MSM
[ 2616.073846] usb 1-1: Manufacturer: ZTE,Incorporated
[ 2616.073848] usb 1-1: SerialNumber: MF1900ZTED010000
[ 3633.625971] usb 1-1: Product: ZTE WCDMA Technologies MSM
[ 3633.625976] usb 1-1: Manufacturer: ZTE,Incorporated
[ 3633.625980] usb 1-1: SerialNumber: MF1900ZTED010000
[ 3634.642422] scsi 5:0:0:0: CD-ROM            ZTE      USB SCSI CD-ROM  2.31 PQ: 0 ANSI: 2
:~$
Здесь я не понял как в итоге определилось устройство(виртуальный CD-ROM я извлёк через GUI)
4)Запускаю sudo usb_modeswitch -v 0x19d2 -p 0x2003 -K

:~$ sudo usb_modeswitch -v 0x19d2 -p 0x2003 -K
Look for default devices ...
   product ID matched
 Found devices in default mode (1)
Access device 004 on bus 001
Current configuration number is 1
Use interface number 0
Use endpoints 0x01 (out) and 0x81 (in)

USB description data (for identification)
-------------------------
Manufacturer: ZTE,Incorporated
     Product: ZTE WCDMA Technologies MSM
  Serial No.: MF1900ZTED010000
-------------------------
Sending standard EJECT sequence
Looking for active driver ...
 No active driver found. Detached before or never attached
Set up interface 0
Use endpoint 0x01 for message sending ...
Trying to send message 1 to endpoint 0x01 ...
 OK, message successfully sent
Read the response to message 1 (CSW) ...
 Response reading failed (error -7)
 Device is gone, skip any further commands
-> Run lsusb to note any changes. Bye!
Смотрю в lsusb, но там vid:pid не изменились
:~$ lsusb
Bus 001 Device 004: ID 19d2:2003 ZTE WCDMA Technologies MSM
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
:~$

5)Захожу в Network Manager и создаю новое подключение Mobile Broadband и задаю параметры

Ставлю галочки в Network Manager на Enable Mobile  Broadband и New Mobile Broadband Connection, но соединения не появляется

6)Запускаю Modem Manager GUI и вижу

Вкладка Info

Захожу во вкладку USSD получаю ошибку

При попытке включить

Оффлайн wolfser2701

  • Участник
  • *
  • Сообщений: 180
    • Просмотр профиля
Цитировать
Looking for active driver ...
No active driver found. Detached before or never attached
sudo lshw -class network?

Оффлайн gamayun

  • Активист
  • *
  • Сообщений: 823
  • Кто ищет, тот найдёт, может быть...
    • Просмотр профиля
Sobir
Цитировать
Пытался содать подключение через Network Manager, но оно не пашет.
Вот что выдаёт lsusb:
Bus 001 Device 002: ID 19d2:2003 ZTE WCDMA Technologies MSM
Установил usb_modeswitch.
В конфигах нет записи с vid:pid - 19d2:2003.
 Что делать?

Для начала , какая ОС установлена (версия) .
Что за железо - ПК , ноутбук , в  какой разъем подсоединяете модем .
Опишите каким образом создавали соединение , и как не "пашет" .
 Также перед созданием темы необходимо читать  - Правила и рекомендации по оформлению тем в разделе Поддержки

Прошу прощения.
Железо-ноутбук.
Установлена ОС- Ubuntu 14.04, работает как виртуальная машина на VirtualBox.
Модем подключаю к разъёму USB 3.0
А основная ОС тогда какая?
Как-то я пробовал на вртуалку usb-модем,ничего не вышло.
Не бери в голову

Оффлайн Sobir

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля


Цитировать
А основная ОС тогда какая?

Windows 7 - Основная ОС


Пользователь добавил сообщение 26 Май 2016, 17:09:24:

sudo lshw -class network?
:~$ sudo lshw -class network
  *-network               
       description: Ethernet interface
       product: 82540EM Gigabit Ethernet Controller
       vendor: Intel Corporation
       physical id: 3
       bus info: pci@0000:00:03.0
       logical name: eth0
       version: 02
       serial: 08:00:27:c8:33:a4
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 66MHz
       capabilities: pm pcix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000 driverversion=7.3.21-k8-NAPI duplex=full ip=10.0.2.15 latency=64 link=yes mingnt=255 multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:19 memory:f0000000-f001ffff ioport:d010(size=8)
:~$

« Последнее редактирование: 26 Май 2016, 17:09:24 от Sobir »

Оффлайн gamayun

  • Активист
  • *
  • Сообщений: 823
  • Кто ищет, тот найдёт, может быть...
    • Просмотр профиля
Сеть в виртуальной машине настраивается в самой программе

Не знаю какие настройки в винде,но гостевая ОС получает интернет от основной.Вот у меня Arch на виртуалке в Ubuntu. Но создать сеть между модемом и виртуальной машиной у меня не вышло.Через вайфай и сетевуху без проблем.
Мой вам совет:ставить Ubuntu реально на жесткий диск и там уже настраивать.Или ждите спеца по виртуальным машинам в windows на форуме Ubuntu  8)   
Не бери в голову

Оффлайн Sobir

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Сеть в виртуальной машине настраивается в самой программе

Не знаю какие настройки в винде,но гостевая ОС получает интернет от основной.Вот у меня Arch на виртуалке в Ubuntu. Но создать сеть между модемом и виртуальной машиной у меня не вышло.Через вайфай и сетевуху без проблем.
Мой вам совет:ставить Ubuntu реально на жесткий диск и там уже настраивать.Или ждите спеца по виртуальным машинам в windows на форуме Ubuntu  8)   

У меня тоже без проблем расшаривается соединение через NAT в настройках виртуалки. Проблема не в настройках виртуальной машины а  в настройке модема на самой Ubuntu. На самом деле на борту модема как бэ есть приложение для запуска модема, но когда его запускаешь выскакивает ошибка типа "QT3 runtime library not installed", а её кажется уже нет в репозиториях.
Вот я и пытаюсь создать подключение через usb_modeswitch и Network Manager

Оффлайн gamayun

  • Активист
  • *
  • Сообщений: 823
  • Кто ищет, тот найдёт, может быть...
    • Просмотр профиля
В конце концов можно запустить Ubuntu с liveCD,когда она запущена на реальном железе,и там уже попробовать настраивать модем.Ну не может виртуальная машина работать в обход основной ОС.Вся начинка компа контролируется основной ОС,а виртуалка есть просто программа эмуляции.Я читал пару "забугорных" форумов,посредством гуглопереводчика, и там я понял,что однозначного решения никто не нашел.
Не бери в голову

 

Страница сгенерирована за 0.06 секунд. Запросов: 24.