Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Многое сломалось в системе после отключения света  (Прочитано 471 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tonny_Bennet

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Здравствуйте.

Есть виртуальная машина под Hyper-V, на которой крутится Ubuntu Server
Linux ganymede 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

После отключения света слетел grub. Загрузился с диска и проверил систему fsck. Система поднялась и по-моему очень многое в ней поломалось. Решил сделать apt-get update - прошло. На upgrade вот такая беда:

~$ sudo apt-get upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Расчёт обновлений…Готово
Пакеты, которые будут оставлены в неизменном виде:
  linux-generic linux-headers-generic linux-image-generic openjdk-7-jdk
  openjdk-7-jre openjdk-7-jre-headless openssl php-pear php5-cli php5-common
  php5-fpm php5-gd php5-mcrypt php5-mysql php5-readline
Пакеты, которые будут обновлены:
  apport apt apt-transport-https apt-utils bash-completion binutils coreutils
  cpp-4.8 dosfstools dpkg gcc-4.8-base git git-man initramfs-tools
  initramfs-tools-bin klibc-utils libapt-inst1.5 libapt-pkg4.12 libc-bin libc6
  libexpat1 libgd3 libgudev-1.0-0 libklibc liblcms2-2 libnl-3-200
  libnl-genl-3-200 libpam-modules libpam-modules-bin libpam-runtime
  libpam-systemd libpam0g libpcre3 libperconaserverclient18 libpq5 libssl1.0.0
  libstdc++6 libsystemd-daemon0 libsystemd-login0 libtasn1-6 libtdb1 libtiff5
  libudev1 libxml2 linux-firmware lsb-base lsb-release multiarch-support
  mysql-common nginx nginx-common nginx-core openssh-client openssh-server
  openssh-sftp-server oracle-java8-installer oracle-java8-set-default
  percona-server-client-5.5 percona-server-common-5.5
  percona-server-server-5.5 postgresql-9.3 postgresql-client-9.3
  python3-apport python3-problem-report systemd-services tzdata tzdata-java
  udev
обновлено 68, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 15 пакетов не обновлено.
Необходимо скачать 0 B/94,9 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 36,1 MB.
Хотите продолжить? [Д/н] y
debconf: Perl may be unconfigured (Can't locate loadable object for module IO in @INC (@INC contains: /etc/perl /usr/l                                                             ocal/lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5                                                             .18 /usr/local/lib/site_perl .) at /usr/lib/perl/5.18/IO/Handle.pm line 9.
Compilation failed in require at /usr/lib/perl/5.18/IO/Handle.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/IO/Handle.pm line 9.
Compilation failed in require at /usr/lib/perl/5.18/IO/Seekable.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/IO/Seekable.pm line 9.
Compilation failed in require at /usr/lib/perl/5.18/IO/File.pm line 11.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/IO/File.pm line 11.
Compilation failed in require at /usr/share/perl/5.18/FileHandle.pm line 9.
Compilation failed in require at (eval 1) line 3.
BEGIN failed--compilation aborted at (eval 1) line 3.
) -- aborting
dpkg: предупреждение: список файлов пакета «irqbalance» отсутствует; предполагаем, что на данный момент у пакета нет у                                                             становленных файлов
dpkg: предупреждение: список файлов пакета «tasksel-data» отсутствует; предполагаем, что на данный момент у пакета нет                                                              установленных файлов
dpkg: предупреждение: список файлов пакета «tasksel» отсутствует; предполагаем, что на данный момент у пакета нет уста                                                             новленных файлов
dpkg: предупреждение: список файлов пакета «libsigsegv2:amd64» отсутствует; предполагаем, что на данный момент у пакет                                                             а нет установленных файлов
dpkg: предупреждение: список файлов пакета «libgdk-pixbuf2.0-0:amd64» отсутствует; предполагаем, что на данный момент                                                              у пакета нет установленных файлов
dpkg: невосстановимая ошибка, прекращение работы:
 список файлов пакета «patch» не является обычным файлом
E: Sub-process /usr/bin/dpkg returned an error code (2)

Подскажите как вылечить.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26078
    • Просмотр профиля
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Tonny_Bennet

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
root@ganymede:~# df -h
Файл.система   Размер Использовано  Дост Использовано% Cмонтировано в
udev             2,0G         4,0K  2,0G            1% /dev
tmpfs            395M         360K  395M            1% /run
/dev/sda1        243G          16G  215G            7% /
none             4,0K            0  4,0K            0% /sys/fs/cgroup
none             5,0M            0  5,0M            0% /run/lock
none             2,0G            0  2,0G            0% /run/shm
none             100M            0  100M            0% /run/user

root@ganymede:~# df -i
Файл.система     Iнодов IИспользовано IСвободно IИспользовано% Cмонтировано в
udev             502420           417    502003             1% /dev
tmpfs            505135           328    504807             1% /run
/dev/sda1      16121856        187282  15934574             2% /
none             505135             1    505134             1% /sys/fs/cgroup
none             505135             1    505134             1% /run/lock
none             505135             1    505134             1% /run/shm
none             505135             1    505134             1% /run/user

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26078
    • Просмотр профиля
Попробуйте удалить кэш апт и заново перекачать файлы индексов.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Tonny_Bennet

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Если речь идёт о
apt-get clean
apt-get update
apt-get upgrade

то это я уже делал. Сделал ещё раз

4.04 [2 686 kB]
Получено 94,9 MБ за 41с (2 278 kБ/c)
debconf: Perl may be unconfigured (Can't locate loadable object for module IO in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .) at /usr/lib/perl/5.18/IO/Handle.pm line 9.
Compilation failed in require at /usr/lib/perl/5.18/IO/Handle.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/IO/Handle.pm line 9.
Compilation failed in require at /usr/lib/perl/5.18/IO/Seekable.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/IO/Seekable.pm line 9.
Compilation failed in require at /usr/lib/perl/5.18/IO/File.pm line 11.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/IO/File.pm line 11.
Compilation failed in require at /usr/share/perl/5.18/FileHandle.pm line 9.
Compilation failed in require at (eval 1) line 3.
BEGIN failed--compilation aborted at (eval 1) line 3.
) -- aborting
dpkg: предупреждение: список файлов пакета «irqbalance» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «tasksel-data» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «tasksel» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libsigsegv2:amd64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: предупреждение: список файлов пакета «libgdk-pixbuf2.0-0:amd64» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
dpkg: невосстановимая ошибка, прекращение работы:
 список файлов пакета «patch» не является обычным файлом
E: Sub-process /usr/bin/dpkg returned an error code (2)

Тут постепенно выясняется, что, к примеру, MC начал криво работать, нет цветовой подсветки в панелях. При открытии mcedit выскакивает ошибка:

Формат /etc/mc/mc.ext изменён с версии 3.0. Возможно, произошёл сбой при установке. Пожалуйста, возьмите свежую копию из пакета Midnight Commander.
Закрываю МС а в консоли много раз повторяется
Предупреждение: неправильная строка в sfs.ini:

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26078
    • Просмотр профиля
Бэкап контейнера есть? IMO, проще будет раскатать бэкап и не мучаться.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Tonny_Bennet

  • Автор темы
  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Был бы бекап я бы и не мучался :) .... ну а раз уж приступ мазохизма нужно, что-то решать с этой системой.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26078
    • Просмотр профиля
Тогда поднимайте новый конт и переносите настройки…
IMO, лечить это будет дольше.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.056 секунд. Запросов: 24.