Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: ubuntu server + xfce = нет раскладок клавиатуры  (Прочитано 1170 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Reloader

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Всем доброго времени суток!
Установлен ubuntu server X32
Установлена XFCE4
(так же установлен xRDP)
Нет возможности добавить русскую раскладку клавиатуры.

причем в консоли (без запуска иксов) всё нормально переключается.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26086
    • Просмотр профиля
Re: ubuntu server + xfce = нет раскладок клавиатуры
« Ответ #1 : 08 Июнь 2016, 20:03:53 »
А зачем на СЕРЕВЕРЕ десктоп?…
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Reloader

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: ubuntu server + xfce = нет раскладок клавиатуры
« Ответ #2 : 08 Июнь 2016, 20:05:59 »
А зачем на СЕРЕВЕРЕ десктоп?…
а какая. к чёрту разница. милейший? Это не относится к делу абсолютно.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26086
    • Просмотр профиля
Re: ubuntu server + xfce = нет раскладок клавиатуры
« Ответ #3 : 08 Июнь 2016, 20:24:42 »
Разница есть. Если он там действительно нужен, тогда есть смысл что-то советовать, искать, пробовать.
А если просто такая вот дурь в голову вошла, то сами с ней носитесь.

P.S.
Локализацию установите.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Reloader

  • Автор темы
  • Любитель
  • *
  • Сообщений: 52
    • Просмотр профиля
Re: ubuntu server + xfce = нет раскладок клавиатуры
« Ответ #4 : 09 Июнь 2016, 02:19:29 »
Разница есть. Если он там действительно нужен, тогда есть смысл что-то советовать, искать, пробовать.
установлен xRDP - это будет сервер удаленных рабочих столов на 5-7 пользователей.

локализация установлена :


Пользователь добавил сообщение 09 Июнь 2016, 02:36:15:
Вывод locale
LANG=ru_RU.UTF-8
LANGUAGE=
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=

Пользователь добавил сообщение 09 Июнь 2016, 02:41:19:
Скорее всего проблема кроется в том что ОС была установлена из  MinimalCD.
Тому есть причина - железо не поддерживает Х64, а 32-х битных версий ubuntu server уже вроде как уже нет...

Пользователь добавил сообщение 09 Июнь 2016, 20:21:35:
Решил пойти от обратного :
Установил Lubuntu
Установил xRDP

Если заходить локально - проблем с раскладкой нет
А вот когда захожу через rdp  - то индикатор раскладки на панели пропадает.
на английском клава работает, а вот при переключении на русский - не реагирует.
В смысле буквы не вводятся, но горячие клавиши работают.
Как будто система не желает печатать кириллицу
« Последнее редактирование: 09 Июнь 2016, 20:21:36 от Reloader »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26086
    • Просмотр профиля
Re: ubuntu server + xfce = нет раскладок клавиатуры
« Ответ #5 : 09 Июнь 2016, 21:13:15 »
При заходе удалённо вроде надо указывать раскладки на клиенте.
По крайней мере что-то такое у меня в памяти вертится.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

alexxnight

  • Гость
Re: ubuntu server + xfce = нет раскладок клавиатуры
« Ответ #6 : 10 Июнь 2016, 11:59:56 »
Да, тоже когда-то развлекался так на серверах amazon :)

sudo touch /etc/xdg/autostart/setxkbmap.desktop
sudo nano /etc/xdg/autostart/setxkbmap.desktop

Добавить:
[Desktop Entry]
Encoding=UTF-8
Version=0.9.4
Type=Application
Name=setxkbmap
Comment=Setxkbmap
Exec=/usr/bin/setxkbmap -layout us,ru -variant , -option grp:alt_shift_toggle,grp_led:scrol
OnlyShowIn=XFCE;
StartupNotify=false
Terminal=false
Hidden=false

 

Страница сгенерирована за 0.056 секунд. Запросов: 24.