Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: "Ошибка при подключении /etc/fstab"  (Прочитано 1090 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lelalo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
При загрузке Ubuntu выдает ошибку:
"Ошибка при подключении /etc/fstab"

"Нажмите S, чтобы продолжить загрузку, или M, чтобы сделать ручное восстановление"

Если нажать на S, то компьютер нормально включается и работает.
Возникла эта ошибка после того, как я добавил строчки для раздела с Windows. Но после этого я удалил добавленную строку, но ошибка все равно выскакивает.
Эту тему изучил, такой синтаксической ошибки у меня нет https://forum.ubuntu.ru/index.php?topic=116236.0 

(Нажмите, чтобы показать/скрыть)

Оффлайн skybour

  • Старожил
  • *
  • Сообщений: 2224
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #1 : 22 Июнь 2016, 20:43:21 »
Покажи еще
Код: Bash
  1. sudo blkid

Оффлайн lelalo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #2 : 22 Июнь 2016, 20:58:11 »
(Нажмите, чтобы показать/скрыть)

Оффлайн Кончита

  • Любитель
  • *
  • Сообщений: 54
  • openmediavault
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #3 : 22 Июнь 2016, 22:05:53 »
Я аж буковки сравнивала - не разгадала ребус.
Может, ошибки на /, попытка смонтироваться в ro, а s скипает ошибку?

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #4 : 22 Июнь 2016, 22:12:59 »
lelalo, а с какой радости у Вас efi раздел подключается с параметрами по-дефолту? Может я неправ, но там должно быть umask=0077

P.S. Желательно нажать таки М и посмотреть, какой раздел не может смонтировать
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн lelalo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #5 : 22 Июнь 2016, 22:40:28 »
lelalo, а с какой радости у Вас efi раздел подключается с параметрами по-дефолту? Может я неправ, но там должно быть umask=0077

1. заменил defaults=>umask=0077 = ничего не изменилось
2. закомментировал все, кроме / = ничего не изменилось

lelalo, Желательно нажать таки М и посмотреть, какой раздел не может смонтировать

Мне придется поискать, как это сделать, но если вы напишите, буду признателен

Оффлайн Lekssey

  • Активист
  • *
  • Сообщений: 299
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #6 : 22 Июнь 2016, 22:52:05 »
В конце файла fstab есть пустая строка? (вроде нужна)

Оффлайн wajnon

  • Старожил
  • *
  • Сообщений: 2778
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #7 : 22 Июнь 2016, 22:54:37 »
lelalo, фаст бут выключить попробуй в вин

Оффлайн lelalo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #8 : 22 Июнь 2016, 23:05:32 »
lelalo, фаст бут выключить попробуй в вин

он у меня выключенный

В конце файла fstab есть пустая строка? (вроде нужна)

нет. Добавил, но ничего не изменилось

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #9 : 22 Июнь 2016, 23:43:13 »
lelalo, где-то у вас попал скрытый символ в fstab. Другой причины я не вижу.
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн skybour

  • Старожил
  • *
  • Сообщений: 2224
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #10 : 22 Июнь 2016, 23:44:42 »
lelalo, приложи файл, что-ли.

Оффлайн lelalo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #11 : 23 Июнь 2016, 00:03:06 »
вот

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #12 : 23 Июнь 2016, 00:32:09 »
Ну вот и нашлась причина. У вас кодировка файла UTF-8 with BOM, а надо просто UTF-8 (without BOM):

вместо # /etc/fstab: st система вначале файла видела ...# /etc/fstab:

В прикрепленном архиве исправленный файл
« Последнее редактирование: 23 Июнь 2016, 00:36:26 от EvangelionDeath »
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн lelalo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #13 : 23 Июнь 2016, 01:39:38 »
Спасибо большое, все работает теперь

Оффлайн Кончита

  • Любитель
  • *
  • Сообщений: 54
  • openmediavault
    • Просмотр профиля
Re: "Ошибка при подключении /etc/fstab"
« Ответ #14 : 23 Июнь 2016, 07:21:01 »
Ну вот и нашлась причина. У вас кодировка файла UTF-8 with BOM, а надо просто UTF-8 (without BOM):

вместо # /etc/fstab: st система вначале файла видела ...# /etc/fstab:

В прикрепленном архиве исправленный файл
Расскажите по-подробнее, пожалуйста.

 

Страница сгенерирована за 0.068 секунд. Запросов: 25.