Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Помогите нубу решить вопросы с драйверами и иксами  (Прочитано 936 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Argsten

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Доброго времени! Спасибо что помогаете!
Купил я значит ноутбук ASUS k501U. Решил значит я для начала поставить mint, поставил, попользовался, понял что не моё (до этого стоял debian с gnome3 на стареньком ноуте и он мне очень доставлял). Поставил debian, как положено начал ставить проприетарные драйвера nVidia. Не взлетел. Ну думаю не беда, есть Ubuntu gnome, думал там должно взлететь все и сразу. Но увы и тут иксы отказывались запускаться при установки  проприетарных драйверов. Пробовал устанавливать драйвера и вручную и через стандартный менеджер, результат оказывался одинаковым. На этом мои знания закончились и я начал пользоваться google, но как оказалось и в google нет ничего толкового по решению моей проблемы. Симптомы таки, про загрузке, в момент когда должен появиться рабочий стол, просто черный экран, при этом ctrl+alt+f1 работает, при вводе startx пишет что 2 error, но не указывает какие, логи я найти не смог.

argsten@argsten-K501UX:~$ cat /var/log/Xorg.0.log | egrep -i "(error|fail|warning)"
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    41.875] (WW) Warning, couldn't open module nvidia
[    41.875] (EE) Failed to load module "nvidia" (module does not exist, 0)
[    41.947] (II) Failed to load module "intel" (already loaded, 22069)
[    41.947] (WW) Warning, couldn't open module nvidia
[    41.947] (EE) Failed to load module "nvidia" (module does not exist, 0)
[    41.947] (II) Failed to load module "nouveau" (already loaded, 0)
[    41.948] (II) Failed to load module "modesetting" (already loaded, 0)
[    41.948] (II) Failed to load module "fbdev" (already loaded, 0)
[    41.948] (II) Failed to load module "vesa" (already loaded, 0)


Так же наблюдается проблема с Wi-Fi (пишут что проблема с интерфейсом, якобы неправильно цепляет оборудование, не знаю на сколько я правильно выразился). lspci выдает вот это:

argsten@argsten-K501UX:~$ lspci
00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 07)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 08)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller (rev 21)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI (rev 21)
00:17.0 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
03:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)

В прочем, вот как это все отображается в меню:
(Нажмите, чтобы показать/скрыть)

Убедительная просьба сильно на меня не бомбить, я только учусь, всего не знаю, но очень нравится. Заранее спасибо за помощь!
« Последнее редактирование: 29 Июнь 2016, 16:34:28 от Argsten »

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3095
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Ну значит Вы либо плохо умете пользваться google или правильно формировать запросы.

Причина проблемы: Nvidia-Bumblebee. Ставьте Prime
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн Argsten

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Ну значит Вы либо плохо умете пользваться google или правильно формировать запросы.

Причина проблемы: Nvidia-Bumblebee. Ставьте Prime
Сделал все по вот этой инструкции:
http://help.ubuntu.ru/wiki/nvidia-prime
Результат:
(Нажмите, чтобы показать/скрыть)


Пользователь добавил сообщение 29 Июнь 2016, 15:19:56:
Кое как запустился используя команды:
sudo apt-get install linux-headers-`uname -r`
sudo dpkg-reconfigure nvidia-current
sudo nvidia-xconfig
sudo reboot
Появился Nvidia X server Settings.
Но в закладке Prime Profiles Nvidia не выбирается, вылезает "кирпич"
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 29 Июнь 2016, 16:33:39 от Argsten »

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3095
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
С каждым разом все веселее.
1) Почитайте инструкцию по вставке картинок.
2) Какую систему Вы изначально ставили? А то исходя из скринов, я разобрал, что там было ядро 3.13, а сейчас 4.4
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн Argsten

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
С каждым разом все веселее.
1) Почитайте инструкцию по вставке картинок.
2) Какую систему Вы изначально ставили? А то исходя из скринов, я разобрал, что там было ядро 3.13, а сейчас 4.4
Ядро 4.4
C драйверами на видео я уже разобрался, осталось только разобраться с wi-fi. Большое спасибо за подсказку на счет драйверов, действительно нужно было лучше искать.

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3095
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
А по поводу wi-fi, дайте вывод
Код: Bash
  1.  rfkill list
  2.  
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн Argsten

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Сердечно извиняюсь за свое долгое отсутствие.
Код: Bash
  1. argsten@argsten-K501UX:~$ rfkill list
  2. 0: hci0: Bluetooth
  3.         Soft blocked: no
  4.         Hard blocked: no
  5. 1: asus-wlan: Wireless LAN
  6.         Soft blocked: no
  7.         Hard blocked: no
  8. 2: asus-bluetooth: Bluetooth
  9.         Soft blocked: no
  10.         Hard blocked: no
  11. 3: phy0: Wireless LAN
  12.         Soft blocked: no
  13.         Hard blocked: yes
  14.  
« Последнее редактирование: 29 Июнь 2016, 21:35:34 от Argsten »

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3095
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Argsten, Ну.
  Hard blocked: yes
Ничего не говорит?
а клавиатуре пробовали включить вай-фай?
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн Argsten

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Блин, честно сказать с таким сталкиваюсь вообще в первый раз, до этого проблем с вафлей не было никогда.
На клавиатуре все возможные сочетания Fn+"" прощелкал, но результата нет. А можно как нибудь в ручную задать это сочетание?

Оффлайн Sly_tom_cat

  • Don't worry, be happy!
  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 11891
  • Xubuntu 18.04 (64bit)
    • Просмотр профиля
Надо бы еще в BIOS/setup utility заглянуть - там то не отключено?
Индикатор для Yandex-Disk: https://forum.ubuntu.ru/index.php?topic=241992
UEFI-Boot - грузимся без загрузчика: http://help.ubuntu.ru/wiki/uefiboot

Оффлайн Argsten

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Надо бы еще в BIOS/setup utility заглянуть - там то не отключено?

Посмотрел ещё раз, все что связано с сетью или вафлей стоит или UnLock, или enable.

 

Страница сгенерирована за 0.07 секунд. Запросов: 24.