Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: E: Unable to locate package  (Прочитано 1660 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kvazer

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
E: Unable to locate package
« : 13 Июль 2016, 21:27:39 »
Помогите!!! Подскажите как установить и где можно взять вот этот модуль kmod-nf-nathelper-extra :'(:idiot2:
« Последнее редактирование: 13 Июль 2016, 21:46:06 от kvazer »

Оффлайн Sergiy17

  • Любитель
  • *
  • Сообщений: 88
    • Просмотр профиля
Re: E: Unable to locate package
« Ответ #1 : 13 Июль 2016, 22:35:46 »
Насколько я понял, это пакет из OpenVRT, нужно установить в Ubuntu?
Лучший способ в чём-то разобраться до конца — это попробовать научить этому компьютер." (с) Дональд Кнут

Оффлайн kvazer

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: E: Unable to locate package
« Ответ #2 : 13 Июль 2016, 23:09:34 »
Если честно то я не знаю откуда он?  :idiot2:

Оффлайн shtunder

  • Новичок
  • *
  • Сообщений: 37
    • Просмотр профиля
Re: E: Unable to locate package
« Ответ #3 : 14 Июль 2016, 02:00:08 »
opkg update
opkg install kmod-nf-nathelper-extra
Моя задача - это слать в головы реквесты, и пока не получу 500, я не сдвинусь с места.

Оффлайн kvazer

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: E: Unable to locate package
« Ответ #4 : 14 Июль 2016, 02:47:14 »
root@ubuntu-512mb-fra1-01:~# opkg update
No command 'opkg' found, did you mean:
 Command 'dpkg' from package 'dpkg' (main)
opkg: command not found
root@ubuntu-512mb-fra1-01:~# opkg install kmod-nf-nathelper-extra
No command 'opkg' found, did you mean:
 Command 'dpkg' from package 'dpkg' (main)
opkg: command not found

Не прокатило! Что ещё посоветуете?

Оффлайн τοΖεη

  • Заслуженный пользователь
  • Администратор
  • Старожил
  • *
  • Сообщений: 8603
    • Просмотр профиля
Re: E: Unable to locate package
« Ответ #5 : 14 Июль 2016, 09:06:24 »
Код: Bash
  1. No command 'opkg' found, did you mean...
Установите opkg
# find / -iname '*τοΖεη*'
# /God's_Universe/Book_Of_Life_aka_LordJC_protected/τοΖεη
Subject description -->> Not an ideal but s@ved 4eVer. Final destination -->> Kingdom Of Heaven

Оффлайн Peter_I

  • Старожил
  • *
  • Сообщений: 1801
    • Просмотр профиля
Re: E: Unable to locate package
« Ответ #6 : 14 Июль 2016, 09:28:02 »
τοΖεη, Я вот и не знал о существовании opkg, а какие у неё преимущества по сравнению с apt-get?
Пётр.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Re: E: Unable to locate package
« Ответ #7 : 14 Июль 2016, 11:59:57 »
Какое отношение все это имеет к Ubuntu?

opkg - это аналог dpkg в OpenWrt.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн mahinist

  • Модератор форума
  • Старожил
  • *
  • Сообщений: 2977
  • Ubuntu-18.04 , Archlinux , BlackArch , Gentoo
    • Просмотр профиля
Re: E: Unable to locate package
« Ответ #8 : 14 Июль 2016, 14:31:23 »
kvazer
Извините , хотелось бы узнать , какая ОС Линукс у Вас  установлена  ?
31-регион

Оффлайн Sly_tom_cat

  • Don't worry, be happy!
  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 11891
  • Xubuntu 18.04 (64bit)
    • Просмотр профиля
Re: E: Unable to locate package
« Ответ #9 : 14 Июль 2016, 14:43:42 »
У меня есть устойчивое впечатление что автор топика нашел инструкцию по настройки чего-то на OPENWRT и пытается ей воспользоваться на Ubuntu.


Давайте для начала проясним - зачем нужно устанавливать kmod-nf-nathelper-extra? Что вы пытаетесь этим добиться. PPTP в Ubuntu настраивается не так как в OPENWRT.
Индикатор для Yandex-Disk: https://forum.ubuntu.ru/index.php?topic=241992
UEFI-Boot - грузимся без загрузчика: http://help.ubuntu.ru/wiki/uefiboot

Оффлайн kvazer

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: E: Unable to locate package
« Ответ #10 : 14 Июль 2016, 21:20:14 »
Сейчас объясню поподробнее. ОС Ubuntu 14.04.4 x64. Сделал все как написано в этом мануале https://habrahabr.ru/company/infopulse/blog/183628/. Всё встало без проблем.  :D При попытке подключения вылетает ошибка 619 не удается подключиться к удаленному компьютеру vpn. Один из пользователей написал что проблема решилась установкой вот этого пакета kmod-nf-nathelper-extra.
При попытке поставить это пакет? делаю это так apt-get install kmod-nf-nathelper-extra вылетакет ЭТО

root@ubuntu-512mb-fra1-01:~# apt-get install kmod-nf-nathelper-extra
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package kmod-nf-nathelper-extra

Подскажите что делать и куда копать :idiot2:!!!

« Последнее редактирование: 14 Июль 2016, 21:24:01 от kvazer »

Оффлайн Sly_tom_cat

  • Don't worry, be happy!
  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 11891
  • Xubuntu 18.04 (64bit)
    • Просмотр профиля
Re: E: Unable to locate package
« Ответ #11 : 14 Июль 2016, 23:05:25 »
kvazer, еще раз: kmod-nf-nathelper-extra - это пакет OpenWRT, а не ubuntu (что черным по белому написал и автор, упомянувший этот пакет). Кроме того это гуглится за пол секунды.

OpenWRT и Ubuntu - разные дистрибутивы, с разными пакетными менеджерами и вообще разной организацией. И пакет от openWRT не существует в пакетной системе Ubuntu и никак вам не поможет с настройкой чего бы то ни-было.

Пользователь добавил сообщение 14 Июль 2016, 23:10:15:
Если нужен VPN - то можно и у нас в мануалах посмотреть - вот, например, по OpenVPN нормальный мануал: http://help.ubuntu.ru/wiki/openvpn
« Последнее редактирование: 14 Июль 2016, 23:10:15 от Sly_tom_cat »
Индикатор для Yandex-Disk: https://forum.ubuntu.ru/index.php?topic=241992
UEFI-Boot - грузимся без загрузчика: http://help.ubuntu.ru/wiki/uefiboot

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Re: E: Unable to locate package
« Ответ #12 : 14 Июль 2016, 23:12:13 »
Поддерживаю предыдущий пост. Я хорошо разбираюсь в OpenWrt. Даже несколько лет поддерживал форк для пользователей Билайн. Но не могу понять что вы хотите сделать и зачем.
Я в личке не консультирую. Вопросы задавайте на форуме.

 

Страница сгенерирована за 0.07 секунд. Запросов: 24.