Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Почтовый сервер на базе Postfix, Dovecot и Ubuntu 16.04 LTS  (Прочитано 4242 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ING

  • Автор темы
  • Активист
  • *
  • Сообщений: 366
    • Просмотр профиля
Всем привет!

Работал у меня сервер на базе 14.04, на нем крутился почтовый сервер (Postfix, Dovecot, MySQL), ставил в свое время по инструкции http://www.volmed.org.ru/wiki/index.php/%D0%9F%D0%BE%D1%87%D1%82%D0%BE%D0%B2%D1%8B%D0%B9_%D1%81%D0%B5%D1%80%D0%B2%D0%B5%D1%80_%D0%BD%D0%B0_%D0%B1%D0%B0%D0%B7%D0%B5_Postfix,_Dovecot_%D0%B8_Ubuntu_14.04_LTS

На днях, в силу разных причин, решил перезалить сервер, в чистую :) Поставил Ubuntu Server 16.04 (64-bit)
Проблема в том, что не могу поставить почтовый сервер по выше упомянутой ссылке ...

sudo apt install postfix
(Нажмите, чтобы показать/скрыть)

и так почти с каждым пакетом ...

Скажите, есть у кого либо инструкция по установке связки Ubuntu 16.04+Postfix+Dovecot+MySQL ???
« Последнее редактирование: 21 Июль 2016, 20:15:03 от ING »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26080
    • Просмотр профиля
А логи читать кто будет?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн ING

  • Автор темы
  • Активист
  • *
  • Сообщений: 366
    • Просмотр профиля
Вопрос был о том, есть ли у кого/где вменяемая инструкция для 16.04 ...
Но рад буду любой помощи :) Так о каких логах речь? куда нужно смотреть? syslog? или еще что?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26080
    • Просмотр профиля
syslog, mail.log… postconf опять же.
postfix просто так не крашится. Обязательно как-то тебя обругает.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Krjd

  • Гость
ING, Если вы прочитаете то, что вам вывело при попытке установки, то увидите
Цитировать
Job for postfix.service failed because the control process exited with error code. See "systemctl status postfix.service" and "journalctl -xe" for details.
Собственно смотрите что с ним..
Актуальный лог по postfix:
systemctl status postfix.service
На счёт второй команды не уверен, но судя по ману это выведет лог со вспомогательным описанием сообщений и проскролит его в конец.
journalctl -xe

Оффлайн ING

  • Автор темы
  • Активист
  • *
  • Сообщений: 366
    • Просмотр профиля
sudo apt install postfix dovecot-common dovecot-imapd mysql-server mysql-client postfix-mysql dovecot-mysql sasl2-bin
(Нажмите, чтобы показать/скрыть)

cat syslog
(Нажмите, чтобы показать/скрыть)

cat mail.log
(Нажмите, чтобы показать/скрыть)

postconf
postconf: fatal: open /etc/postfix/main.cf: No such file or directory


Пользователь добавил сообщение 21 Июль 2016, 21:19:39:
ING, Если вы прочитаете то, что вам вывело при попытке установки, то увидите
Цитировать
Job for postfix.service failed because the control process exited with error code. See "systemctl status postfix.service" and "journalctl -xe" for details.
Собственно смотрите что с ним..
Актуальный лог по postfix:
systemctl status postfix.service
На счёт второй команды не уверен, но судя по ману это выведет лог со вспомогательным описанием сообщений и проскролит его в конец.
journalctl -xe

systemctl status postfix.service
(Нажмите, чтобы показать/скрыть)

journalctl -xe
(Нажмите, чтобы показать/скрыть)

Пользователь добавил сообщение 21 Июль 2016, 21:29:30:
fatal: Postfix integrity check failed!
и
Failed to start LSB: Postfix Mail Transport Agent.

LSB что это?
« Последнее редактирование: 21 Июль 2016, 21:29:31 от ING »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26080
    • Просмотр профиля
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн askanim

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Почтовый сервер на базе Postfix, Dovecot и Ubuntu 16.04 LTS
« Ответ #7 : 01 Сентябрь 2016, 06:31:45 »
Я поставил LSB всё в точности тоже самое, ему пофиг. Он не ставит и не настраивает dovecot и всё post fix в результе с ошибками ставится бред какой то

Оффлайн ING

  • Автор темы
  • Активист
  • *
  • Сообщений: 366
    • Просмотр профиля
Re: Почтовый сервер на базе Postfix, Dovecot и Ubuntu 16.04 LTS
« Ответ #8 : 28 Сентябрь 2016, 00:07:50 »
Судя по всему либо никто не ставит на 16.04 mysql 5.7, либо ставят но не считают возможным поделиться историей успеха :)

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26080
    • Просмотр профиля
Re: Почтовый сервер на базе Postfix, Dovecot и Ubuntu 16.04 LTS
« Ответ #9 : 28 Сентябрь 2016, 00:29:54 »
А при чём тут MySQL?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн ING

  • Автор темы
  • Активист
  • *
  • Сообщений: 366
    • Просмотр профиля
Re: Почтовый сервер на базе Postfix, Dovecot и Ubuntu 16.04 LTS
« Ответ #10 : 28 Сентябрь 2016, 22:32:07 »
При обработке следующих пакетов произошли ошибки:
 mysql-server-5.7
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

при этом ... В итоге имено это :(

Пользователь добавил сообщение 28 Сентябрь 2016, 22:48:49:
Вот по шагам:

$ sudo apt-get install postfix
[sudo] пароль для ...:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Предлагаемые пакеты:
  procmail postfix-mysql postfix-pgsql postfix-ldap postfix-pcre sasl2-bin dovecot-common
  postfix-cdb mail-reader postfix-doc
НОВЫЕ пакеты, которые будут установлены:
  postfix
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
Необходимо скачать 0 B/1 152 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 3 697 kB.
Предварительная настройка пакетов ...
Выбор ранее не выбранного пакета postfix.
(Чтение базы данных … на данный момент установлено 136580 файлов и каталогов.)
Подготовка к распаковке …/postfix_3.1.0-3_amd64.deb …
Распаковывается postfix (3.1.0-3) …
Обрабатываются триггеры для libc-bin (2.23-0ubuntu3) …
Обрабатываются триггеры для systemd (229-4ubuntu8) …
Обрабатываются триггеры для ureadahead (0.100.0-19) …
Обрабатываются триггеры для ufw (0.35-0ubuntu2) …
Обрабатываются триггеры для man-db (2.7.5-1) …
Настраивается пакет postfix (3.1.0-3) …

Postfix was not set up.  Start with
  cp /usr/share/postfix/main.cf.debian /etc/postfix/main.cf
.  If you need to make changes, edit
/etc/postfix/main.cf (and others) as needed.  To view Postfix configuration
values, see postconf(1).

After modifying main.cf, be sure to run '/etc/init.d/postfix reload'.

Обрабатываются триггеры для libc-bin (2.23-0ubuntu3) …
$

пока все хорошо ...

$ sudo apt-get install dovecot-common
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Заметьте, вместо «dovecot-common» выбирается «dovecot-core»
The following additional packages will be installed:
  libexttextcat-2.0-0 libexttextcat-data ntpdate
Предлагаемые пакеты:
  ntp dovecot-gssapi dovecot-sieve dovecot-pgsql dovecot-mysql dovecot-sqlite dovecot-ldap
  dovecot-imapd dovecot-pop3d dovecot-lmtpd dovecot-managesieved dovecot-solr dovecot-lucene
НОВЫЕ пакеты, которые будут установлены:
  dovecot-core libexttextcat-2.0-0 libexttextcat-data ntpdate
обновлено 0, установлено 4 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
Необходимо скачать 0 B/2 646 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 8 320 kB.
Хотите продолжить? [Д/н]
Выбор ранее не выбранного пакета ntpdate.
(Чтение базы данных … на данный момент установлено 136756 файлов и каталогов.)
Подготовка к распаковке …/ntpdate_1%3a4.2.8p4+dfsg-3ubuntu5.1_amd64.deb …
Распаковывается ntpdate (1:4.2.8p4+dfsg-3ubuntu5.1) …
Выбор ранее не выбранного пакета libexttextcat-data.
Подготовка к распаковке …/libexttextcat-data_3.4.4-1ubuntu3_all.deb …
Распаковывается libexttextcat-data (3.4.4-1ubuntu3) …
Выбор ранее не выбранного пакета libexttextcat-2.0-0:amd64.
Подготовка к распаковке …/libexttextcat-2.0-0_3.4.4-1ubuntu3_amd64.deb …
Распаковывается libexttextcat-2.0-0:amd64 (3.4.4-1ubuntu3) …
Выбор ранее не выбранного пакета dovecot-core.
Подготовка к распаковке …/dovecot-core_1%3a2.2.22-1ubuntu2_amd64.deb …
Распаковывается dovecot-core (1:2.2.22-1ubuntu2) …
Обрабатываются триггеры для man-db (2.7.5-1) …
Обрабатываются триггеры для libc-bin (2.23-0ubuntu3) …
Обрабатываются триггеры для systemd (229-4ubuntu8) …
Обрабатываются триггеры для ureadahead (0.100.0-19) …
Обрабатываются триггеры для ufw (0.35-0ubuntu2) …
Настраивается пакет ntpdate (1:4.2.8p4+dfsg-3ubuntu5.1) …
Настраивается пакет libexttextcat-data (3.4.4-1ubuntu3) …
Настраивается пакет libexttextcat-2.0-0:amd64 (3.4.4-1ubuntu3) …
Настраивается пакет dovecot-core (1:2.2.22-1ubuntu2) …
Обрабатываются триггеры для libc-bin (2.23-0ubuntu3) …
$

и тут все хорошо ...

$ sudo apt-get install dovecot-imapd
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
НОВЫЕ пакеты, которые будут установлены:
  dovecot-imapd
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
Необходимо скачать 0 B/142 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 528 kB.
Выбор ранее не выбранного пакета dovecot-imapd.
(Чтение базы данных … на данный момент установлено 137412 файлов и каталогов.)
Подготовка к распаковке …/dovecot-imapd_1%3a2.2.22-1ubuntu2_amd64.deb …
Распаковывается dovecot-imapd (1:2.2.22-1ubuntu2) …
Обрабатываются триггеры для dovecot-core (1:2.2.22-1ubuntu2) …
Настраивается пакет dovecot-imapd (1:2.2.22-1ubuntu2) …
Обрабатываются триггеры для dovecot-core (1:2.2.22-1ubuntu2) …
$

и тут ... продолжаем

$ sudo apt-get install mysql-server
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
The following additional packages will be installed:
  libevent-core-2.0-5 libhtml-template-perl mysql-client-5.7 mysql-client-core-5.7
  mysql-common mysql-server-5.7 mysql-server-core-5.7
Предлагаемые пакеты:
  libipc-sharedcache-perl mailx tinyca
НОВЫЕ пакеты, которые будут установлены:
  libevent-core-2.0-5 libhtml-template-perl mysql-client-5.7 mysql-client-core-5.7
  mysql-common mysql-server mysql-server-5.7 mysql-server-core-5.7
обновлено 0, установлено 8 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
Необходимо скачать 0 B/18,1 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 161 MB.
Хотите продолжить? [Д/н]
Предварительная настройка пакетов ...
Выбор ранее не выбранного пакета libevent-core-2.0-5:amd64.
(Чтение базы данных … на данный момент установлено 137427 файлов и каталогов.)
Подготовка к распаковке …/libevent-core-2.0-5_2.0.21-stable-2_amd64.deb …
Распаковывается libevent-core-2.0-5:amd64 (2.0.21-stable-2) …
Выбор ранее не выбранного пакета mysql-common.
Подготовка к распаковке …/mysql-common_5.7.15-0ubuntu0.16.04.1_all.deb …
Распаковывается mysql-common (5.7.15-0ubuntu0.16.04.1) …
Выбор ранее не выбранного пакета mysql-client-core-5.7.
Подготовка к распаковке …/mysql-client-core-5.7_5.7.15-0ubuntu0.16.04.1_amd64.deb …
Распаковывается mysql-client-core-5.7 (5.7.15-0ubuntu0.16.04.1) …
Выбор ранее не выбранного пакета mysql-client-5.7.
Подготовка к распаковке …/mysql-client-5.7_5.7.15-0ubuntu0.16.04.1_amd64.deb …
Распаковывается mysql-client-5.7 (5.7.15-0ubuntu0.16.04.1) …
Выбор ранее не выбранного пакета mysql-server-core-5.7.
Подготовка к распаковке …/mysql-server-core-5.7_5.7.15-0ubuntu0.16.04.1_amd64.deb …
Распаковывается mysql-server-core-5.7 (5.7.15-0ubuntu0.16.04.1) …
Обрабатываются триггеры для man-db (2.7.5-1) …
Настраивается пакет mysql-common (5.7.15-0ubuntu0.16.04.1) …
update-alternatives: ошибка: альтернативный путь /etc/mysql/my.cnf.fallback не существует
dpkg: ошибка при обработке пакета mysql-common (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 2
При обработке следующих пакетов произошли ошибки:
 mysql-common
E: Sub-process /usr/bin/dpkg returned an error code (1)
$

а тут уже не все хорошо ...
создал пустой файл /etc/mysql/my.cnf.fallback и заново попытался установить mysql-server

$ sudo apt-get install mysql-server
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
The following additional packages will be installed:
  libhtml-template-perl mysql-server-5.7
Предлагаемые пакеты:
  libipc-sharedcache-perl mailx tinyca
НОВЫЕ пакеты, которые будут установлены:
  libhtml-template-perl mysql-server mysql-server-5.7
обновлено 0, установлено 3 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
не установлено до конца или удалено 5 пакетов.
Необходимо скачать 0 B/2 642 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 48,6 MB.
Хотите продолжить? [Д/н]
Предварительная настройка пакетов ...
Настраивается пакет mysql-common (5.7.15-0ubuntu0.16.04.1) …
update-alternatives: используется /etc/mysql/my.cnf.fallback для предоставления /etc/mysql/my.cnf (my.cnf) в автоматическом режиме
Выбор ранее не выбранного пакета mysql-server-5.7.
(Чтение базы данных … на данный момент установлено 137584 файла и каталога.)
Подготовка к распаковке …/mysql-server-5.7_5.7.15-0ubuntu0.16.04.1_amd64.deb …
Распаковывается mysql-server-5.7 (5.7.15-0ubuntu0.16.04.1) …
Выбор ранее не выбранного пакета libhtml-template-perl.
Подготовка к распаковке …/libhtml-template-perl_2.95-2_all.deb …
Распаковывается libhtml-template-perl (2.95-2) …
Выбор ранее не выбранного пакета mysql-server.
Подготовка к распаковке …/mysql-server_5.7.15-0ubuntu0.16.04.1_all.deb …
Распаковывается mysql-server (5.7.15-0ubuntu0.16.04.1) …
Обрабатываются триггеры для systemd (229-4ubuntu8) …
Обрабатываются триггеры для ureadahead (0.100.0-19) …
Обрабатываются триггеры для man-db (2.7.5-1) …
Настраивается пакет libevent-core-2.0-5:amd64 (2.0.21-stable-2) …
Настраивается пакет mysql-client-core-5.7 (5.7.15-0ubuntu0.16.04.1) …
Настраивается пакет mysql-client-5.7 (5.7.15-0ubuntu0.16.04.1) …
Настраивается пакет mysql-server-core-5.7 (5.7.15-0ubuntu0.16.04.1) …
Настраивается пакет mysql-server-5.7 (5.7.15-0ubuntu0.16.04.1) …
update-alternatives: ошибка: альтернативный путь /etc/mysql/mysql.cnf не существует
dpkg: ошибка при обработке пакета mysql-server-5.7 (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 2
Настраивается пакет libhtml-template-perl (2.95-2) …
dpkg: зависимости пакетов не позволяют настроить пакет mysql-server:
 mysql-server зависит от mysql-server-5.7, однако:
  Пакет mysql-server-5.7 пока не настроен.

dpkg: ошибка при обработке пакета mysql-server (--configure):
 проблемы зависимостей — оставляем не настроенным
Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
            Обрабатываются триггеры для libc-bin (2.23-0ubuntu3) …
При обработке следующих пакетов произошли ошибки:
 mysql-server-5.7
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
$

и снова беда ... опять создал пустой файл /etc/mysql/mysql.cnf и повторил установку mysql-server

$ sudo apt-get install mysql-server
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
mysql-server is already the newest version (5.7.15-0ubuntu0.16.04.1).
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
не установлено до конца или удалено 2 пакетов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Хотите продолжить? [Д/н]
Настраивается пакет mysql-server-5.7 (5.7.15-0ubuntu0.16.04.1) …
update-alternatives: используется /etc/mysql/mysql.cnf для предоставления /etc/mysql/my.cnf (my.cnf) в автоматическом режиме
AppArmor parser error for /etc/apparmor.d/usr.sbin.mysqld in /etc/apparmor.d/usr.sbin.mysqld at line 9: ?????????? ??????? 'abstractions/mysql'
Checking if update is needed.
Checking server version.
Running queries to upgrade MySQL server.
Checking system database.
mysql.columns_priv                                 OK
mysql.db                                           OK
mysql.engine_cost                                  OK
mysql.event                                        OK
mysql.func                                         OK
mysql.general_log                                  OK
mysql.gtid_executed                                OK
mysql.help_category                                OK
mysql.help_keyword                                 OK
mysql.help_relation                                OK
mysql.help_topic                                   OK
mysql.innodb_index_stats                           OK
mysql.innodb_table_stats                           OK
mysql.ndb_binlog_index                             OK
mysql.plugin                                       OK
mysql.proc                                         OK
mysql.procs_priv                                   OK
mysql.proxies_priv                                 OK
mysql.server_cost                                  OK
mysql.servers                                      OK
mysql.slave_master_info                            OK
mysql.slave_relay_log_info                         OK
mysql.slave_worker_info                            OK
mysql.slow_log                                     OK
mysql.tables_priv                                  OK
mysql.time_zone                                    OK
mysql.time_zone_leap_second                        OK
mysql.time_zone_name                               OK
mysql.time_zone_transition                         OK
mysql.time_zone_transition_type                    OK
mysql.user                                         OK
The sys schema is already up to date (version 1.5.1).
Checking databases.
mail.domains                                       OK
mail.forwardings                                   OK
mail.transport                                     OK
mail.users                                         OK
sys.sys_config                                     OK
Upgrade process completed successfully.
Checking if update is needed.
Настраивается пакет mysql-server (5.7.15-0ubuntu0.16.04.1) …
$


о чудо, установился! Продолжаем ...

$ sudo apt-get install mysql-client
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
НОВЫЕ пакеты, которые будут установлены:
  mysql-client
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
Необходимо скачать 0 B/10,0 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 132 kB.
Выбор ранее не выбранного пакета mysql-client.
(Чтение базы данных … на данный момент установлено 137672 файла и каталога.)
Подготовка к распаковке …/mysql-client_5.7.15-0ubuntu0.16.04.1_all.deb …
Распаковывается mysql-client (5.7.15-0ubuntu0.16.04.1) …
Настраивается пакет mysql-client (5.7.15-0ubuntu0.16.04.1) …
$

все хорошо, дальше ...

$ sudo apt-get install postfix-mysql
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
The following additional packages will be installed:
  libmysqlclient20
НОВЫЕ пакеты, которые будут установлены:
  libmysqlclient20 postfix-mysql
обновлено 0, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
Необходимо скачать 0 B/823 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 4 474 kB.
Хотите продолжить? [Д/н]
Выбор ранее не выбранного пакета libmysqlclient20:amd64.
(Чтение базы данных … на данный момент установлено 137676 файлов и каталогов.)
Подготовка к распаковке …/libmysqlclient20_5.7.15-0ubuntu0.16.04.1_amd64.deb …
Распаковывается libmysqlclient20:amd64 (5.7.15-0ubuntu0.16.04.1) …
Выбор ранее не выбранного пакета postfix-mysql.
Подготовка к распаковке …/postfix-mysql_3.1.0-3_amd64.deb …
Распаковывается postfix-mysql (3.1.0-3) …
Обрабатываются триггеры для libc-bin (2.23-0ubuntu3) …
Настраивается пакет libmysqlclient20:amd64 (5.7.15-0ubuntu0.16.04.1) …
Настраивается пакет postfix-mysql (3.1.0-3) …
Обрабатываются триггеры для libc-bin (2.23-0ubuntu3) …
$

все ок ...

$ sudo apt-get install dovecot-mysql
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
НОВЫЕ пакеты, которые будут установлены:
  dovecot-mysql
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
Необходимо скачать 0 B/9 860 B архивов.
После данной операции, объём занятого дискового пространства возрастёт на 75,8 kB.
Выбор ранее не выбранного пакета dovecot-mysql.
(Чтение базы данных … на данный момент установлено 137688 файлов и каталогов.)
Подготовка к распаковке …/dovecot-mysql_1%3a2.2.22-1ubuntu2_amd64.deb …
Распаковывается dovecot-mysql (1:2.2.22-1ubuntu2) …
Обрабатываются триггеры для dovecot-core (1:2.2.22-1ubuntu2) …
Настраивается пакет dovecot-mysql (1:2.2.22-1ubuntu2) …
Обрабатываются триггеры для dovecot-core (1:2.2.22-1ubuntu2) …
$


все ок ...

$ sudo apt-get install sasl2-bin
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
The following additional packages will be installed:
  db-util db5.3-util
НОВЫЕ пакеты, которые будут установлены:
  db-util db5.3-util sasl2-bin
обновлено 0, установлено 3 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
Необходимо скачать 0 B/175 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 668 kB.
Хотите продолжить? [Д/н]
Предварительная настройка пакетов ...
Выбор ранее не выбранного пакета db5.3-util.
(Чтение базы данных … на данный момент установлено 137695 файлов и каталогов.)
Подготовка к распаковке …/db5.3-util_5.3.28-11_amd64.deb …
Распаковывается db5.3-util (5.3.28-11) …
Выбор ранее не выбранного пакета db-util.
Подготовка к распаковке …/db-util_1%3a5.3.21~exp1ubuntu2_all.deb …
Распаковывается db-util (1:5.3.21~exp1ubuntu2) …
Выбор ранее не выбранного пакета sasl2-bin.
Подготовка к распаковке …/sasl2-bin_2.1.26.dfsg1-14build1_amd64.deb …
Распаковывается sasl2-bin (2.1.26.dfsg1-14build1) …
Обрабатываются триггеры для man-db (2.7.5-1) …
Обрабатываются триггеры для systemd (229-4ubuntu8) …
Обрабатываются триггеры для ureadahead (0.100.0-19) …
Настраивается пакет db5.3-util (5.3.28-11) …
Настраивается пакет db-util (1:5.3.21~exp1ubuntu2) …
Настраивается пакет sasl2-bin (2.1.26.dfsg1-14build1) …
Обрабатываются триггеры для systemd (229-4ubuntu8) …
Обрабатываются триггеры для ureadahead (0.100.0-19) …
$

и тут ок.

И что, вся проблема в двух отсутствующих файлах??? :(( Не прикольно ... Посмотрим как будет все это хозяйство работать.


Пользователь добавил сообщение 29 Сентябрь 2016, 12:17:43:
Нашел еще один "пунтик", с которым postfix не справился ...
В файле /etc/postfix/sql/mysql-virtual_domains.cf предлагается использовать такой конфиг:

user = mail_admin
password = mail_admin_password
dbname = mail
query = SELECT domain AS virtual FROM domains WHERE domain = '%s'
hosts = 127.0.0.1

и это у меня не работает :(
Если проверить команду в MySQL то выяснится, что мускулу не нравится virtual.
Убираем AS virtual и все работает

user = mail_admin
password = mail_admin_password
dbname = mail
query = SELECT domain FROM domains WHERE domain = '%s'
hosts = 127.0.0.1
« Последнее редактирование: 29 Сентябрь 2016, 12:18:40 от ING »

 

Страница сгенерирована за 0.067 секунд. Запросов: 25.