Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: flash player ubuntu 16.04  (Прочитано 5036 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн iGorw

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
flash player ubuntu 16.04
« : 22 Июль 2016, 13:42:12 »
В общем проблема такая: не могу установить google chrome на ubuntu 16.04 32бит. Стоит отметить что я первый день пользуюсь этой ОС (да и вообще линукс). Я пробовал устанавливать через терминал вписывая вот такие команды
Код: Bash
  1. wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -
  2. sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google-chrome.list'
  3. sudo apt-get update
  4. sudo apt-get install google-chrome-stable

(нашел на просторах интернета)

пишет следующее :
Код: HTML5
  1. Чтение списков пакетов… Готово
  2. Построение дерева зависимостей      
  3. Чтение информации о состоянии… Готово
  4. E: Не удалось найти пакет google-chrome-stable

пробовал скачать с офф сайта гугл файл .deb
 открываю наживаю установить, кнопка "установить" тусклеет на несколько секунд потом снова становится активной но ничего не происходит.

пробовал еще один способ через терминал (не могу найти сейчас), выдавало ошибку 404 fail not found (по моему так)

собственно зачем мне хром? нужно смотреть фильмы онлайн, как я понял нужный для этого флешплеер сразу есть в нем, до этого пытался установить просто флеш, тоже ничего хорошего не получилось. Не понимаю что делаю не так.
« Последнее редактирование: 26 Июль 2016, 16:45:42 от iGorw »

Оффлайн Sirrke

  • Участник
  • *
  • Сообщений: 109
  • Arch Linux
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #1 : 22 Июль 2016, 13:57:37 »
Google c марта 2016 прекратил поддержку Google Chrome для 32-битных систем. Хромиум в помощь. Далее в терминале: sudo apt-get install pepperflashplugin-nonfree
« Последнее редактирование: 22 Июль 2016, 13:59:49 от Sirrke »

Оффлайн iGorw

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #2 : 22 Июль 2016, 14:06:04 »
читал про то что прекратил, но честно говоря думал что прекратил выпуск обновлений, а тут все кардинально оказывается.

в терминале: sudo apt-get install pepperflashplugin-nonfree

Код: HTML5
  1. Чтение списков пакетов… Готово
  2. Построение дерева зависимостей      
  3. Чтение информации о состоянии… Готово
  4. Предлагаемые пакеты:
  5.   chromium-browser ttf-mscorefonts-installer ttf-dejavu ttf-xfree86-nonfree
  6. НОВЫЕ пакеты, которые будут установлены:
  7.   pepperflashplugin-nonfree
  8. обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 346 пакетов не обновлено.
  9. Необходимо скачать 11,2 kБ архивов.
  10. После данной операции, объём занятого дискового пространства возрастёт на 42,0 kB.
  11. Get:1 http://ru.archive.ubuntu.com/ubuntu xenial/multiverse i386 pepperflashplugin-nonfree i386 1.8.2ubuntu1 [11,2 kB]
  12. Получено 11,2 kБ за 0с (40,7 kБ/c)                    
  13. Выбор ранее не выбранного пакета pepperflashplugin-nonfree.
  14. (Чтение базы данных … на данный момент установлено 174554 файла и каталога.)
  15. Подготовка к распаковке …/pepperflashplugin-nonfree_1.8.2ubuntu1_i386.deb …
  16. Распаковывается pepperflashplugin-nonfree (1.8.2ubuntu1) …
  17. Настраивается пакет pepperflashplugin-nonfree (1.8.2ubuntu1) …
  18. WARNING: W: Недоступен открытый ключ для следующих ID ключей:
  19. 1397BC53640DB551
  20. E: Не найдено ни одного пакета
  21. E: Не найдено ни одного пакета
  22. E: Не найдено ни одного пакета
  23. E: Не найдено ни одного пакета
  24. E: Не найдено ни одного пакета
  25. E: Не найдено ни одного пакета
  26. dpkg-deb: ошибка: --extract требует указания каталога назначения.
  27. Вероятно, вам следует использовать dpkg --install
  28.  
  29. Чтобы получить информацию о работе с файлами .deb, введите dpkg-deb --help.
  30. Чтобы получить информацию об установке и удалении пакетов, введите dpkg --help.
« Последнее редактирование: 22 Июль 2016, 14:55:22 от Azure »

Оффлайн Sirrke

  • Участник
  • *
  • Сообщений: 109
  • Arch Linux
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #3 : 22 Июль 2016, 14:11:47 »
iGorw, Хромиум стоит?
sudo apt install chromium-browser

Оффлайн iGorw

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #4 : 22 Июль 2016, 14:30:23 »
iGorw, Хромиум стоит?
sudo apt install chromium-browser

хромиум установил через магазин, но при поптыке запустить какое нибудь видео (пару сайтов попробовал) пишет "невозможно запустить  плагин"

Оффлайн Sirrke

  • Участник
  • *
  • Сообщений: 109
  • Arch Linux
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #5 : 22 Июль 2016, 14:47:44 »
sudo apt install -fПлагин вообще установил, или нет? Последовательность в первом моем сообщении была указана. Сначала ставишь хромиум, потом пепперфлеш.
« Последнее редактирование: 22 Июль 2016, 14:55:57 от Sirrke »

Оффлайн iGorw

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #6 : 22 Июль 2016, 14:59:35 »
в хромимум точно так же нужно устанавливать флеш, ок, попытался поставить pepper flash

sudo update-pepperflashplugin-nonfree --install
WARNING: W: Недоступен открытый ключ для следующих ID ключей:
1397BC53640DB551
E: Не найдено ни одного пакета
E: Не найдено ни одного пакета
E: Не найдено ни одного пакета
E: Не найдено ни одного пакета
E: Не найдено ни одного пакета
E: Не найдено ни одного пакета
dpkg-deb: ошибка: --extract требует указания каталога назначения.
Вероятно, вам следует использовать dpkg --install

Чтобы получить информацию о работе с файлами .deb, введите dpkg-deb --help.
Чтобы получить информацию об установке и удалении пакетов, введите dpkg --help.


у меня не получается установить через терминал ни одного приложения....

Оффлайн Sirrke

  • Участник
  • *
  • Сообщений: 109
  • Arch Linux
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #7 : 22 Июль 2016, 15:14:34 »
в хромимум точно так же нужно устанавливать флеш, ок, попытался поставить pepper flash

sudo update-pepperflashplugin-nonfree --install
Казалось бы причем тут обновление плагина, который еще явно не установлен!

sudo apt install pepperflashplugin-nonfreeЭта команда для установки плагина флеш плеера.
sudo apt install -fЭта команда для удовлетворения зависимостей. Требуется в ряде случаев при неудачной установке программы.
Хромиум установлен. Далее вводим первую команду в терминал. При неудачной установке вводим вторую. Не получилось - выхлоп скопировать и выложить сюда под спойлер.

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3094
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #8 : 22 Июль 2016, 15:21:19 »
Если очень нужен Хром http://google-chrome.ru.uptodown.com/ubuntu/old
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн iGorw

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #9 : 22 Июль 2016, 16:32:08 »
sudo apt install pepperflashplugin-nonfreeЭта команда для установки плагина флеш плеера.
[/quote]

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
pepperflashplugin-nonfree is already the newest version (1.8.2ubuntu1).
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 275 пакетов не обновлено.

я так понимаю это означаетчто плагин установлен, но проблема не решилась...

« Последнее редактирование: 22 Июль 2016, 16:40:42 от iGorw »

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1471
  • ubuntu 18.04
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #10 : 22 Июль 2016, 16:47:28 »
Google c марта 2016 прекратил поддержку Google Chrome для 32-битных систем. Хромиум в помощь. Далее в терминале: sudo apt-get install pepperflashplugin-nonfree
Пакет pepperflashplugin-nonfree занимается тем, что скачивает гугл хром соответсвующей разрядности, выковыривает флеш из его дистрибутива, и ставит его в ОС.
Думаю понятно, почему этот пакет не работает для 32 битных систем :)

Поставить его можно так:
Удаляешь все флеши понаставленные.
Идешь в источники приложений
Ставишь там галку напротив пункта "Партнеры Canonical" - http://1.bp.blogspot.com/-WV8QDCGL32k/VUdBWPttrxI/AAAAAAAAF3w/b_D-tFZ5gNo/s1600/LinuxRussia_0046.png
Ставишь пакет adobe-flashplugin
« Последнее редактирование: 22 Июль 2016, 16:51:02 от soarin »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #11 : 22 Июль 2016, 16:57:03 »
soarin,
У меня на 32-битной системе с Хромиумом флеш работает. Причем последней версии. Как ставил уже не помню.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Hoi

  • Новичок
  • *
  • Сообщений: 40
  • Linux Mint Mate 17
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #12 : 22 Июль 2016, 17:03:47 »
Я поставил флэш на хромиум так.
Скачал флэш с сайта Adobe распаковал libpepflashplayer.so  и закинул в /opt/pepperflash/
Потом прописал команду запуска chromium-browser --ppapi-flash-path=/opt/pepperflash/libpepflashplayer.so --ppapi-flash-version=21.0.0.209 %U

И все. Работает все хорошо. Стоит: Xubuntu 16.04 x32

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #13 : 22 Июль 2016, 17:04:53 »
Hoi,
У меня стоит версия 22 и обновляется. Руками и так понятно было что можно.

Пользователь добавил сообщение 22 Июль 2016, 17:07:21:
Вспомнил как

sudo apt-get install adobe-flashplugin
Теперь там и pepper есть.
« Последнее редактирование: 22 Июль 2016, 17:07:21 от Pilot6 »
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн iGorw

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: google chrome ubuntu 16.04
« Ответ #14 : 26 Июль 2016, 16:44:47 »
Hoi,
У меня стоит версия 22 и обновляется. Руками и так понятно было что можно.

Пользователь добавил сообщение 22 Июль 2016, 17:07:21:
Вспомнил как

sudo apt-get install adobe-flashplugin
Теперь там и pepper есть.

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет adobe-flashplugin недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «adobe-flashplugin» не найден кандидат на установку


Пользователь добавил сообщение 26 Июль 2016, 16:46:48:

Поставить его можно так:
Удаляешь все флеши понаставленные.
Идешь в источники приложений
Ставишь там галку напротив пункта "Партнеры Canonical" - http://1.bp.blogspot.com/-WV8QDCGL32k/VUdBWPttrxI/AAAAAAAAF3w/b_D-tFZ5gNo/s1600/LinuxRussia_0046.png
Ставишь пакет adobe-flashplugin

галочка стоит, но пакета такого ненаходит
« Последнее редактирование: 26 Июль 2016, 16:46:48 от iGorw »

 

Страница сгенерирована за 0.064 секунд. Запросов: 25.