Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Проблема с зависимостями Ubuntu 16.04  (Прочитано 743 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн VadVenaR

  • Автор темы
  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Всем Доброго Дня!!!
При попытка установитьили удалить ЛЮБУЮ программы выскакивает такая ошибка:
sudo  apt-get install lftp
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 libqt4-dbus : Зависит: libqt4-xml (= 4:4.8.1-0ubuntu4.9) но 4:4.8.7+dfsg-5ubuntu2 будет установлен
               Зависит: libqtcore4 (= 4:4.8.1-0ubuntu4.9) но 4:4.8.7+dfsg-5ubuntu2 будет установлен
               Рекомендует: qdbus (= 4:4.8.1-0ubuntu4.9)
               Ломает: libqt4-dbus:i386 (!= 4:4.8.1-0ubuntu4.9) но 4:4.8.7+dfsg-5ubuntu2 будет установлен
 libqt4-dbus:i386 : Ломает: libqt4-dbus (!= 4:4.8.7+dfsg-5ubuntu2) но 4:4.8.1-0ubuntu4.9 будет установлен
 libqtdbus4 : Ломает: libqt4-dbus (< 4:4.8.2+dfsg-8) но 4:4.8.1-0ubuntu4.9 будет установлен
 libqtdbus4:i386 : Ломает: libqt4-dbus (< 4:4.8.2+dfsg-8) но 4:4.8.1-0ubuntu4.9 будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).


apt-get install -f не помогает
Удалить какой нибудь пакет с помощью
dpkg --purge тоже не помогает может кто знает в чем проблема?
началось все с того что я пытался установить paromtv.
« Последнее редактирование: 22 Июль 2016, 14:54:23 от VadVenaR »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26068
    • Просмотр профиля
Re: Проблема с зависимостями Ubuntu 16.04
« Ответ #1 : 22 Июль 2016, 15:46:08 »
началось все с того что я пытался установить paromtv.
С этого места, и подробнее.
Что именно вы делали?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Broken_Brain

  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Re: Проблема с зависимостями Ubuntu 16.04
« Ответ #2 : 22 Июль 2016, 23:36:04 »
Я попытаюсь угадать:
 у вас x64 битная ubuntu, и вы установили пакет  libqt4-dbus:i386 для, как указано в названии, архитектуры i386, а до установки у вас уже был установлен libqt4-dbus:amd64  и вот поэтому идет конфликт, как указано в вашем "выхлопе":
Цитировать
Ломает: libqt4-dbus:i386 (!= 4:4.8.1-0ubuntu4.9) но 4:4.8.7+dfsg-5ubuntu2 будет установлен
 libqt4-dbus:i386 : Ломает: libqt4-dbus (!= 4:4.8.7+dfsg-5ubuntu2) но 4:4.8.1-0ubuntu4.9 будет установлен
.

удаляйте libqt4-dbus:i386 и проблема с установкой пакетов исчезнет сама собой.

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26068
    • Просмотр профиля
Re: Проблема с зависимостями Ubuntu 16.04
« Ответ #3 : 23 Июль 2016, 00:22:43 »
Я попытаюсь угадать:
 у вас x64 битная ubuntu, и вы установили пакет  libqt4-dbus:i386 для, как указано в названии, архитектуры i386, а до установки у вас уже был установлен libqt4-dbus:amd64  и вот поэтому идет конфликт
Пакеты для разных архитектур не конфликтуют.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Broken_Brain

  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Re: Проблема с зависимостями Ubuntu 16.04
« Ответ #4 : 23 Июль 2016, 00:56:38 »
странно.. у меня конфликтовали. я когда guitar pro ставил, были проблемы. но не в этом дело.
Сообщение системы указывает:

 libqtdbus4:i386 : Ломает: libqt4-dbus (< 4:4.8.2+dfsg-8) но 4:4.8.1-0ubuntu4.9 будет установлен
« Последнее редактирование: 23 Июль 2016, 01:49:23 от Broken_Brain »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26068
    • Просмотр профиля
Re: Проблема с зависимостями Ubuntu 16.04
« Ответ #5 : 23 Июль 2016, 02:11:46 »
Broken_Brain, давайте дождёмся ответа ТС, хорошо?
Гадание на кофейной гуще до добра не доводит.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Broken_Brain

  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Re: Проблема с зависимостями Ubuntu 16.04
« Ответ #6 : 23 Июль 2016, 02:51:40 »
согласен. Ждем-с

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 1704
  • Kubuntu 12.04, 16.04, 18.04, 19.04
    • Просмотр профиля
Re: Проблема с зависимостями Ubuntu 16.04
« Ответ #7 : 23 Июль 2016, 12:53:54 »
началось все с того что я пытался установить paromtv.

Что значит пытался установить - не удалось?

Если мы говорим об одном и том же paromtv, то он обновился и надо качать свежую версию, ибо прежняя на 16.04 не ставится.
Я странен, а не странен кто ж? (С)

 

Страница сгенерирована за 0.056 секунд. Запросов: 24.