Форум русскоязычного сообщества Ubuntu


Автор Тема: Установив ubuntu0.16.04.2 удивился PHP Version 7  (Прочитано 405 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mstdmstd

  • Автор темы
  • Активист
  • *
  • Сообщений: 264
    • Просмотр профиля
Всем привет,
Установив ubuntu0.16.04.2 и по статье https://www.digitalocean.com/community/tutorials/how-to-install-linux-apache-mysql-php-lamp-stack-on-ubuntu-16-04  установил php  и обнаружил PHP Version 7.0.8-0
Я работал с php5.6 в kubuntu 14.04. Подскажите как лучше поступить ?
Есть ли возвожность вернуться к  php5.6 или ковырять дальше 7й?
Как-то упустил а что такие большие шаги в нумерации и стоит ли переходить ?

  Спасибо!

Оффлайн Sergiy17

  • Любитель
  • *
  • Сообщений: 88
    • Просмотр профиля
Re: Установив ubuntu0.16.04.2 удивился PHP Version 7
« Ответ #1 : 13 Август 2016, 22:01:18 »
Там не так много изменений, можете спокойно использовать. Об изменениях можно почитать на хабре - https://habrahabr.ru/post/280071/
Лучший способ в чём-то разобраться до конца — это попробовать научить этому компьютер." (с) Дональд Кнут

Оффлайн mstdmstd

  • Автор темы
  • Активист
  • *
  • Сообщений: 264
    • Просмотр профиля
Re: Установив ubuntu0.16.04.2 удивился PHP Version 7
« Ответ #2 : 14 Август 2016, 07:04:36 »
Спасибо!
Еще подскажите :
1) А как с обратной совместимостью У нас на сервере  5.4.45? Судя по статье если не использовать новые конструкции 7и то будет работать ?
2) Есть ли какой xammp для 5.6 и инструкция как его ставить и возможность иметь локально 5у и 7у?

Оффлайн slo_nik

  • Активист
  • *
  • Сообщений: 474
    • Просмотр профиля
Re: Установив ubuntu0.16.04.2 удивился PHP Version 7
« Ответ #3 : 14 Август 2016, 11:59:52 »
Спасибо!
Еще подскажите :
1) А как с обратной совместимостью У нас на сервере  5.4.45? Судя по статье если не использовать новые конструкции 7и то будет работать ?
2) Есть ли какой xammp для 5.6 и инструкция как его ставить и возможность иметь локально 5у и 7у?

Не используйте новые возможности php7 и будет работать на php5.4.
Можете на локальном попробовать удалить php7 и поставить ту версию, которая Вам нужна.
Ubuntu 16.04 LTS | Intel® Core™ i5-6500 CPU @ 3.20GHz × 4 | GeForce GTX 1060 6GB/PCIe/SSE2 | RAM 16Gb | и ни в коем случае не пользуйтесь услугами uadomen.com

Оффлайн mstdmstd

  • Автор темы
  • Активист
  • *
  • Сообщений: 264
    • Просмотр профиля
Re: Установив ubuntu0.16.04.2 удивился PHP Version 7
« Ответ #4 : 16 Август 2016, 15:23:35 »
А нет ли в php7 возможности при вызове методов php7  выведить варнинги ? Такой мягкий контроль php-версий ...

 

Страница сгенерирована за 0.057 секунд. Запросов: 24.