Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: [РЕШЕНО]на 16.04 перестал работать TV тюнер  (Прочитано 1528 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн rgkor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Видеокарта: MSI R9 280
ТВ тюнер: AverTV/505
На ubuntu 15.10 с пропиретарным драйвером видеокарты все работало.
На 16.10 tvtime пишет:
*** tvtime requires hardware YUY2 overlay support from your video card
*** driver.  If you are using an older NVIDIA card (TNT2), then
*** this capability is only available with their binary drivers.
*** For some ATI cards, this feature may be found in the experimental
*** GATOS drivers: http://gatos.sourceforge.net/
*** If unsure, please check with your distribution to see if your
*** X driver supports hardware overlay surfaces.

Тв карта в системе находится:
dmesg | grep saa7134
[   17.832821] saa7134: saa7130/34: v4l2 driver version 0, 2, 17 loaded
[   17.832921] saa7134: saa7130[0]: found at 0000:04:07.0, rev: 1, irq: 21, latency: 32, mmio: 0xfe700000
[   17.832925] saa7134: saa7130[0]: subsystem: 1461:a10a, board: AverMedia AverTV/505 [card=194,autodetected]
[   17.832937] saa7134: saa7130[0]: board init: gpio is 100e8
[   17.870519] input: saa7134 IR (AverMedia AverTV/50 as /devices/pci0000:00/0000:00:14.4/0000:04:07.0/rc/rc0/input5
[   17.870574] rc rc0: saa7134 IR (AverMedia AverTV/50 as /devices/pci0000:00/0000:00:14.4/0000:04:07.0/rc/rc0
[   18.030451] saa7134: i2c eeprom 00: 61 14 0a a1 ff ff ff ff ff ff ff ff ff ff ff ff
[  ..........

Пытался включить оверлей путем исправления /usr/share/X11/xorg.conf.d/10-amdgpu.conf.
(Что правил закоментарено.)
Section "OutputClass"
Identifier "AMDgpu"
MatchDriver "amdgpu"
Driver "amdgpu"
# Option "VideoOverlay" "yes"
# Option "OpenGLOverlay" "yes"
EndSection


Такая правка приводит к краху системы.


P.S. такой драйвер http://support.amd.com/en-us/kb-articles/Pages/AMD-Radeon-GPU-PRO-Linux-Beta-Driver%e2%80%93Release-Notes.aspx - не заработал
« Последнее редактирование: 20 Август 2016, 15:50:04 от Punko »

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 1704
  • Kubuntu 12.04, 16.04, 18.04, 19.04
    • Просмотр профиля
Re: на 16.04 перестал работать TV тюнер
« Ответ #1 : 17 Август 2016, 20:07:24 »
rgkor, покажите выхлоп
xvinfoи
lspci -k | grep VGA -A2а то у вас там в тексте уже 16.10, мало ли что.
« Последнее редактирование: 17 Август 2016, 22:48:36 от AlexBKost »
Я странен, а не странен кто ж? (С)

Оффлайн skybour

  • Старожил
  • *
  • Сообщений: 2224
    • Просмотр профиля
Re: на 16.04 перестал работать TV тюнер
« Ответ #2 : 17 Август 2016, 21:17:54 »
В 16.04 же нету проприетарного драйвера для радеона.

Оффлайн rgkor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: на 16.04 перестал работать TV тюнер
« Ответ #3 : 18 Август 2016, 15:40:03 »
xvinfo
X-Video Extension version 2.2
screen #0
  Adaptor #0: "GLAMOR Textured Video"
    number of ports: 16
    port base: 63
    operations supported: PutImage
    supported visuals:
      depth 24, visualID 0x21
    number of attributes: 5
      "XV_BRIGHTNESS" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_CONTRAST" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_SATURATION" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_HUE" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_COLORSPACE" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 0)
    maximum XvImage size: 8192 x 8192
    Number of image formats: 2
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)

lspci -k | grep VGA -A2
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti PRO [Radeon HD 7950/8950 OEM / R9 280]
Subsystem: Micro-Star International Co., Ltd. [MSI] Tahiti PRO [Radeon HD 7950/8950 OEM / R9 280]
Kernel driver in use: radeon


Пользователь добавил сообщение 18 Август 2016, 16:51:59:
После успешной установки этого драйвера:
http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Install.aspx

xvinfo
X-Video Extension version 2.2
screen #0
 no adaptors present

Пользователь добавил сообщение 18 Август 2016, 17:34:11:

dpkg -l amdgpu-pro

||/ Имя                     Версия           Архитектура      Описание
+++-=======================-================-================-===================================================
ii  amdgpu-pro              16.30.3-315407   amd64            This package install all amdgpu-pro components.

« Последнее редактирование: 18 Август 2016, 17:34:11 от rgkor »

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 1704
  • Kubuntu 12.04, 16.04, 18.04, 19.04
    • Просмотр профиля
Re: на 16.04 перестал работать TV тюнер
« Ответ #4 : 18 Август 2016, 23:56:48 »
rgkor, я не зря просил выхлоп xvinfo и lspci -k | grep VGA -A2. Они соответствуют друг другу и свидетельствуют о гарантированном запуске tvtime на свободном драйвере radeon. А на счет "amdgpu" у меня были сомнения, но у вас работает radeon. потому и правка 10-amdgpu.conf ничем помочь не могла.

На 16.04 со свободным radeon TVtime должен РАБОТАТЬ.

Устанавливать же AMDGPU-PRO Driver не имело никакого смысла, ибо ваша MSI R9 280 не входит в список поддерживаемых этим драйвером.
Я странен, а не странен кто ж? (С)

Оффлайн rgkor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: на 16.04 перестал работать TV тюнер
« Ответ #5 : 19 Август 2016, 06:36:34 »
У меня не так много квалификации по настройке видео.
Тем более, что раньше все работало из коробки.
Что я делаю дальше:

1.По инструкции от AMD - удаляю драйвер  AMDGPU-PRO.
(если нужно ставлю с 0 систему)

А что нужно дальше сделать, что бы tvtime запустился?

(после установки из коробки он не работает)
« Последнее редактирование: 19 Август 2016, 06:39:19 от rgkor »

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 1704
  • Kubuntu 12.04, 16.04, 18.04, 19.04
    • Просмотр профиля
Re: на 16.04 перестал работать TV тюнер
« Ответ #6 : 19 Август 2016, 13:12:41 »
rgkor, В вашем первом посте, к сожалению, приведен не полный вывод неудачного запуска tvtime. то что мы видим сейчас - стандартное ругательство, а основная причина находится над ним через пустую строку. Потрудитесь дополнить, может у вас какой-то уникальный случай, и тогда что-то проясниться.
Я странен, а не странен кто ж? (С)

Оффлайн rgkor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: на 16.04 перестал работать TV тюнер
« Ответ #7 : 19 Август 2016, 15:36:43 »

tvtime
Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/roman/.tvtime/tvtime.xml
xvoutput: No XVIDEO port found which supports YUY2 images.

*** tvtime requires hardware YUY2 overlay support from your video card
*** driver.  If you are using an older NVIDIA card (TNT2), then
*** this capability is only available with their binary drivers.
*** For some ATI cards, this feature may be found in the experimental
*** GATOS drivers: http://gatos.sourceforge.net/
*** If unsure, please check with your distribution to see if your
*** X driver supports hardware overlay surfaces.


Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 1704
  • Kubuntu 12.04, 16.04, 18.04, 19.04
    • Просмотр профиля
Re: на 16.04 перестал работать TV тюнер
« Ответ #8 : 19 Август 2016, 23:57:01 »
rgkor, Смотрите, строка xvoutput: No XVIDEO port found which supports YUY2 images. соответствует второму выводу xvinfo отсюда https://forum.ubuntu.ru/index.php?topic=281039.msg2212671#msg2212671, но никак не первому, если бы в нем в третьей строке вместо слова GLAMOR значилось Radeon.

Вы точно не производили никаких действия в системе над графическим стеком, после состояния "не из коробки"?

Вот ссылка на проблему как у вас https://bugs.freedesktop.org/show_bug.cgi?id=84478.
Я странен, а не странен кто ж? (С)

Оффлайн rgkor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: на 16.04 перестал работать TV тюнер
« Ответ #9 : 20 Август 2016, 07:58:15 »
Для получения системы без модификации загрузился с установочного диска.

xvinfo
X-Video Extension version 2.2
screen #0
  Adaptor #0: "GLAMOR Textured Video"
    number of ports: 16
    port base: 63
    operations supported: PutImage
    supported visuals:
      depth 24, visualID 0x21
    number of attributes: 5
      "XV_BRIGHTNESS" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_CONTRAST" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_SATURATION" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_HUE" (range -1000 to 1000)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_COLORSPACE" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 0)
    maximum XvImage size: 8192 x 8192
    Number of image formats: 2
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
- То же самое.

Во вложении лог xorg.
Там упоминается драйвер radeon.

Всем огромное спасибо за ответы.
Если ничего не получится поставлю 15.10 с рабочим драйвером.
« Последнее редактирование: 20 Август 2016, 08:34:34 от rgkor »

Оффлайн AlexBKost

  • Старожил
  • *
  • Сообщений: 1704
  • Kubuntu 12.04, 16.04, 18.04, 19.04
    • Просмотр профиля
Re: на 16.04 перестал работать TV тюнер
« Ответ #10 : 20 Август 2016, 12:53:28 »
rgkor, можно еще Установить проприетарный драйвер AMD Crimson Edition 15.12 в Ubuntu 16.04 https://www.opennet.ru/tips/info/2977.shtml#14, правда это связано с откатом Иксов, что многими признается не совсем кошерным, но как вариант лучше чем 15.10 - там поддержка уже прекращена https://lists.ubuntu.com/archives/ubuntu-security-announce/2016-July/003492.html.
Я странен, а не странен кто ж? (С)

Оффлайн rgkor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: на 16.04 перестал работать TV тюнер
« Ответ #11 : 20 Август 2016, 15:49:19 »
Спасибо за помощь! Тему можно закрыть!

 

Страница сгенерирована за 0.06 секунд. Запросов: 24.