Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: После обновления выросла частота процессора  (Прочитано 1196 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlphaGeo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Решился обновиться с 14.04 на 16.04 (Xubuntu). Всё прошло без каких-либо проблем и функционирует нормально. Однако я заметил, что возросла частота процессора: при нагрузке 1-3% держится около максимального значения 3700 Мгц и иногда опускается к минимальным 800 (процессор Intel Core i3-4170). На 14.04 такого никогда не замечал, да и температура процессора теперь выросла на 3-5 градусов от "обычных".
В качестве временной меры понизил максимальную частоту процессора до 2400.
cpufreq-info выдаёт следующую информацию:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.00 ms.
  hardware limits: 800 MHz - 3.70 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 800 MHz and 2.40 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
  current CPU frequency is 2.30 GHz.
Среди доступных режимов нет ondemand и conservative. Хотя не уверен, что они помогли бы решить проблему, ведь даже в режиме powersave процессор не стесняется разгоняться на полную.
В BIOS выставил режим работы системы на "экономичный" — никакого эффекта не принесло.
Хотелось бы спросить, есть ли возможность отрегулировать сам режим работы powersave, чтобы процессор так не "жёг", и если да, то как это сделать?
« Последнее редактирование: 22 Август 2016, 18:33:45 от AlphaGeo »

Оффлайн suslikk

  • Старожил
  • *
  • Сообщений: 2367
    • Просмотр профиля
AlphaGeo, а видюха есть?
Нарисуй свой город на openstreetmap.org

Оффлайн AlphaGeo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
AlphaGeo, а видюха есть?
Да, видео GeForce GT730, драйвер от Nvidia 361.42. Нормально работает, не из консоли сейчас пишу :-)
Вообще, почитал Хабр… Можно, конечно, заморочиться с cpufreqd, но как-то не хотелось бы. Куда ж подевались режимы ondemand и conservative?
И, что подозрительно, все статьи в интернете на эту тему мне только от 2010 года попадались. Может, что-то при обновлении недоустановилось?

Оффлайн ALiEN175

  • Старожил
  • *
  • Сообщений: 2220
  • X-9000SC
    • Просмотр профиля
попробуйте принудительно
Код: Bash
  1. echo conservative | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

То, что в доступных режимах нет conservative/ondemand, не значит, что его нельзя выставить.
У меня тоже нет conservative, но я его могу поставить:
(Нажмите, чтобы показать/скрыть)
Благодарности на Yandex 41001488642430. Cпасибо.

Оффлайн AlphaGeo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
попробуйте принудительно
Код: Bash
  1. echo conservative | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

То, что в доступных режимах нет conservative/ondemand, не значит, что его нельзя выставить.

Не-а :-( Так я и раньше "тыкал" — надо было сразу написать…
echo conservative | sudo tee /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
conservative
tee: /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor: Недопустимый аргумент

То же самое через cpufreq-set:
sudo cpufreq-set -g conservative
Error setting new values. Common errors:
- Do you have proper administration rights? (super-user?)
- Is the governor you requested available and modprobed?
- Trying to set an invalid policy?
- Trying to set a specific frequency, but userspace governor is not available,
   for example because of hardware which cannot be set to a specific frequency
   or because the userspace governor isn't loaded?
С ondemand аналогично.

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1179
  • Ubuntu 14.04 LTS
    • Просмотр профиля
AlphaGeo, у Вас Intel P-State вроде работает.
cpupower frequency-infoЧто показывает?

Пользователь добавил сообщение 22 Август 2016, 18:30:47:
В 14.04 pstate по умолчанию был отключен, в 16.04, возможно, работает из коробки.
« Последнее редактирование: 22 Август 2016, 18:30:47 от Tear »

Оффлайн AlphaGeo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
AlphaGeo, у Вас Intel P-State вроде работает.
Это хороший знак?

Цитата: Tear
cpupower frequency-infoЧто показывает?
Я так понимаю, cpupower аналогична cpufrequtils, и я выше информацию от последней приводил, но вот, пожалуйста:
cpupower frequency-info
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.00 ms.
  hardware limits: 800 MHz - 3.70 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 800 MHz and 2.40 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
  current CPU frequency is 2.30 GHz.
  boost state support:
    Supported: no
    Active: no
Последние две строки настораживают…

Цитата: Tear
В 14.04 pstate по умолчанию был отключен, в 16.04, возможно, работает из коробки.
Значит pstate следует отключить?

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1179
  • Ubuntu 14.04 LTS
    • Просмотр профиля
Значит pstate следует отключить?
Зачем? Эта технология регулирует тепловыделение, тактовую частоту и питание процессоров от Intel. Я бы с ней разбирался. Возможно, просто нужно настроить.

Если всё же хотите отключить, то, думаю, в /etc/default/grub нужно дописать intel_pstate=disable (в Ubuntu 14.04, чтобы включить, нужно было писать intel_pstate=enable). Примерно так:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_pstate=disable"

Потом sudo update-grub и перезагрузиться.

Сам проверить не могу, потому что у меня процессор от AMD и версия ОС другая, так что на свой страх и риск.

Я бы не отключал, наверное.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Tear,
Не нужно intel_pstate отключать. Это очень хорошо работающая технология. Там нет ondemand, но его и не нужно.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1179
  • Ubuntu 14.04 LTS
    • Просмотр профиля
Pilot6, да я согласен. Я бы не отключал.

Оффлайн AlphaGeo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Не нужно intel_pstate отключать. Это очень хорошо работающая технология. Там нет ondemand, но его и не нужно.
Не берусь спорить, и мало что понимаю в электронике, но мне почему-то кажется, что если устройство используя данную технологию работы выделяет больше тепла, то оно и больше энергии потребляет, следовательно с проблемой экономного энергопотребления справляется хуже.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Я не знаю в чем суть вашей проблемы, и есть ли проблема вообще. Но интеловский проц в режиме conservative потребляет меньше, чем в режиме powersave.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн AlphaGeo

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Но интеловский проц в режиме conservative потребляет меньше, чем в режиме powersave.
Где-то здесь опечатка?

Оффлайн ALiEN175

  • Старожил
  • *
  • Сообщений: 2220
  • X-9000SC
    • Просмотр профиля
AlphaGeo, вот и ответ: intel pstate и cpufreq - разные вещи. Либо управляете c помощью pstate, либо cpufreq
Благодарности на Yandex 41001488642430. Cпасибо.

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1179
  • Ubuntu 14.04 LTS
    • Просмотр профиля
Не берусь спорить, и мало что понимаю в электронике, но мне почему-то кажется, что если устройство используя данную технологию работы выделяет больше тепла, то оно и больше энергии потребляет, следовательно с проблемой экономного энергопотребления справляется хуже.
Понимаете, в Ubuntu 16.04 произошли изменения в пакетной базе. Поэтому с чем связано повысившееся тепловыделение, сказать сразу сложно. Это можно установить путём проб и экспериментов. С другой стороны, в Ubuntu 14.04 pstate был отключен по умолчанию не просто так, вроде как не всегда хорошо работал (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1188647). В 15.04 вроде пофиксили, и если у Вас процессор уходит в режим powersave, то должно быть нормально. Вот здесь человек пишет, что старый драйвер cpufreq всё равно не позволяет управлять частотами Вашего процессора. Так что если рост температуры некритичен, я бы оставил как есть.
Если всё же хочется экспериментировать, то можно попытаться отключить pstate и посмотреть, как изменится тепловыделение. Но я бы не заморачивался, вряд ли оно того стоит.
« Последнее редактирование: 23 Август 2016, 05:12:11 от Tear »

 

Страница сгенерирована за 0.075 секунд. Запросов: 24.