Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Битые пакеты\Wine  (Прочитано 383 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sling

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Битые пакеты\Wine
« : 27 Август 2016, 19:14:42 »
Доброго времени суток. Какой день бьюсь с установкой винишка на ubuntu 16.04
uname -a
Linux lenovo 4.4.0-34-generic #53-Ubuntu SMP Wed Jul 27 16:06:39 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
sources.list:
(Нажмите, чтобы показать/скрыть)
sat@lenovo:~$ sudo apt-get install wine
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 wine : Зависит: wine1.6
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
Следуем совету
sat@lenovo:~$ sudo apt-get install wine1.6
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 wine1.6 : Зависит: wine1.6-i386 (= 1:1.6.2-0ubuntu14)
           Рекомендует: fonts-droid но он не может быть установлен
           Рекомендует: ttf-mscorefonts-installer но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
И так далее.
В системе было несколько ядер, вычистил, осталось только 34:
sudo apt-get purge $(dpkg -l 'linux-*' | sed '/^ii/!d;/'"$(uname -r | sed "s/\(.*\)-\([^0-9]\+\)/\1/")"'/d;s/^[^ ]* [^ ]* \([^ ]*\).*/\1/;/[0-9]/!d' | head -n -1)
Загружался в recovery mode, исправлял битые пакеты, не помогает.
sudo apt-get -f install и dpkg --configure -a тоже не помогает
Может я делаю что не то, пробовал читать похожие топики, не выходит :idiot2:

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26080
    • Просмотр профиля
Re: Битые пакеты\Wine
« Ответ #1 : 27 Август 2016, 19:38:00 »
apt-get update делали?
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Sling

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Re: Битые пакеты\Wine
« Ответ #2 : 27 Август 2016, 19:41:46 »
Само собой  ;D
Но не помогло
« Последнее редактирование: 27 Август 2016, 19:49:04 от Sling »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 26080
    • Просмотр профиля
Re: Битые пакеты\Wine
« Ответ #3 : 27 Август 2016, 19:55:52 »
apt-cache show wine
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Sling

  • Автор темы
  • Любитель
  • *
  • Сообщений: 53
    • Просмотр профиля
Re: Битые пакеты\\Wine
« Ответ #4 : 27 Август 2016, 20:01:37 »
sat@lenovo:~$ apt-cache show wine
Package: wine
Priority: extra
Section: universe/otherosfs
Installed-Size: 6
Maintainer: Scott Ritchie <scottritchie@ubuntu.com>
Architecture: amd64
Source: wine1.6
Version: 1:1.6.2-0ubuntu14
Depends: wine1.6
Filename: pool/universe/w/wine1.6/wine_1.6.2-0ubuntu14_amd64.deb
Size: 974
MD5sum: bea5bed393084b4406fcda336325bc71
SHA1: 12cb87640d0cb8a707ce2e89ebd872e5e32c8c9b
SHA256: ab68e0b0f6122e5d189171242a3fc706cd8689ed45feb25b3140530f17c81188
Description-ru: Microsoft Windows Compatibility Layer (meta-package)
 Wine - это слой совместимости для запуска программ Windows под Linux.
 Программы работают без потери скорости и без эмуляции. Wine не требует
 наличия Microsoft Windows, хотя может использовать системные файлы Windows
 вместо своих собственных.
 .
 This meta-package always depends on the default version of Wine.
Description-md5: 6474b3e541944944e61aec502ceb28f2
Multi-Arch: foreign
Homepage: http://www.winehq.org/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

Пользователь добавил сообщение 28 Август 2016, 10:04:18:
Проблема решилась даунгрейдом некоторых пакетов
sudo aptitude install wine1.6
...........

     Remove the following packages:                         
1)     libgfortran3                                         

     Downgrade the following packages:                       
2)     gcc-6-base [6.1.1-9 (now) -> 6.0.1-0ubuntu1 (xenial)]
3)     libblas3 [3.6.1-1 (now) -> 3.6.0-2ubuntu2 (xenial)]   
4)     libgcc1 [1:6.1.1-9 (now) -> 1:6.0.1-0ubuntu1 (xenial)]

« Последнее редактирование: 28 Август 2016, 10:04:18 от Sling »

 

Страница сгенерирована за 0.056 секунд. Запросов: 24.