Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?  (Прочитано 1127 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн JusTsar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« : 14 Сентябрь 2016, 16:47:14 »
Ребята помогите, не могу обновить ядро, выдает такую ошибку. Сейчас стоит Ubuntu Xenial (16.04 LTS) (GNU/Linux 4.5.7-std-3 x86_64 ).

Оффлайн zotkindm

  • Старожил
  • *
  • Сообщений: 2452
  • (K)Ub 14.04
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #1 : 14 Сентябрь 2016, 17:19:56 »
1. Обновляй через synaptic.
2. Зачем?

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #2 : 14 Сентябрь 2016, 19:52:37 »
JusTsar,
Ядро состоит из нескольких пактов, которые надо ставить вместе. А вообще не понятно зачем вы вообще это затеяли, если таких вещей не понимаете.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн JusTsar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #3 : 14 Сентябрь 2016, 21:28:52 »
1. Обновляй через synaptic.
2. Зачем?
1. А через apt никак, какая разница то?
2. А зачем выходят обновления? Не просто так наверно....
Ядро состоит из нескольких пактов, которые надо ставить вместе.
Ну так я и ставлю linux-headers и linux-image для своей архитектуры. Что я делаю не так?
А вообще не понятно зачем вы вообще это затеяли, если таких вещей не понимаете.
Я многих вещей не понимаю пока что в убунте и делаю в основном, как пишут в интернетах, ибо недавно поставил и хотелось бы немного освоится. Раз обновления выходят, что то же в них фиксится и улучшается, исправляются ошибки и баги.... И что плохого в том, чтобы держать ядро в актуальном состояние?

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #4 : 14 Сентябрь 2016, 21:36:01 »
JusTsar,
Цитировать
А зачем выходят обновления? Не просто так наверно....
Это какие-такие обновления "выходят"? В Ubuntu не поддерживаются ядра 3.5, 3.7 и т.д. Вместо этого нужные патчи попадают в официальные ядра. Вы вкорячиваете зачем-то неподдерживаемые ядра и находите при этом проблемы.
Я советую все это удалить и устанвливать официальные обновления, для чего ничего сложного делать не надо.

Установка нестандартных ядер нужна для тестирования или решения специфических проблем. Просто так "от нечего делать" ядра устанавливать не надо.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн JusTsar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #5 : 14 Сентябрь 2016, 22:04:40 »
Это какие-такие обновления "выходят"? В Ubuntu не поддерживаются ядра 3.5, 3.7 и т.д.
Я советую все это удалить и устанвливать официальные обновления
А здесь что появляется, не офф версии ядер линукса? И как они могут не поддерживаться (3.5, 3.7), если по ссылке что я дал они там есть?))
Вы советуете удалить что, то что я пытался установить linux-headers-4.7.3-040703-generic и linux-image-4.7.3-040703-generic?
« Последнее редактирование: 14 Сентябрь 2016, 22:11:22 от JusTsar »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #6 : 14 Сентябрь 2016, 22:33:59 »
А здесь что появляется, не офф версии ядер линукса? И как они могут не поддерживаться (3.5, 3.7), если по ссылке что я дал они там есть?))
Здесь появляются сборки mainline ядре для тестирования и других целей. Они там совсем не для установки в рабочие системы.
Я советую удалить и 4.7.3, и 4.5 ядра.

Ядра из mainline не предназначены для Ubuntu.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн www777

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2594
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #7 : 14 Сентябрь 2016, 23:10:51 »
А я советую отформатировать диск, с системой. Наивно полагать, что он туда только лишь не поддерживаемые ядра вкорячил...

Оффлайн JusTsar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #8 : 14 Сентябрь 2016, 23:34:02 »
Я советую удалить и 4.7.3, и 4.5 ядра.
4.7.3 не установилось же, поэтому удалять нечего, кроме .deb пакетов. А 4.5 как я удалю то, у меня из образа Ubuntu на моем VPS с этим ядром устанавливается.
А я советую отформатировать диск, с системой. Наивно полагать, что он туда только лишь не поддерживаемые ядра вкорячил...
Оригинальный совет, спс! Если принять во внимание, что это удаленный сервер и на нем есть данные. ???
Можете и дальше "наивно полагать", но кроме sudo apt-get update и sudo apt-get upgrade ничего не делалось. А ядра так и не "вкорячились". И к слову, если ядра не поддерживаемые, то как у меня сейчас 4.5.7 стоит и все отлично работает? :)

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #9 : 14 Сентябрь 2016, 23:37:45 »
А 4.5 как я удалю то, у меня из образа Ubuntu на моем VPS с этим ядром устанавливается.
Эта фраза не понятна. Что за VPS? На VPS вообще ядра таким образом не обновляются. Про VPS раньше речи вообще не было.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн www777

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2594
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #10 : 14 Сентябрь 2016, 23:43:29 »
Цитировать
И к слову, если ядра не поддерживаемые, то как у меня сейчас 4.5.7 стоит и все отлично работает?
Очень просто, пусть у вас всё замечательно работает, делайте как вам удобно, только в таком случае, воздержитесь, от публикации своих проблем на форуме.

Оффлайн JusTsar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #11 : 15 Сентябрь 2016, 00:08:23 »
Что за VPS? На VPS вообще ядра таким образом не обновляются. Про VPS раньше речи вообще не было.
Есть разница в обновление ядер у десктопного и серверного варианта Ubuntu?
Очень просто, пусть у вас всё замечательно работает, делайте как вам удобно, только в таком случае, воздержитесь, от публикации своих проблем на форуме.
Это почему я должен воздерживаться от публикаций? :o
Вроде, для этого существует форум и есть раздел для новичков, чтобы задавать интересующие новичков вопросы. И будьте добры, проясните предыдущий вопрос для новичка. Потому что вы говорите что он "вкорячил" не поддерживаемые ядра и что то мне подсказывает, что по логике вещей, когда ядра не поддерживаемые, то ОС работать не должна в таком случае. Но она почему то работает на не поддерживаемом ядре 4.5.7! :-\

Оффлайн www777

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 2594
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #12 : 15 Сентябрь 2016, 00:11:32 »
Цитировать
Есть разница в обновление ядер у десктопного и серверного варианта Ubuntu?
Нет
Цитировать
что по логике вещей, когда ядра не поддерживаемые, то ОС работать не должна в таком случае.
Мне вас искренне жаль, но я вам помочь не смогу. У меня не такой логики как у вас.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #13 : 15 Сентябрь 2016, 00:13:19 »
Есть разница в обновление ядер у десктопного и серверного варианта Ubuntu?
Между дескотопным и серверным вариантом разницы нет. А вот между обычной установкой и VPS разница обычно есть. На VPS вместо grub что-то другое обычно стоит. Поэтому загрузиться с другим ядром можно из меню VPS, а просто так нельзя.
И будьте добры, проясните предыдущий вопрос для новичка. Потому что вы говорите что он "вкорячил" не поддерживаемые ядра и что то мне подсказывает, что по логике вещей, когда ядра не поддерживаемые, то ОС работать не должна в таком случае. Но она почему то работает на не поддерживаемом ядре 4.5.7!
Неподдерживаемое ядро не означает, что система обязательно не будет работать. Это означают, что проблемы с этими ядрами не поддерживаются Canonical и сообществом. Вы можете ставить эти ядра на свой страх и риск, но не ожидайте, что вам будут с этим помогать.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн JusTsar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Не могу обновить ядро, Ubuntu Xenial 16.04 LTS?
« Ответ #14 : 15 Сентябрь 2016, 01:09:33 »
Мне вас искренне жаль, но я вам помочь не смогу. У меня не такой логики как у вас.
Что то сомневаюсь я вашей жалости, скорее чсв зашкаливает.... А помочь бы вы смогли и объяснить толком, как это делает Pilot6, за что ему огромное спасибо! Но у вас увы, другая же логика....  :P
А вот между обычной установкой и VPS разница обычно есть. На VPS вместо grub что-то другое обычно стоит. Поэтому загрузиться с другим ядром можно из меню VPS, а просто так нельзя.
А теперь понятно, не знал таких тонкостей про VPS. Надо было еще в 1м посте добавить, что Ubuntu стоит на VPS. И если я правильно понимаю, это меню с которого можно загрузиться доступно только хостеру? :(
Неподдерживаемое ядро не означает, что система обязательно не будет работать. Это означают, что проблемы с этими ядрами не поддерживаются Canonical и сообществом. Вы можете ставить эти ядра на свой страх и риск, но не ожидайте, что вам будут с этим помогать.
Ах вот оно что!)) А где можно узнать какие поддерживаются ядра, а какие нет?

 

Страница сгенерирована за 0.065 секунд. Запросов: 24.