Форум русскоязычного сообщества Ubuntu


Автор Тема: W2KSP4_EN.EXE\Wine 1.8\проблема с запуском  (Прочитано 1896 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ConnaiSSant

  • Автор темы
  • Активист
  • *
  • Сообщений: 458
    • Просмотр профиля
W2KSP4_EN.EXE\Wine 1.8\проблема с запуском
« : 25 Сентябрь 2016, 21:24:33 »
Всем привет. Проблема с W2KSP4, файл не найден. Но если скачать вручную и поместить в директорию .cache/winetricks/win2ksp4 и запустить его, то выдает ошибку о несоответствии версии виндовс и устанавливаемого ПО

Пользователь добавил сообщение 25 Сентябрь 2016, 21:25:12:
В Вайн выбрана версия виндуса - винхп
wine1.8

Отредактировал название темы в соответствии с Правилами создания тем
Butjapka
« Последнее редактирование: 26 Октябрь 2016, 22:27:39 от Butjapka »

Оффлайн ReNzRv

  • Старожил
  • *
  • Сообщений: 1971
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #1 : 25 Сентябрь 2016, 21:38:37 »
Цитировать
W2KSP4, файл не найден
Что ты запускаешь?

Оффлайн ConnaiSSant

  • Автор темы
  • Активист
  • *
  • Сообщений: 458
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #2 : 26 Сентябрь 2016, 07:19:59 »
W2ksp4_ru.exe

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2515
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #3 : 26 Сентябрь 2016, 07:34:29 »
ConnaiSSant, в заголовке у тебя  W2KSP4_EN.EXE, запускаешь ты W2ksp4_ru.exe, а в Wine у тебя выбрана WinXP.  Зоопарк, в общем. Какого результата ты хочешь добиться?

(W2ksp4 - это 4-й сервиспак для Windows 2000, если что; на WinXP он и не должен устанавливаться).
Я никого не сторожил!

Оффлайн ConnaiSSant

  • Автор темы
  • Активист
  • *
  • Сообщений: 458
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #4 : 26 Сентябрь 2016, 09:03:08 »
En - ru локализация. Устанавливается в зависимости от языка системы и без разницы как я тут назвал, это сути не меняет. Пробовал ставить win2000, тоже самое. Вот и решил ут спросить. На локаль забейте, не  в этом дело. Если не совпадает локаль , то ошибка другая будет.


Пользователь добавил сообщение 26 Сентябрь 2016, 09:05:06:
ConnaiSSant, в заголовке у тебя  W2KSP4_EN.EXE, запускаешь ты W2ksp4_ru.exe, а в Wine у тебя выбрана WinXP.  Зоопарк, в общем. Какого результата ты хочешь добиться?

(W2ksp4 - это 4-й сервиспак для Windows 2000, если что; на WinXP он и не должен устанавливаться).


Поле того, как в winecfg выставил win2000 - нужно еще что нибудь нажать (кроме применить и окей) ? Или сразу заработает?

Пользователь добавил сообщение 26 Сентябрь 2016, 09:06:44:
Результат - танки запустить. В хауту просят ставить сп4
« Последнее редактирование: 26 Сентябрь 2016, 09:06:44 от ConnaiSSant »

Оффлайн ReNzRv

  • Старожил
  • *
  • Сообщений: 1971
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #5 : 26 Сентябрь 2016, 11:25:18 »
Паки обновлений и прочее ставится через winetricks.

Цитировать
Поле того, как в winecfg выставил win2000 - нужно еще что нибудь нажать (кроме применить и окей) ? Или сразу заработает?
man wineboot
Пользователь добавил сообщение 26 Сентябрь 2016, 11:28:10:
Цитировать
танки запустить
танки только на вин 2к? о_О
« Последнее редактирование: 26 Сентябрь 2016, 11:28:10 от renzrv »

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2515
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #6 : 26 Сентябрь 2016, 11:29:09 »
En - ru локализация. Устанавливается в зависимости от языка системы и без разницы как я тут назвал

Еще какая разница есть. Но не суть.

"Танки" - это world of tanks?
На их форуме делятся несколькими способами настройки, включая специальную версию Wine, патченную под WoT. Заодно и никаких сервиспаков под давно умершую win2000 устанавливать не придется :)
К слову, и на этом форуме, кажется, была тема по WoT. Поищи.
Я никого не сторожил!

Оффлайн ConnaiSSant

  • Автор темы
  • Активист
  • *
  • Сообщений: 458
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #7 : 26 Сентябрь 2016, 13:18:45 »
Да инструкция есть в вики. Там сп4 нужно ставить, кстати. Сейчас проблема с обновлением сп4. Это единственное, что не установилось. Про winetricks в курсе.

Пользователь добавил сообщение 26 Сентябрь 2016, 13:22:43:
Цитировать
танки только на вин 2к? о_О

Не, но в инструкции на сей ресурсе именно сп4

Комп не мой (на моем стоят танки) galium-nine mesa wine в связке. И что то с этими обновлениями я застрял.

Пользователь добавил сообщение 26 Сентябрь 2016, 13:24:37:
К слову, и на этом форуме, кажется, была тема по WoT. Поищи.

Гляну еще раз. Спасибо.

Ребят, пока я гляжу на мануалы, если вдруг   кого нибудь осенит, дайте знать.
« Последнее редактирование: 26 Сентябрь 2016, 13:24:37 от ConnaiSSant »

Оффлайн eNdiD

  • Участник
  • *
  • Сообщений: 188
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #8 : 26 Сентябрь 2016, 18:20:44 »
Минимальная поддерживаемая версия Windows для танков - XP. Это значит, что на Windows 2000 они не заведутся, тем более в вайне. Где вы вообще такое нашли? Я бегло погуглил и не увидел ни одной инструкции, где бы в Wine предлагалось ставить версию Win 2000.

Оффлайн ConnaiSSant

  • Автор темы
  • Активист
  • *
  • Сообщений: 458
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #9 : 26 Сентябрь 2016, 18:29:52 »
Где вы вообще такое нашли? Я бегло погуглил и не увидел ни одной инструкции, где бы в Wine предлагалось ставить версию Win 2000.

http://help.ubuntu.ru/wiki/wot#настройка_wine_и_инсталляция_игры

Winetriscks тянет за собой




Пользователь добавил сообщение 26 Сентябрь 2016, 18:31:00:
winetricks d3dx9 vcrun2008 corefonts msxml6 wininet ie8

Где то тут он есть

Пользователь добавил сообщение 26 Сентябрь 2016, 18:35:52:
Если для w2ksp4  нужен win2000 то его и выставил в winecfg, а если дл танков не нужен вин2000 то зачем winetricks тянет из интернета sp4?
« Последнее редактирование: 26 Сентябрь 2016, 18:35:52 от ConnaiSSant »

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2515
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #10 : 26 Сентябрь 2016, 18:52:20 »
Если для w2ksp4  нужен win2000 то его и выставил в winecfg, а если дл танков не нужен вин2000 то зачем winetricks тянет из интернета sp4

А на каком этапе оно его тянет?
Я никого не сторожил!

Оффлайн ConnaiSSant

  • Автор темы
  • Активист
  • *
  • Сообщений: 458
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #11 : 26 Сентябрь 2016, 19:25:51 »
winetricks d3dx9 vcrun2008 corefonts msxml6 wininet ie8

На этом)) скорее всего wininet

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2515
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #12 : 26 Сентябрь 2016, 19:53:39 »
скорее всего wininet

Для того чтобы выяснить наверняка, нужно по одному компоненты устанавливать.
Я никого не сторожил!

Оффлайн ConnaiSSant

  • Автор темы
  • Активист
  • *
  • Сообщений: 458
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #13 : 26 Сентябрь 2016, 19:57:32 »
скорее всего wininet

Для того чтобы выяснить наверняка, нужно по одному компоненты устанавливать.

Можно просто погуглить)))
А что это нам даст?

Пользователь добавил сообщение 26 Сентябрь 2016, 20:00:34:
Я не в курсе почему не садиться пакет сп4 (всегда он ставился) даже на моем железе он требовался, я его качал отдельно и устанавливал, ибо он отсутствовал по ссылке, той что в winetricks.

Точно пню, всегда его ставил и никогда не выбирал вин2000. все раьотало. может от версии wine зависит?
« Последнее редактирование: 26 Сентябрь 2016, 20:00:34 от ConnaiSSant »

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2515
    • Просмотр профиля
Re: W2KSP4_EN.EXE не тот
« Ответ #14 : 26 Сентябрь 2016, 20:36:54 »
Можно просто погуглить)))

Можно просто поговорить о том, о сем. Но задача, вроде, программу заставить работать?
Префикс 32-битный?

может от версии wine зависит?

Это возможно. У меня wine 1.9 с хвостом, и в нем отсутствует сама возможность выбора win2000 в качестве имитируемой системы, выбор начинается с winxp. Попробуй более старый wine. Или более новый. Или не ставить проблемную библиотеку, а воспользоваться встроенной. Или через PoL. Установка виндовых программ в linux - всегда лотерея.
« Последнее редактирование: 26 Сентябрь 2016, 20:40:53 от alang »
Я никого не сторожил!

 

Страница сгенерирована за 0.063 секунд. Запросов: 24.