Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: [РЕШЕНО] Новый ноутбук перегревается, по-видимому, вина в драйвере видеокарты  (Прочитано 3341 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн InGenTech

  • Автор темы
  • Любитель
  • *
  • Сообщений: 67
    • Просмотр профиля
Итак, есть новый ноутбук: DELL, Inspiron 15; процессор и видеокарта от AMD - соответственно A10-8700P Radeon R6, 10 Compute Cores 4C+6G × 4 и гибридная графика, на сколько понял такова - Radeon R6 + Radeon R6 M345DX(или AMD Radeon (TM) R5 M335)
Из коробки стояла Ubuntu 14.04(может 14.04.1). Пытался обновить до 16.04, но происходит конфликт с версией ядра(скорее всего из-за того, что в Ubuntu 16.04 прекращена поддержка проприетарного https://www.linux.org.ru/news/ubuntu/12420747/page3 драйвера AMD(из коробки стоял именно он).
Есть инструмент восстановления до "из коробки 14.04." В итоге обновил до 14.04.5. Греется(до 70 градусов) и само собой шумит причём как на проприетарном, так и на свободном драйверах. При использовании свободного ещё один минус - недоступно стандартное разрешение 1366x768, доступно только 1024x768
Немного лечится этим http://askubuntu.com/questions/303234/dell-inspiron-5521-i7-3317u-fan-cpu-too-noisy
Переустанавливал проприетарный по инструкциям, изложенным help.ubuntu.ru
Пробовал изменять активную карту в настройках Catalyst, изменения, если и были, то крайне незначительны.

ОБНОВЛЕНО:
Так или иначе улучшил состояние ноутбука. Благодарю всех отписавшихся в теме, особенно Tear за его советы в личных сообщениях.
Итак, решил проблему для себя так. Установил 16.04. Ноут шумит, но безумного гула нет. Греется, но не до кипящей температуры.  Работать комфортно можно.
Вывод sensors, которые до установки(не обновления) 16.04 вообще не работали:
amdgpu-pci-0008
Adapter: PCI adapter
temp1:         +0.0°C  (crit =  +0.0°C, hyst =  +0.0°C)

radeon-pci-0300
Adapter: PCI adapter
temp1:            N/A  (crit = +120.0°C, hyst = +90.0°C)

k10temp-pci-00c3
Adapter: PCI adapter
temp1:        +70.8°C  (high = +70.0°C)
                       (crit = +100.0°C, hyst = +99.0°C)

fam15h_power-pci-00c4
Adapter: PCI adapter
power1:       51.10 mW (crit =  15.00 W)

dell_smm-virtual-0
Adapter: Virtual device
Other Fan:   4000 RPM
CPU:          +72.0°C 
GPU:           +2.0°C 
SODIMM:       +42.0°C
« Последнее редактирование: 23 Октябрь 2016, 08:06:25 от InGenTech »

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1177
  • Ubuntu 14.04 LTS
    • Просмотр профиля
В 14.04.5 та же версия ядра и иксов, что и в 16.04. Устанавливайте 14.04.1 и пользуйтесь спокойно.

Оффлайн InGenTech

  • Автор темы
  • Любитель
  • *
  • Сообщений: 67
    • Просмотр профиля
В 14.04.5 та же версия ядра и иксов, что и в 16.04. Устанавливайте 14.04.1 и пользуйтесь спокойно.
Т.е. советуете избежать обновлений ядра и X-сервера. Но как? Наглухо отключить обновление системы и программ?
Всё ж нужны важные обновления безопасности и рекомендованные.
« Последнее редактирование: 28 Сентябрь 2016, 17:32:33 от InGenTech »

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1177
  • Ubuntu 14.04 LTS
    • Просмотр профиля
Если установите 14.04.1, при обновлениях версия расти не будет. Обновления будут идти нормально до 2019 года. Сможете установить тот проприетарный драйвер, который работал.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
InGenTech,
Если вы поставите Ubuntu 14.04 без точек, ядро не обновится до 4.4 само, даже если вы будете ставить все обновления.
Ставьте "оригинальную" 14.04, и проблем не будет.

Ну и конечно можно поставить 16.04, разобравшись в чем проблема.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2508
    • Просмотр профиля
"Наглухо" не обязательно, достаточно заблокировать проблемные пакеты. Делается это либо через Synaptic, либо в терминале командой
sudo apt-mark hold <имя_пакета>
Я никого не сторожил!

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1177
  • Ubuntu 14.04 LTS
    • Просмотр профиля
alang, зачем что-то блокировать? Оно и так будет нормально и нужные обновления будет получать

Оффлайн InGenTech

  • Автор темы
  • Любитель
  • *
  • Сообщений: 67
    • Просмотр профиля
Ещё добавлю. Была 14.04(ну или, опять же 14.04.1) встроенная. Сделал как с завода после покупки с
помощью DELL Recovery. Не изменял источников обновлений. Просила обновлений на около 700 mb. Обновлял Update manager.  Он завис на пакете grub-efi-amd64. Исправлял по-всякому через терминал(update + upgrade + confiure --a). Итак, несколько раз.

Система работала, но уже как 14.04.5, с уже упомянутыми проблемами. Ещё была проблема невхода в систему, не загружался рабочий стол informatikum.ru/blog/ubuntu-cant-load: здесь думаю был конфликт с LightDM(может, недостановленного), драйвера. Из окна авторизации вход в консоль через Ctrl + Alt + F1 не работал, решал восстановлением в первоначальное состояние в меню GRUB.

Хотелось бы просто поработать на системе, с которой купил. Не ставить начисто или даже dual-boot, корректируя разделы диска, думаю, не профессионально.
« Последнее редактирование: 29 Сентябрь 2016, 12:37:35 от InGenTech »

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1177
  • Ubuntu 14.04 LTS
    • Просмотр профиля
Ну это несколько меняет дело. Нужно смотреть версию ядра.

Оффлайн InGenTech

  • Автор темы
  • Любитель
  • *
  • Сообщений: 67
    • Просмотр профиля
Tear, сейчас 3.13.0-96-generic, работает и шумит, драйвер проприетарный - качество изображение хорошее.
Уже писал про то, как не раз Менеджер обновлений зависал на обработке(установка, видимо) grub-efi-amd64 при обновлении  с 14.04(.1?) -> 14.04.5, 3.13.0-38-generic -> 3.13.0-96-generic
Отмечу, что недолго работал при дефолтной системе, но так откровенно комп не гудел точно.

Состояние драйверов таково
« Последнее редактирование: 28 Сентябрь 2016, 20:17:03 от InGenTech »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
InGenTech,
Сейчас с драйверами полный порядок. Переключите не встроенную карту из catalyst.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Tear

  • Старожил
  • *
  • Сообщений: 1177
  • Ubuntu 14.04 LTS
    • Просмотр профиля
А состояние "из коробки" восстановить сейчас можете? На ноуте рекавери-раздел? Если да, то я бы сделал восстановление в первоначальное состояние и для начала сделал бы бэкап жёсткого диска со всеми разделами на всякий случай. Потом провёл бы обычное обновление и пытался решить проблему, имея резервную копию в запасе. А то по Вашему описанию проблем целая куча.

Оффлайн InGenTech

  • Автор темы
  • Любитель
  • *
  • Сообщений: 67
    • Просмотр профиля
Pilot6, в Catalyst Control Center включён высокопроизводительный GPU, шумит. Переключил на энергосберегающий, перезагрузился.
Ещё маленькая проблемка, связанная. Не работает охлаждающая подставка DeepCool(сейчас, правда, работает). Перестановка в другие порты USB не помогает.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
Tear,
Так похоже, что это и есть оно самое, первоначальное состояние.
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 11169
    • Просмотр профиля
в Catalyst Control Center включён высокопроизводительный GPU, шумит. Переключил на энергосберегающий, перезагрузился.
Ну так проблема с шумом решена?

Ещё маленькая проблемка, связанная. Не работает охлаждающая подставка DeepCool(сейчас, правда, работает). Перестановка в другие порты USB не помогает.
С чем эта проблемка связана? И какое отношение она вообще имеет к Ubuntu?
Я в личке не консультирую. Вопросы задавайте на форуме.

 

Страница сгенерирована за 0.07 секунд. Запросов: 24.