Форум русскоязычного сообщества Ubuntu


Автор Тема: Что то сломалось :(  (Прочитано 273 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SaIvAl

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Что то сломалось :(
« : 08 Октябрь 2016, 07:55:20 »
Не работает декстоп, а точнее сам процесс входа в систему под основным пользователем, при входе моргает экран и выбрасывает обратно к вводу пароля. Входить как гость могу.

Во время загрузки стали появляться не понятные мне строчки... вот и все собственно говоря

https://drive.google.com/open?id=0Bxh2A80TLZx_MVhSMHl6amJsbUk[

Дистрибутив : Ubuntu 16.04 lts

Оффлайн alang

  • Старожил
  • *
  • Сообщений: 2515
    • Просмотр профиля
Re: Что то сломалось :(
« Ответ #1 : 08 Октябрь 2016, 08:29:32 »
cat /etc/fstab

Вывод сюда под спойлер.
Я никого не сторожил!

Оффлайн SaIvAl

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Re: Что то сломалось :(
« Ответ #2 : 08 Октябрь 2016, 08:48:49 »
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 08 Октябрь 2016, 08:50:39 от SaIvAl »

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3109
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: Что то сломалось :(
« Ответ #3 : 08 Октябрь 2016, 09:14:34 »
SaIvAl,
1) А чего у вас 2 корня? На sda2 и sda3 или я чего-то не знаю?
2) надо бы сделать fsck для sda3.
3) после загрузки зайдите в tty1 под своим пользователем и выполните
Код: Bash
  1. mv .config .config.old
  2.  
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн SaIvAl

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Re: Что то сломалось :(
« Ответ #4 : 08 Октябрь 2016, 10:04:05 »
Цитировать
после загрузки зайдите в tty1 под своим пользователем и выполните
Не срабатывает. Пишет строку с непонятными символами.
Цитировать
надо бы сделать fsck для sda3.
все в порядке с ним.

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3109
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: Что то сломалось :(
« Ответ #5 : 08 Октябрь 2016, 10:05:59 »
SaIvAl, классно. Ну а почему у вас два / (рут раздела) подсказать можете? Может какой-то из них все же должен быть /home ?
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн SaIvAl

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Re: Что то сломалось :(
« Ответ #6 : 08 Октябрь 2016, 10:08:51 »
Цитировать
SaIvAl, классно. Ну а почему у вас два / (рут раздела) подсказать можете? Может какой-то из них все же должен быть /home ?
Вполне возможно) как я это могу сделать сейчас? и должно ли это как то повлиять?

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3109
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: Что то сломалось :(
« Ответ #7 : 08 Октябрь 2016, 10:21:03 »
SaIvAl, ну тут берете LiveCD / Flash. Загружаетесь, смотрите что и на каком диске у вас на родной системе. Исправляете на рабочей системе /etc/fstab
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн SaIvAl

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Re: Что то сломалось :(
« Ответ #8 : 08 Октябрь 2016, 10:36:53 »
Цитировать
Исправляете на рабочей системе /etc/fstab
Можно по подробнее?

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3109
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: Что то сломалось :(
« Ответ #9 : 08 Октябрь 2016, 11:08:42 »
SaIvAl, ну вы же откуда-то скопировали "оптимизацию" =)

После загрузки с лайв сд монтируете рут раздел основной системы куда-либо (можете глянуть как это делается в вики на тему восстановление загрузчика)

Открываете <mount point>/etc/fstab в редакторе с правами рута.

Вносите изменения:

на одной из строк у вас должно быть

Код: INI
  1. UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx /home ext4 defaults,noatime,data=writeback 0 2
  2.  

Где xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx - UUID реального раздела (можете глянуть через gparted, на LiveCD присутствует)

P.S. И на будущее, не следует слепо следовать советам, если не понимаете, к чему это может привести.

P.P.S. С ядра 4.0 можно использовать директиву lazytime вместо noatime, так как в noatime есть некоторые "болезни"
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн SaIvAl

  • Автор темы
  • Новичок
  • *
  • Сообщений: 19
    • Просмотр профиля
Re: Что то сломалось :(
« Ответ #10 : 08 Октябрь 2016, 14:34:09 »
Цитировать
SaIvAl, ну вы же откуда-то скопировали "оптимизацию" =)
Будет мне уроком)

Все решено, переустановил ось, а проблема найдена верно, спасибо за помощь.

 

Страница сгенерирована за 0.066 секунд. Запросов: 24.