Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может  (Прочитано 3942 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн akhur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
sudo apt-get install php5-fpm
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 libpam-modules : ПредЗависит: debconf (>= 0.5) но он не будет установлен или
                                          debconf-2.0
                  ПредЗависит: libpam-modules-bin (= 1.1.8-3.2ubuntu2)
                  Рекомендует: update-motd но он не будет установлен
 libpam0g : Зависит: debconf (>= 0.5) но он не будет установлен или
                            debconf-2.0
 php5-fpm : ПредЗависит: dpkg (>= 1.15.7.2~)
            Зависит: libssl1.0.0 (>= 1.0.0) но он не будет установлен
            Зависит: php5-common (= 5.3.10-1ubuntu3.25) но он не будет установлен
            Зависит: ucf но он не будет установлен
            Зависит: tzdata но он не будет установлен
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.

Оффлайн skybour

  • Старожил
  • *
  • Сообщений: 2224
    • Просмотр профиля
Код: Bash
  1. sudo apt-get install -f

Оффлайн akhur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
sudo apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  diffstat hardening-includes intltool-debian libapt-pkg-perl
  libarchive-zip-perl libclass-accessor-perl libclone-perl libdata-alias-perl
  libemail-valid-perl libexporter-tiny-perl libfcgi-perl libio-pty-perl
  libio-string-perl libipc-run-perl liblist-moreutils-perl libnet-dns-perl
  libnet-domain-tld-perl libnet-ip-perl libperlio-gzip-perl libsub-name-perl
  libtext-levenshtein-perl libyaml-libyaml-perl patchutils t1utils
Для их удаления используйте «sudo apt autoremove».
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.


дальше выполняю ту же команду и опять выдает ошибку

Оффлайн skybour

  • Старожил
  • *
  • Сообщений: 2224
    • Просмотр профиля
Код: Bash
  1. sudo apt autoremove

Оффлайн akhur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Удаляется diffstat (1.61-1) …
Удаляется hardening-includes (2.7ubuntu2) …
Удаляется intltool-debian (0.35.0+20060710.4) …
Удаляется libapt-pkg-perl (0.1.29build7) …
Удаляется libarchive-zip-perl (1.56-2) …
Удаляется libclass-accessor-perl (0.34-1) …
Удаляется libclone-perl (0.38-1build1) …
Удаляется libdata-alias-perl (1.20-1build1) …
Удаляется libemail-valid-perl (1.198-1) …
Удаляется liblist-moreutils-perl (0.413-1build1) …
Удаляется libexporter-tiny-perl (0.042-1) …
Удаляется libfcgi-perl (0.77-1build1) …
Удаляется libipc-run-perl (0.94-1) …
Удаляется libio-pty-perl (1:1.08-1.1build1) …
Удаляется libio-string-perl (1.08-3) …
Удаляется libnet-dns-perl (0.81-2build1) …
Удаляется libnet-domain-tld-perl (1.73-1) …
Удаляется libnet-ip-perl (1.26-1) …
Удаляется libperlio-gzip-perl (0.19-1build1) …
Удаляется libsub-name-perl (0.14-1build1) …
Удаляется libtext-levenshtein-perl (0.13-1) …
Удаляется libyaml-libyaml-perl (0.41-6build1) …
Удаляется patchutils (0.3.4-1) …
Удаляется t1utils (1.39-2) …
Обрабатываются триггеры для man-db (2.7.5-1) …

после этого выполняю установку опять ошибка

Оффлайн skybour

  • Старожил
  • *
  • Сообщений: 2224
    • Просмотр профиля
после этого выполняю установку опять ошибка
Какая? Левые репозитории добавлял? Покажи:
Код: Bash
  1. ls /etc/apt/sources.list.d/

Оффлайн akhur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
та же что и в первом посте
Цитировать
    ls /etc/apt/sources.list.d/

пусто

Пользователь добавил сообщение 10 Октябрь 2016, 17:24:56:
в общем ничего установить не получается

sudo apt-get install wine1.7
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 wine1.7 : Зависит: wine1.7-amd64 (= 1:1.7.18-0ubuntu1) но он не будет установлен
           Зависит: wine1.7-i386 (= 1:1.7.18-0ubuntu1)
           Рекомендует: winbind
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.


Пользователь добавил сообщение 10 Октябрь 2016, 17:36:10:
ps
Там проблема в /etc/apt/source.list
заменил на стандартный получилось установить wine, но php5-fpm пакеты не получается
E: Для пакета «php5-fpm» не найден кандидат на установку


Пользователь добавил сообщение 10 Октябрь 2016, 17:45:35:
pps
в версии 16.04 пакет php устанавливается apt-get install php
а php-fpm : apt-get install php-fpm php

и устанавливается 7 версия, а надо 5 установить
« Последнее редактирование: 10 Октябрь 2016, 17:53:51 от akhur »

 

Страница сгенерирована за 0.074 секунд. Запросов: 24.