Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Повреждена система пакетов  (Прочитано 1404 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн andreyvladimirovich2012

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Повреждена система пакетов
« : 10 Октябрь 2016, 17:25:45 »
Здравствуйте. Повреждена система пакетов. Выходит сообщение: "Система пакетов повреждена

Если вы используете сторонние источники приложений, отключите их, поскольку они являются частым
источником проблем. После этого выполните в терминале следующую команду: apt-get install -f"
"Следующие пакеты имеют неудовлетворённые зависимости:

linux-headers-generic: Depends: linux-headers-3.2.0-54-generic но он не установлен
linux-headers-generic-pae: Depends: linux-headers-3.2.0-54-generic-pae но он не установлен"
При попытке установить пакеты система просит права суперпользователя.

Оффлайн AndreX

  • Оператор IRC
  • Участник
  • *
  • Сообщений: 133
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #1 : 10 Октябрь 2016, 17:36:30 »
sudo apt-get update
sudo apt-get install linux-headers-3.2.0-54-generic-pae
sudo apt-get install -f


Пользователь добавил сообщение 10 Октябрь 2016, 17:38:17:
либо sudo apt-get dist-upgrade
« Последнее редактирование: 10 Октябрь 2016, 17:38:17 от AndreX »
01001000 01100101 01101100 01101100 01101111 00100000 01110111 01101111 01110010 01101100 01100100

Оффлайн andreyvladimirovich2012

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #2 : 11 Октябрь 2016, 10:24:53 »
Здравствуйте. sudo apt-get install -f вроде помогает. Теперь другая проблема - не хватает места на диске. Не знаете как освободить место на диске?
andrej@home:~$ sudo apt-get install -f
[sudo] password for andrej:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  scilab-minimal-bin libjlatexmath-java libopencv-highgui2.3
  libopencv-features2d2.3 linux-headers-3.2.0-36-generic-pae libunity6
  scilab-cli libjhdf5-jni libopencv-imgproc2.3 libjgoodies-common-java
  linux-headers-3.2.0-36 libatk-wrapper-java libskinlf-java libpvm3
  liblaf-plugin-java java-common libantlr-java libopencv-calib3d2.3
  libhdf5-serial-1.8.4 libopencv-video2.3 libopencv-objdetect2.3
  libxmlgraphics-commons-java libcommons-io-java libcommons-logging-java
  libopencv-flann2.3 icedtea-netx-common ttf-sil-gentium-basic scilab-data
  libopencv-core2.3 libjrosetta-java libjline-java scilab-include libdee-1.0-1
  libjogl-jni libjgoodies-looks-java pvm libavalon-framework-java
  libflexdock-java librhino-java libamd2.2.0 libcommons-parent-java libmatio0
  libumfpack5.4.0 linux-headers-3.2.0-36-generic libatk-wrapper-java-jni
  java-wrappers
Для их удаления используйте «apt-get autoremove».
Будут установлены следующие дополнительные пакеты:
  linux-headers-3.2.0-111 linux-headers-3.2.0-111-generic
  linux-headers-3.2.0-111-generic-pae linux-headers-generic
  linux-headers-generic-pae
НОВЫЕ пакеты, которые будут установлены:
  linux-headers-3.2.0-111 linux-headers-3.2.0-111-generic
  linux-headers-3.2.0-111-generic-pae
Пакеты, которые будут обновлены:
  linux-headers-generic linux-headers-generic-pae
обновлено 2, установлено 3 новых пакетов, для удаления отмечено 0 пакетов, и 597 пакетов не обновлено.
не установлено до конца или удалено 2 пакетов.
Необходимо скачать 0 B/13,7 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 79,3 MB.
Хотите продолжить [Д/н]? Д
(Чтение базы данных ... на данный момент установлено 728049 файлов и каталогов.)
Распаковывается пакет linux-headers-3.2.0-111 (из файла .../linux-headers-3.2.0-111_3.2.0-111.153_all.deb)...
dpkg: не удалось обработать параметр /var/cache/apt/archives/linux-headers-3.2.0-111_3.2.0-111.153_all.deb (--unpack):
 не удалось создать «/usr/src/linux-headers-3.2.0-111/arch/cris/include/asm/ioctls.h.dpkg-new» (при обработке «./usr/src/linux-headers-3.2.0-111/arch/cris/include/asm/ioctls.h»): На устройстве кончилось место
Отчёты apport не записаны, так как получено сообщение об ошибке о нехватке места на диске
         dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)
Распаковывается пакет linux-headers-3.2.0-111-generic (из файла .../linux-headers-3.2.0-111-generic_3.2.0-111.153_i386.deb)...
dpkg: не удалось обработать параметр /var/cache/apt/archives/linux-headers-3.2.0-111-generic_3.2.0-111.153_i386.deb (--unpack):
 не удалось создать «/usr/src/linux-headers-3.2.0-111-generic/include/config/iwlwifi/debugfs.h.dpkg-new» (при обработке «./usr/src/linux-headers-3.2.0-111-generic/include/config/iwlwifi/debugfs.h»): На устройстве кончилось место
Отчёты apport не записаны, так как получено сообщение об ошибке о нехватке места на диске
         dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)
Распаковывается пакет linux-headers-3.2.0-111-generic-pae (из файла .../linux-headers-3.2.0-111-generic-pae_3.2.0-111.153_i386.deb)...
dpkg: не удалось обработать параметр /var/cache/apt/archives/linux-headers-3.2.0-111-generic-pae_3.2.0-111.153_i386.deb (--unpack):
 не удалось создать «/usr/src/linux-headers-3.2.0-111-generic-pae/include/config/hw/random/virtio.h.dpkg-new» (при обработке «./usr/src/linux-headers-3.2.0-111-generic-pae/include/config/hw/random/virtio.h»): На устройстве кончилось место
Отчёты apport не записаны, так как получено сообщение об ошибке о нехватке места на диске
         dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/linux-headers-3.2.0-111_3.2.0-111.153_all.deb
 /var/cache/apt/archives/linux-headers-3.2.0-111-generic_3.2.0-111.153_i386.deb
 /var/cache/apt/archives/linux-headers-3.2.0-111-generic-pae_3.2.0-111.153_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Цитата: Правила форума
1.4. Листинги и содержимое текстовых файлов следует добавлять в сообщение с помощью тегов [spoiler]...[/spoiler] или [code]...[/code], либо прикреплять к сообщению в виде отдельного файла.

--БТР
« Последнее редактирование: 11 Октябрь 2016, 10:37:36 от БТР »

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5140
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #3 : 11 Октябрь 2016, 10:35:40 »
andreyvladimirovich2012, вы системные сообщения читать будете?

Следующие пакеты устанавливались автоматически и больше не требуются:
...
Для их удаления используйте «apt-get autoremove».

команду нужно выполнять через sudo.

Оффлайн andreyvladimirovich2012

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #4 : 11 Октябрь 2016, 11:12:12 »
Пробовал, вот что получилось

andrej@home:~$ sudo apt-get autoremove
[sudo] password for andrej:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 linux-headers-generic : Зависит: linux-headers-3.2.0-54-generic но он не установлен
 linux-headers-generic-pae : Зависит: linux-headers-3.2.0-54-generic-pae но он не установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.

andrej@home:~$ sudo apt-get -f
apt 0.8.16~exp12ubuntu10.14 для i386 скомпилирован Sep  8 2013 03:26:42
Использование: apt-get [параметры] команда
               apt-get [параметры] install|remove пакет1 [пакет2…]
               apt-get [параметры] source пакет1 [пакет2…]

apt-get — простая программа с интерфейсом командной строки
для скачивания и установки пакетов. Наиболее часто используемые
команды — update и install.

Команды:
   update -  получить новые списки пакетов
   upgrade - выполнить обновление
   install - установить новые пакеты (на месте пакета указывается имя пакета
             (libc6, а не имя файла libc6.deb)
   remove -  удалить пакеты
   autoremove - автоматически удалить все неиспользуемые пакеты
   purge -   удалить пакеты вместе с их файлами настройки
   source -  скачать архивы с исходным кодом
   build-dep - настроить всё необходимое для сборки
               пакета из исходного кода
   dist-upgrade - обновить всю систему, подробнее в apt-get(
   dselect-upgrade - руководствоваться выбором, сделанным в dselect
   clean -   удалить скачанные файлы архивов
   autoclean - удалить старые скачанные файлы архивов
   check -   проверить наличие нарушенных зависимостей
   changelog - скачать и показать файл изменений заданного пакета
   download - скачать двоичный пакет в текущий каталог

Параметры:
  -h   эта справка
  -q   показывать сообщения о работе, не выводить индикатор хода работы
  -qq  показывать только сообщения об ошибках
  -d   только скачать и НЕ устанавливать и не распаковывать архивы
  -s   не выполнять действия на самом деле, только имитация работы
  -y   отвечать «Да» на все вопросы, сами вопросы при этом не выводить
  -f   попытаться исправить систему, имеющую сломанные зависимости
  -m   попытаться продолжить, даже если архивы не найдены
  -u   показывать также список обновляемых пакетов
  -b   собрать пакет из исходного кода после его получения
  -V   показывать полные номера версий
  -c=? читать указанный файл настройки
  -o=? задать значение произвольному параметру настройки,
       например, -o dir::cache=/tmp
В справочных страницах apt-get(, sources.list(5) и apt.conf(5)
содержится подробная информация и описание параметров.
                       В APT есть коровья СУПЕРСИЛА.

andrej@home:~$ sudo apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  scilab-minimal-bin libjlatexmath-java libopencv-highgui2.3
  libopencv-features2d2.3 linux-headers-3.2.0-36-generic-pae libunity6
  scilab-cli libjhdf5-jni libopencv-imgproc2.3 libjgoodies-common-java
  linux-headers-3.2.0-36 libatk-wrapper-java libskinlf-java libpvm3
  liblaf-plugin-java java-common libantlr-java libopencv-calib3d2.3
  libhdf5-serial-1.8.4 libopencv-video2.3 libopencv-objdetect2.3
  libxmlgraphics-commons-java libcommons-io-java libcommons-logging-java
  libopencv-flann2.3 icedtea-netx-common ttf-sil-gentium-basic scilab-data
  libopencv-core2.3 libjrosetta-java libjline-java scilab-include libdee-1.0-1
  libjogl-jni libjgoodies-looks-java pvm libavalon-framework-java
  libflexdock-java librhino-java libamd2.2.0 libcommons-parent-java libmatio0
  libumfpack5.4.0 linux-headers-3.2.0-36-generic libatk-wrapper-java-jni
  java-wrappers
Для их удаления используйте «apt-get autoremove».
Будут установлены следующие дополнительные пакеты:
  linux-headers-3.2.0-111 linux-headers-3.2.0-111-generic
  linux-headers-3.2.0-111-generic-pae linux-headers-generic
  linux-headers-generic-pae
НОВЫЕ пакеты, которые будут установлены:
  linux-headers-3.2.0-111 linux-headers-3.2.0-111-generic
  linux-headers-3.2.0-111-generic-pae
Пакеты, которые будут обновлены:
  linux-headers-generic linux-headers-generic-pae
обновлено 2, установлено 3 новых пакетов, для удаления отмечено 0 пакетов, и 597 пакетов не обновлено.
не установлено до конца или удалено 2 пакетов.
Необходимо скачать 0 B/13,7 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 79,3 MB.
Хотите продолжить [Д/н]? Д
(Чтение базы данных ... на данный момент установлено 728049 файлов и каталогов.)
Распаковывается пакет linux-headers-3.2.0-111 (из файла .../linux-headers-3.2.0-111_3.2.0-111.153_all.deb)...
dpkg: не удалось обработать параметр /var/cache/apt/archives/linux-headers-3.2.0-111_3.2.0-111.153_all.deb (--unpack):
 не удалось создать «/usr/src/linux-headers-3.2.0-111/arch/cris/include/asm/ioctls.h.dpkg-new» (при обработке «./usr/src/linux-headers-3.2.0-111/arch/cris/include/asm/ioctls.h»): На устройстве кончилось место
Отчёты apport не записаны, так как получено сообщение об ошибке о нехватке места на диске
         dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)
Распаковывается пакет linux-headers-3.2.0-111-generic (из файла .../linux-headers-3.2.0-111-generic_3.2.0-111.153_i386.deb)...
dpkg: не удалось обработать параметр /var/cache/apt/archives/linux-headers-3.2.0-111-generic_3.2.0-111.153_i386.deb (--unpack):
 ошибка создания каталога «./usr/src/linux-headers-3.2.0-111-generic/include/config/iwlwifi»: На устройстве кончилось место
Отчёты apport не записаны, так как получено сообщение об ошибке о нехватке места на диске
         dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)
Распаковывается пакет linux-headers-3.2.0-111-generic-pae (из файла .../linux-headers-3.2.0-111-generic-pae_3.2.0-111.153_i386.deb)...
dpkg: не удалось обработать параметр /var/cache/apt/archives/linux-headers-3.2.0-111-generic-pae_3.2.0-111.153_i386.deb (--unpack):
 не удалось создать «/usr/src/linux-headers-3.2.0-111-generic-pae/include/config/hw/random/virtio.h.dpkg-new» (при обработке «./usr/src/linux-headers-3.2.0-111-generic-pae/include/config/hw/random/virtio.h»): На устройстве кончилось место
Отчёты apport не записаны, так как получено сообщение об ошибке о нехватке места на диске
         dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/linux-headers-3.2.0-111_3.2.0-111.153_all.deb
 /var/cache/apt/archives/linux-headers-3.2.0-111-generic_3.2.0-111.153_i386.deb
 /var/cache/apt/archives/linux-headers-3.2.0-111-generic-pae_3.2.0-111.153_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Цитата: Правила форума
1.4. Листинги и содержимое текстовых файлов следует добавлять в сообщение с помощью тегов [spoiler]...[/spoiler] или [code]...[/code], либо прикреплять к сообщению в виде отдельного файла.

--БТР
« Последнее редактирование: 11 Октябрь 2016, 13:31:03 от БТР »

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5140
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #5 : 11 Октябрь 2016, 13:36:40 »
andreyvladimirovich2012, на разделе с системой есть пользовательские файлы, которые можно временно переместить на другой диск? Например, фильмы или музыку из домашнего каталога.
Дайте вывод
sudo parted -l
df -h
df -k

P.S: в третий раз размещение вывода терминала без тега "код" сочту нарушением правил форума и выпишу проценты.

Оффлайн andreyvladimirovich2012

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #6 : 11 Октябрь 2016, 16:59:54 »
Вот так 
(Нажмите, чтобы показать/скрыть)

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5140
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #7 : 11 Октябрь 2016, 17:45:31 »
sudo apt-get clean
sudo dpkg -P scilab-minimal-bin libjlatexmath-java libopencv-highgui2.3 libopencv-features2d2.3 linux-headers-3.2.0-36-generic-pae libunity6 scilab-cli libjhdf5-jni libopencv-imgproc2.3 libjgoodies-common-java linux-headers-3.2.0-36 libatk-wrapper-java libskinlf-java libpvm3 liblaf-plugin-java java-common libantlr-java libopencv-calib3d2.3 libhdf5-serial-1.8.4 libopencv-video2.3 libopencv-objdetect2.3 libxmlgraphics-commons-java libcommons-io-java libcommons-logging-java libopencv-flann2.3 icedtea-netx-common ttf-sil-gentium-basic scilab-data libopencv-core2.3 libjrosetta-java libjline-java scilab-include libdee-1.0-1 libjogl-jni libjgoodies-looks-java pvm libavalon-framework-java libflexdock-java librhino-java libamd2.2.0 libcommons-parent-java libmatio0 libumfpack5.4.0 linux-headers-3.2.0-36-generic libatk-wrapper-java-jni java-wrappers
sudo apt-get install -f

Оффлайн andreyvladimirovich2012

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #8 : 11 Октябрь 2016, 18:43:37 »
(Нажмите, чтобы показать/скрыть)

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5140
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #9 : 11 Октябрь 2016, 18:45:44 »
andreyvladimirovich2012, на вопросе Хотите продолжить [Д/н]? не надо набирать "Д", просто нажмите Enter.

Оффлайн andreyvladimirovich2012

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #10 : 11 Октябрь 2016, 18:54:55 »
(Нажмите, чтобы показать/скрыть)

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5140
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #11 : 12 Октябрь 2016, 09:02:00 »
andreyvladimirovich2012, зачем в системе две версии ядра - generic и generic-pae? Дайте вывод
uname -aпотом
sudo apt-get update
sudo dpkg -P linux-headers-3.2.0-111 linux-headers-3.2.0-111-generic linux-headers-3.2.0-111-generic-pae
sudo apt-get install linux-headers-3.2.0-54-generic
sudo apt-get install -f

Оффлайн andreyvladimirovich2012

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #12 : 12 Октябрь 2016, 20:51:05 »
Насчёт ядер - не знаю. Человек, который мне устанавливал Линукс переехал в Москву, возможности связаться с ним - нету. Он мне установил Ubuntu 10-ую. Сказал, чтобы всё время обновлял систему из менеджера обновлений. Я каждый день и обновлял. Потом я обновил до 12-ой версии. И дальше обновлял - пока не повредился менеджер пакетов.

(Нажмите, чтобы показать/скрыть)


Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5140
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #13 : 13 Октябрь 2016, 08:53:51 »
sudo dpkg -P linux-headers-3.2.0-111-generic linux-headers-3.2.0-111-generic-pae linux-headers-generic-pae linux-image-generic-pae linux-generic-pae
sudo apt-get autoremove
sudo apt-get install -f

Оффлайн andreyvladimirovich2012

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Повреждена система пакетов
« Ответ #14 : 13 Октябрь 2016, 19:45:06 »
(Нажмите, чтобы показать/скрыть)

 

Страница сгенерирована за 0.073 секунд. Запросов: 25.