Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: separate+ (CMYK-плагин) не устанавливается в GIMP  (Прочитано 846 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн maks05

  • Автор темы
  • Старожил
  • *
  • Сообщений: 6214
    • Просмотр профиля
Имеется separate+-0.5.8. Нужно его прикрутить к GIMP 2.8.18 в Ubuntu 16.04.1.
В файле "прочти меня" по поводу установки сказано:
Цитировать
(Linux or UNIX-like operating systems)

In the beginning, check whether a GIMP development package is installed.
(In the case of Ubuntu, the name is "libgimp2.0-dev".)
Additionally, Little CMS (lcms), libtiff and libjpeg development
packages are required to be installed; therefore, check it at the same
time.

Next, modify Makefile by an editor as necessary. Regularly, PREFIX,
INSTALLDIR etc. will be modified to fit your environment.

Open the terminal window, move to the folder which is generated by the
separate+ ZIP file decompression, and run the following commands.

$ make
$ sudo make install

NOTE : If you cannot use sudo, get superuser privilige by "su" and "make
install".

Прочитав статью https://habrahabr.ru/post/130868/ решил вместо make install использовать checkinstall.

Результат:
(Нажмите, чтобы показать/скрыть)
Собственно, предсказуемо, поскольку начал ругаться ещё на стадии make.
Я правильно понимаю, что ему не хватает некоторых пакетов? Я пытался поискать их Synaptic, но их и след простыл. Или я вообще, что-то не так делаю?
Кто ставил себе separate+ и как оно правильно делается?
« Последнее редактирование: 10 Октябрь 2016, 22:01:43 от maks05 »

Оффлайн suslikk

  • Старожил
  • *
  • Сообщений: 2367
    • Просмотр профиля
Re: separate+ (CMYK-плагин) не устанавливается в GIMP
« Ответ #1 : 10 Октябрь 2016, 21:32:24 »
sudo apt install libgimp2.0-dev делали перед сборкой?
А также: Additionally, Little CMS (lcms), libtiff and libjpeg development
packages are required to be installed; therefore, check it at the same
time.
Нарисуй свой город на openstreetmap.org

Оффлайн maks05

  • Автор темы
  • Старожил
  • *
  • Сообщений: 6214
    • Просмотр профиля
Re: separate+ (CMYK-плагин) не устанавливается в GIMP
« Ответ #2 : 11 Октябрь 2016, 03:22:57 »
Да, забыл чего-то. Поставил.

Но, цель пока всё равно не достигнута:
Цитировать
maksim@i5-4670:~/separate+-0.5.8$ make
gcc -g  separate-core.o separate-gui.o separate-export.o util.o tiff.o psd.o jpeg.o iccbutton.o lcms_wrapper.o -o separate `pkg-config gimp-2.0 --libs` `pkg-config gimpui-2.0 --libs` `pkg-config gtk+-2.0 --libs` `pkg-config lcms --libs` -ltiff -ljpeg
Package lcms was not found in the pkg-config search path.
Perhaps you should add the directory containing `lcms.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lcms' found
/usr/bin/ld: separate-core.o: неопределённая ссылка на символ «pow@@GLIBC_2.2.5»
//lib/x86_64-linux-gnu/libm.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
Makefile:84: ошибка выполнения рецепта для цели «separate»
make: *** [separate] Ошибка 1

Как я понял, он не видит пакет lcms, хотя тот есть.
А вот как и куда добавить переменную окружения, я не совсем понял.
« Последнее редактирование: 11 Октябрь 2016, 03:30:27 от maks05 »

Оффлайн scsiman

  • Активист
  • *
  • Сообщений: 331
    • Просмотр профиля
Re: separate+ (CMYK-плагин) не устанавливается в GIMP
« Ответ #3 : 11 Октябрь 2016, 16:04:13 »
maks05, liblcms{какая-у-вас-версия}-dev установлен?
Dell Studio XPS 16, Ubuntu 14.04 LTS (Home).
HP nx6110, Ubuntu 8.04 LTS => 10.04 LTS (Home).

Оффлайн maks05

  • Автор темы
  • Старожил
  • *
  • Сообщений: 6214
    • Просмотр профиля
Re: separate+ (CMYK-плагин) не устанавливается в GIMP
« Ответ #4 : 11 Октябрь 2016, 16:21:30 »
scsiman, да, установлен.

Решил проблему обходным путём: открыл многослойный .psd в CMYK с помощью Krita.
Однако и с "separate+" хорошо бы разобраться. Но терзают меня смутные сомнения: последняя версия датируется, кажется, 2007 годом (или 2010-м?). В общем, прога давно не обновлялась, стандартные пути в системе поменялись, библиотеки и зависимости другие... Тут или ставить с помощью make install, что бы она себя жёстко прописала туда, куда задумывалось, либо пересобирать под Ubuntu 16.04. Может кто-то возьмётся?

 

Страница сгенерирована за 0.055 секунд. Запросов: 24.