Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: проблема с libmono-winforms2.0-cil  (Прочитано 1370 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн eleks

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
проблема с libmono-winforms2.0-cil
« : 16 Октябрь 2016, 14:44:19 »
Хотел установить программу SMath, которая требует наличия библиотеки libmono-winforms2.0-cil. В ранних версиях Ubuntu эту библиотеку можно было найти в центре приложений. Однако в Ubuntu 16.04 64бит данная библиотека почему-то отсутствует. Ну что-же, нахожу её здесь:
http://packages.ubuntu.com/ru/trusty/all/libmono-winforms2.0-cil/download
скачиваю, и пытаюсь установить с помощью цетра приложений. Т.е. давлю на кнопку установить, процесс как-бы начинается, но не доходит до ввода пароля и сбрасывается.
Что делаю не так? Может быть в новой Ubuntu запуск exe-шников осуществляется каким-то другим образом?

Пользователь добавил сообщение 16 Октябрь 2016, 15:39:29:
Похоже на то, что под Ubuntu 16.04 64bit используется пакет libmono-windowsbase4.0-cil
http://packages.ubuntu.com/ru/xenial/all/libmono-windowsbase4.0-cil/download
Пакет скачивается и устанавливается. При этом SMath пытается запуститься, иконка некоторое время висит в трее и пропадает. :-[

ТС не появлялся на Форуме более полугода по состоянию на 17/07/2019 (последняя явка: 01/11/2017). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 17 Июль 2019, 09:14:00 от zg_nico »

Оффлайн Ilya С

  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
Re: проблема с libmono-winforms2.0-cil
« Ответ #1 : 16 Октябрь 2016, 17:13:09 »
попробуй установить нужный пакет (2.0) через dpkg, а не через центр.

Оффлайн eleks

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: проблема с libmono-winforms2.0-cil
« Ответ #2 : 17 Октябрь 2016, 22:16:50 »
Чего-то не хватает. Возникают ошибки и пакет не устанавливается. :-[

$ sudo dpkg -i /home/eleks/Загрузки/SMath/libmono-winforms2.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb
[sudo] пароль для eleks:
Выбор ранее не выбранного пакета libmono-winforms2.0-cil.
(Чтение базы данных … на данный момент установлено 241558 файлов и каталогов.)
Подготовка к распаковке …/libmono-winforms2.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb …
Распаковывается libmono-winforms2.0-cil (3.2.8+dfsg-4ubuntu1.1) …
dpkg: зависимости пакетов не позволяют настроить пакет libmono-winforms2.0-cil:
 libmono-winforms2.0-cil зависит от libmono-accessibility2.0-cil (>= 1.0), однако:
  Пакет libmono-accessibility2.0-cil не установлен.
 libmono-winforms2.0-cil зависит от libmono-corlib2.0-cil (>= 3.2.8), однако:
  Пакет libmono-corlib2.0-cil не установлен.
 libmono-winforms2.0-cil зависит от libmono-posix2.0-cil (>= 3.2.3), однако:
  Пакет libmono-posix2.0-cil не установлен.
 libmono-winforms2.0-cil зависит от libmono-system-data2.0-cil (>= 3.0.6), однако:
  Пакет libmono-system-data2.0-cil не установлен.
 libmono-winforms2.0-cil зависит от libmono-system-runtime2.0-cil (>= 2.4), однако:
  Пакет libmono-system-runtime2.0-cil не установлен.
 libmono-winforms2.0-cil зависит от libmono-system-web2.0-cil (>= 2.10.3), однако:
dpkg: ошибка при обработке пакета libmono-winforms2.0-cil (--install):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 libmono-winforms2.0-cil
« Последнее редактирование: 17 Октябрь 2016, 22:19:32 от eleks »

Оффлайн don Rumata

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: проблема с libmono-winforms2.0-cil
« Ответ #3 : 24 Декабрь 2017, 18:51:32 »
sudo -i

echo "deb http://download.mono-project.com/repo/ubuntu $(lsb_release -c -s) main" > /etc/apt/sources.list.d/mono-official.list

apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF

apt update

LATEST_LIBMONO_WINDOWS_FORMS_VERSION=$(aptitude search -F %p --sort version libmono-system-windows-forms* | tail -1 | sed 's/:i386//' | tr -d ' ')

apt -y install $LATEST_LIBMONO_WINDOWS_FORMS_VERSION

На сегодняшний момент прилетит пакет libmono-system-windows-forms4.0-cil
Как он совместим с версий 2 - хз.
Здесь все бесполезно. Знаний не хватает, а золото теряет цену, потому что опаздывает.

 

Страница сгенерирована за 0.245 секунд. Запросов: 22.