Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: При просмотре видео на ютубе нагрузка на CPU выше 60%  (Прочитано 2837 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nekk

  • Автор темы
  • Любитель
  • *
  • Сообщений: 55
    • Просмотр профиля
В браузерах Firefox и Google Chrome при просмотре видео на ютубе (и других ресурсах) грузит ЦП от 60 до 90%.
OS: 16.04 x64
CPU: Intel Pentium N3540
VGA: Intel HD Graphics
Драйвера все стандартные i915, для ЦП intel cpu microcode родной убунтовский 2015 года.
Аппаратное ускорение включено.
Пробовал ставить последние драйвера для видео от Intel с их сайта, ставил i965-va, пробовал рецепты для браузеров с отключением/включением скрытых настроек...
Кто сталкивался с таким? Даже пустая система с одной вкладкой в браузере грузит выше 60%.

Оффлайн peregrine

  • FSM
  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 7083
  • Gentoo x64 Ubuntu 16.04.1 x64
    • Просмотр профиля
Аппаратное ускорение под Linux-ом в браузерах работает плохо. Не всегда оно включается в простых настройках, иногда только в конфигурационных страничках браузера и то далеко не на всех видяхах и драйверах. Давай вывод
lspci -k | egrep 'VGA|3D' -A2Какие-то мутные дрова с сайтов ставить вообще нет смысла.

Оффлайн theurs

  • Активист
  • *
  • Сообщений: 457
    • Просмотр профиля
По-моему процессор просто слабый. На ютубе по умолчанию используется кодек vp9 и видеокарты умеют его аппаратно декодировать только начиная с 2015 года или около того. На других сайтах могут тормозить рекламные блоки.

Для ютуба и хрома можно установить расширение h264fy что бы получать видео пожатое старым кодеком h264, ну и адблок.

Оффлайн Nekk

  • Автор темы
  • Любитель
  • *
  • Сообщений: 55
    • Просмотр профиля
Аппаратное ускорение под Linux-ом в браузерах работает плохо. Не всегда оно включается в простых настройках, иногда только в конфигурационных страничках браузера и то далеко не на всех видяхах и драйверах. Давай вывод
lspci -k | egrep 'VGA|3D' -A2Какие-то мутные дрова с сайтов ставить вообще нет смысла.
lspci -k | egrep 'VGA|3D' -A2
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)
        Subsystem: Lenovo Atom Processor Z36xxx/Z37xxx Series Graphics & Display
        Kernel driver in use: i915


Пользователь добавил сообщение 21 Октябрь 2016, 15:19:56:
По-моему процессор просто слабый. На ютубе по умолчанию используется кодек vp9 и видеокарты умеют его аппаратно декодировать только начиная с 2015 года или около того. На других сайтах могут тормозить рекламные блоки.

Для ютуба и хрома можно установить расширение h264fy что бы получать видео пожатое старым кодеком h264, ну и адблок.
Проц норм. Все где то в настройках/драйверах/софт. Для примера, в 7х окнах ситуация почти аналогичная, но немного лучше. А в 10ке вообще нагрузка минимальная - около 15%.
« Последнее редактирование: 21 Октябрь 2016, 15:19:56 от Nekk »

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3095
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Nekk, где-то я уже писал обэтом и не один раз - надо заставить браузеры использовать аппаратное ускорение.

Для Chrome/Chromium/Opera(на движке WebKit): вбиваем в строке браузера chrome://flags#ignore-gpu-blacklist и меняем значение переключателя. После чего перезапускаем браузер

Для Firefox:
1) https://support.mozilla.org/uk/kb/upgrade-graphics-drivers-use-hardware-acceleration
2) вбиваем в строке about:config, соглашаемся "на свой страх и риск", вбиваем там hardware-video и меняем false на true (двойной клик)
« Последнее редактирование: 22 Октябрь 2016, 13:57:48 от EvangelionDeath »
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн soarin

  • Старожил
  • *
  • Сообщений: 1474
  • ubuntu 18.04
    • Просмотр профиля
EvangelionDeath,
Я тоже писал не раз, что аппаратное декодирование видео под линуксами в браузерах не работает в принципе.
https://bugzilla.mozilla.org/show_bug.cgi?id=563206
https://bugs.chromium.org/p/chromium/issues/detail?id=463440

А в 10ке вообще нагрузка минимальная - около 15%.
Youtube имеет видео в двух форматах: h264 и VP9.
По умолчанию для Firefox и Chrome суётся VP9.
Windows 10 аппаратно в браузерах умеет h264 и VP9, Windows 7 - h264, Линуксы - ничего.
Поэтому такие результаты.

PS: Разве что можешь поставить Chromium из этого PPA https://launchpad.net/~saiarcot895/+archive/ubuntu/chromium-beta (естественно без каких-то гарантий на стабильность). Возможно заработает h264 (но опять же нужно переключить youtube в h264, может быть расширением h264ify).
« Последнее редактирование: 22 Октябрь 2016, 14:31:37 от soarin »

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14922
  • Я не слышу.
    • Просмотр профиля
Цитировать
CPU выше 60%
топько команда.
watch "ps aux | sort -nrk 3,3 | head -n 5"
~.o

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3095
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
soarin, я наверное не в курсе, но у меня загрузка 4-22% (i3-3217U) при просмотре видео youtube (ну и около 40+ вкладок открыто) + еще всякаяфигня запущена (chromium)
На втором ноутбуке загрузка процессора выше (там жена смотрит с другого сайта и AdBlock не выпиливает один блок с рекламой), но после удаления "рекламного блока" нагрузка падает до 20-30% (там AMD P320) c 60-70 (google chrome)
« Последнее редактирование: 22 Октябрь 2016, 14:33:43 от EvangelionDeath »
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн DimanBG

  • Старожил
  • *
  • Сообщений: 1033
    • Просмотр профиля
Проц норм. Все где то в настройках/драйверах/софт. Для примера, в 7х окнах ситуация почти аналогичная, но немного лучше. А в 10ке вообще нагрузка минимальная - около 15%.
В Вин10 наверно Квик Синк работает.

Оффлайн Nekk

  • Автор темы
  • Любитель
  • *
  • Сообщений: 55
    • Просмотр профиля
Большое спасибо всем кто отозвался! Буду пробовать! Тему закрываем.
P.S. Плагин для браузеров h264ify позволяет на моем железе смотреть видео 4к  :o

 

Страница сгенерирована за 0.058 секунд. Запросов: 24.