Форум русскоязычного сообщества Ubuntu


Автор Тема: Отключили электричество во время обновления  (Прочитано 503 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Evgenikus

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Доброго времени суток! Я в системе новичок. Начал обновлять систему и вырубили электричество. Теперь система не загружается. В биосе не даёт вносить ни какие изменения. Помогите пожалуйста! Горит черный экран с надписями и всё. ASUS N53jg I3-2600, 6 Gb ROM, Nvidia GeForce - 415. Заранее огромное спасибо!

Оффлайн Sirrke

  • Участник
  • *
  • Сообщений: 109
  • Arch Linux
    • Просмотр профиля
Evgenikus, Было бы неплохо обозначить, что конкретно за надписи выдает компьютер при включении. Тогда можно сделать какие-либо выводы.

Оффлайн Evgenikus

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Вот:

Оффлайн Sirrke

  • Участник
  • *
  • Сообщений: 109
  • Arch Linux
    • Просмотр профиля
Подозреваю, что это не всё. Поскольку в приложенном файле я не вижу ошибки. tty работает? Можешь перейти туда (ctrl+alt+f1)? Далее выполни sudo apt -f upgrade

Оффлайн Evgenikus

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Ть в том, что загрузка дальше этих строк не идёт. Полтора часа ждал. Комбинацию клавиш эту не пробовал. Сейчас попробую.

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 4312
  • Все по палатам!
    • Просмотр профиля
Не понял. Ноутбук и пропало электрическво, а батарея не работает?
Извините, я все еще учусь

Оффлайн Evgenikus

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Дохлая года как полтора))) Час держит заряд и дохнет. Она новая держала 3 часа и не больше.

Оффлайн SergeyIT

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 4312
  • Все по палатам!
    • Просмотр профиля
Так часа бы хватило...
Извините, я все еще учусь

Оффлайн Evgenikus

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Ему не хватило)))

Оффлайн Evgenikus

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Всё... По-ходу прикончил систему. Запустил с диском Ubuntu, нажал запуск без установки - ноут завис. Я его вырубил... И теперь он мне выдает вот это:
error: file '/boot/grub/i386-pc/normaly.mod' not found
Entering rescue more...
grub rescue>

Скажите - это лечится?....

Оффлайн BloodyFRag

  • Любитель
  • *
  • Сообщений: 68
    • Просмотр профиля
Evgenikus, лечится. http://help.ubuntu.ru/wiki/%D0%B2%D0%BE%D1%81%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5_grub
P.S. не плохо бы научиться пользоваться поиском...
А основная проблема, если не излечится прямым путем, т.е. через tty при запуске, то  может излечится chroot'ом основной системы в лайв сиди и последующего обновления.
Запускаешь лайв сиди, идешь в тетминал, узнаешь на каком разделе стоит система, чаще всего это /dev/sda1

И построчно копируешь код который ниже, хотя я на твоем бы месте писал ручками, так хоть запомнишь что нибудь:

sudo mkdir /mnt/temp
sudo mount /dev/sdXZ /mnt/temp <<< в этой строке /dev/sdXZ нужно заменить на раздел с установленной системой.
for i in /dev /dev/pts /proc /sys; do sudo mount -B $i /mnt/temp$i;  done
sudo cp /etc/resolv.conf /mnt/temp/etc/resolv.conf
sudo chroot /mnt/temp
sudo apt-get update
sudo apt-get dist-upgrade
sudo update-grub
« Последнее редактирование: 01 Ноябрь 2016, 09:35:27 от BloodyFRag »

Оффлайн Evgenikus

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
А без Live CD/USB ни как?


Оффлайн Evgenikus

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
делаю всё пошагово как сказано, но как только ввожу "insmod normal" он мне выдает " '/boot/grub/i386-pc/normal.mod' not found"

 

Страница сгенерирована за 0.059 секунд. Запросов: 24.