Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Не могу установить wine. Помогите  (Прочитано 518 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн feuertod

  • Автор темы
  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Не могу установить wine. Помогите
« : 03 Ноябрь 2016, 19:44:21 »
Ошибка такого характера:
(Нажмите, чтобы показать/скрыть)

Сообщение подредактировал
Цитата: Правила форума
1.4. Листинги и содержимое текстовых файлов следует добавлять в сообщение с помощью тегов [spoiler]...[/spoiler] или [code]...[/code], либо прикреплять к сообщению в виде отдельного файла.

Butjapka

« Последнее редактирование: 03 Ноябрь 2016, 22:58:04 от Butjapka »

Оффлайн Ampermetr

  • Активист
  • *
  • Сообщений: 491
    • Просмотр профиля
Re: Не могу установить wine. Помогите
« Ответ #1 : 03 Ноябрь 2016, 20:51:31 »
apt-get -f install
Женский форум,топик "Плакала всю ночь, подскажите из-за чего?"
Линукс форум, топик "Всю ночь собирал генту, подскажите зачем?"

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6212
    • Просмотр профиля
Re: Не могу установить wine. Помогите
« Ответ #2 : 03 Ноябрь 2016, 21:13:08 »
feuertod, wine 1.6 и так бы установился, без подключения репозитория, через Synaptic или через терминал. Репозиторий сейчас другой и версия Wine уже 1.9.
Смотрите https://wiki.winehq.org/Ubuntu .
Другое дело, что с пакетами из этого репозитория пару дней назад какие-то непонятки происходить начали - тоже проблема с зависимостями и система рекомендует сделать тот же install -f, только вот не помогает. Подробно не разбирался. Скорее всего что-то поломалось с очередными обновлениями и со следующими исправиться.

Оффлайн JR224

  • Участник
  • *
  • Сообщений: 163
    • Просмотр профиля
Re: Не могу установить wine. Помогите
« Ответ #3 : 04 Ноябрь 2016, 08:22:07 »
ogdan@bogdan:~$ sudo add-apt-repository ppa:ubuntu-wine/ppa

bogdan@bogdan:~$ sudo apt-get install wine1.6
Я дико извиняюсь - а систему озвучить ?
И заглянуть, так, для общего развития, сюды например https://launchpad.net/~ubuntu-wine/+archive/ubuntu/ppa?field.series_filter=trusty
maks05, Не путайте человека,  всё там нормально, и с репом и с вайном.  У меня стоит winehq-staging из ppa:wine/wine-builds - всё отлично обновляется. Вчера например обновлялся - всё пучком.

Оффлайн maks05

  • Старожил
  • *
  • Сообщений: 6212
    • Просмотр профиля
Re: Не могу установить wine. Помогите
« Ответ #4 : 04 Ноябрь 2016, 14:16:20 »
JR224, у меня тоже обновилось, но после хитрых манипуляций по установке некоторых библиотек через POL - подтянулось что-то недостающее и всё стало нормально.
А на счёт репозиториев... Мне одному кажется, что рекомендуемый и мной, и вами "builds", идёт с репозитория
sudo add-apt-repository ppa:wine/wine-buildsа у автора
sudo add-apt-repository ppa:ubuntu-wine/ppaПо-моему, явное несоответствие.

А так да, версию ОС хорошо бы озвучить. Но, опять же, если нужна именно версия wine 1.6, то в Ubuntu 16.04, например, специальный репозиторий подключать не нужно. Wine 1.6 есть в базовых репах и нагляднее всего можно установить через Synaptic. Если нужна версия 1.9.22, то "builds"-репозиторий в помощь. Разве нет?
« Последнее редактирование: 04 Ноябрь 2016, 21:46:17 от maks05 »

Оффлайн JR224

  • Участник
  • *
  • Сообщений: 163
    • Просмотр профиля
Re: Не могу установить wine. Помогите
« Ответ #5 : 05 Ноябрь 2016, 03:34:34 »
maks05, POL, понятно, я им не балуюсь. Удобная конечно штука, для создания разных префиксов и версий Вайн. Но по мне Wine предпочтительней и удобней, тем более что пока всё уживается отлично и в одном префиксе и версии.
Да дело в том что у автора темы подключён ppa:ubuntu-wine/ppa и при этом он ставит wine1.6. Конечно он получит ошибку.Так как начиная с Тrusty в этом репо версии 1.6 уже нет. В любом случае версию ОС надо бы указать, если хочется нормального ответа, а не гадания.
Но, опять же, если нужна именно версия wine 1.6, то в Ubuntu 16.04, например, специальный репозиторий подключать не нужно. Wine 1.6 есть в базовых репах
Это да, по кр. мере в 14.04 Wine1.6 - есть. Насчёт 16.04 не знаю честно, что там есть,  я её ещё не ковырял, мне пока 14.04 - более чем.
Если нужна версия 1.9.22, то "builds"-репозиторий в помощь. Разве нет?
Cогласен. Хорош там Вайн! Правда ТСу , судя по всему перед тем как что то ставить, лучше было бы поинтересоваться.

 

Страница сгенерирована за 0.063 секунд. Запросов: 24.