Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Flash-браузерки на Ubuntu  (Прочитано 658 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nevzor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Flash-браузерки на Ubuntu
« : 07 Ноябрь 2016, 18:33:35 »
Играю я значит в браузерные игры, "Elvenar" и "The Settlers Онлайн". Накатил вчера на свой нетбук Ubuntu 16.10 и столкнулся с проблемой, что не могу запустить эти игры, пишет, что для игры нужен "Adobe Flash Player 11.7", причём даже в Сhromium. Причём, до этого на этом же самом нетбуке стоял Xubuntu 16.04 и всё работало без проблем... Курю форумы и гуглы уже весь день, половина советов уже устарела, половина не помогает. Пробовал ставить Google Chrome, не смог, .deb пакет взятый с офф. сайта виснет при установке, ставить через репозитарий так же вышло, пробовал этот способ - http://help.ubuntu.ru/wiki/google_chrome пишет пакет "google-chrome-stable" не найдет. Может кто что подскажет, а? :)

Оффлайн Длиннорогий

  • Активист
  • *
  • Сообщений: 257
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #1 : 07 Ноябрь 2016, 18:59:45 »
apt install flashplugin-installer

Оффлайн Alie Alexandross

  • Старожил
  • *
  • Сообщений: 1580
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #2 : 07 Ноябрь 2016, 19:25:00 »
Накатил вчера на свой нетбук Ubuntu 16.10
(Нажмите, чтобы показать/скрыть)
Подпись автора jillsmitt истинна...

Оффлайн Nevzor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #3 : 07 Ноябрь 2016, 19:59:49 »
apt install flashplugin-installer
Уже стоит, при вводе в терминале данной команды выдаёт:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлен пакет flashplugin-installer самой новой версии (11.2.202.643ubuntu0.16.10.1).
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Проблема тут в том, что данная команда ставит Flash версии 11.2, а для игр нужна минимум версия 11.7

Оффлайн Длиннорогий

  • Активист
  • *
  • Сообщений: 257
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #4 : 07 Ноябрь 2016, 20:03:16 »
Nevzor, тогда  http://help.ubuntu.ru/wiki/flash раздел Установка вручную. Но не факт, что будет корректно работать.

Оффлайн Nevzor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #5 : 07 Ноябрь 2016, 20:08:39 »
Накатил вчера на свой нетбук Ubuntu 16.10
(Нажмите, чтобы показать/скрыть)
У меня Samsung NP-NC110 на Intel Atom, старенький аппарат, однако на Ubuntu 16.10 бегает ничего так, не идеально конечно, мелкие фризы бывают, плюс когда тяжёлые приложения запускаю подвисает немного, но в целом на 7 из 10. Сёрфить в инете, работать с текстовыми документами можно без проблем. Как ни странно, Xubuntu 16.04 работала намного хуже. Если сейчас ещё и с Flash разберусь, так вообще песня будет :)

Оффлайн Aleksandru

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 1865
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #6 : 07 Ноябрь 2016, 20:53:04 »
Что у вас в chrome://plugins/

Предлагаю метод, скачать с сайта Adobe: flash_player_ppapi_linux.x86_64.tar.gz
https://get.adobe.com/ru/flashplayer/otherversions/
Распаковать архив, взять из него libpepflashplayer.so и положить в:
/usr/lib/adobe-flashplugin/
Intel Core i3-3220 3.30GHz, GeForce GT 1030, MSI H61M-P20, 8GB RAM, SAMSUNG_MZMPC032- Kubuntu 18.04-х64

Оффлайн Nevzor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #7 : 08 Ноябрь 2016, 06:51:33 »
Что у вас в chrome://plugins/

Предлагаю метод, скачать с сайта Adobe: flash_player_ppapi_linux.x86_64.tar.gz
https://get.adobe.com/ru/flashplayer/otherversions/
Распаковать архив, взять из него libpepflashplayer.so и положить в:
/usr/lib/adobe-flashplugin/
Так, в chrome://plugins/ - два плагина:
1) Adobe Flash Player - Версия: 11.2.999.999 Shockwave Flash 11.2 r999
Имя:   Shockwave Flash
Описание:   Shockwave Flash 11.2 r999
Версия:   11.2.999.999
Расположение:   /opt/google/chrome/PepperFlash/libpepflashplayer.so

2) Chromium PDF Viewer (2 files)
Имя:   Chromium PDF Viewer
Версия:   
Расположение:   chrome-extension://mhjfbmdgcfjbbpaeojofohoefgiehjai/

Пробовал бросить файл libpepflashplayer.so по указанному вами адресу... Там нет такой папки и создать её что-то не получается. И самое странное, в папке /opt/ нет папки /google/ так что подменить указанный в свойствах файл тоже не получается :(

Оффлайн Patrols

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #8 : 08 Ноябрь 2016, 07:23:54 »

Оффлайн andytux

  • Старожил
  • *
  • Сообщений: 1520
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #9 : 08 Ноябрь 2016, 07:29:02 »

https://forum.ubuntu.ru/index.php?topic=283525.msg2233324#msg2233324

Флешплеер скачивал с сайта get.adobe.com.

Оффлайн theurs

  • Активист
  • *
  • Сообщений: 457
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #10 : 08 Ноябрь 2016, 08:31:22 »
для хрома и хромиума надо устанавливать пакет pepperflashplugin-nonfree

Оффлайн Nevzor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #11 : 08 Ноябрь 2016, 11:28:11 »
для хрома и хромиума надо устанавливать пакет pepperflashplugin-nonfree
При попытке установить данный пакет выдаёт:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет pepperflashplugin-nonfree недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «pepperflashplugin-nonfree» не найден кандидат на установку

Оффлайн Длиннорогий

  • Активист
  • *
  • Сообщений: 257
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #12 : 08 Ноябрь 2016, 12:14:19 »
Nevzor, насколько я понимаю, у вас он подтянут вместе с Chromium


1) Adobe Flash Player - Версия: 11.2.999.999 Shockwave Flash 11.2 r999
Имя:   Shockwave Flash
Описание:   Shockwave Flash 11.2 r999
Версия:   11.2.999.999
Расположение:   /opt/google/chrome/PepperFlash/libpepflashplayer.so

Оффлайн theurs

  • Активист
  • *
  • Сообщений: 457
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #13 : 08 Ноябрь 2016, 12:25:14 »
для хрома и хромиума надо устанавливать пакет pepperflashplugin-nonfree
При попытке установить данный пакет выдаёт:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет pepperflashplugin-nonfree недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «pepperflashplugin-nonfree» не найден кандидат на установку

Надо открыть менеджер приложений Ubuntu, зайти в его настройки и там выбрать все возможные источники на второй вкладке

Оффлайн Nevzor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Flash-браузерки на Ubuntu
« Ответ #14 : 08 Ноябрь 2016, 15:07:35 »
Nevzor, насколько я понимаю, у вас он подтянут вместе с Chromium


1) Adobe Flash Player - Версия: 11.2.999.999 Shockwave Flash 11.2 r999
Имя:   Shockwave Flash
Описание:   Shockwave Flash 11.2 r999
Версия:   11.2.999.999
Расположение:   /opt/google/chrome/PepperFlash/libpepflashplayer.so

Да, но версия 11.2, а для игр надо минимум 11.7 :( Причём, что странно, до этого я устанавливал на этот же нетбук Xubuntu 16.04 и всё работало без каких-либо танцев с бубном. Сам я ничего не ставил дополнительно. Так сказать из коробки Flash уже был новой версии... Может я какую нестандартную сборку ставил? Хм... Не помню уже откуда я тогда образ брал...

 

Страница сгенерирована за 0.109 секунд. Запросов: 24.