Форум русскоязычного сообщества Ubuntu


Автор Тема: Не компилируется. Ошибка -- Configuring incomplete, errors occurred!  (Прочитано 1089 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн makssun

  • Автор темы
  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
Здравствуйте!
Установлена на впс-сервере Ubuntu 14.04.
Не могу ничего скомпиллировать с исходников.
Например, https://github.com/xcicoin/xcicoin

Делаю:
sudo apt-get update
    sudo apt-get install git cmake make gcc libboost1.55-all-dev
    git clone https://github.com/xcicoin/xcicoin.git
    cd xcicoin
    make

Выдает:

Call Stack (most recent call first):
  CMakeLists.txt:112 (find_package)


-- Found Git: /usr/bin/git
-- Could NOT find Threads (missing:  Threads_FOUND)
-- Configuring incomplete, errors occurred!
See also "/home/max/xcicoin/build/release/CMakeFiles/CMakeOutput.log".
See also "/home/max/xcicoin/build/release/CMakeFiles/CMakeError.log".
make: *** [cmake-release] Error 1

Что нужно, чтоб скомпиллировать программу?
Да, и еще, не устанавливается sudo apt-get install git cmake make gcc libboost1.55-all-dev
выдает:

The following packages have unmet dependencies: libboost1.55-all-dev : Depends: libboost-iostreams1.55-dev but it is not going to be installed Depends: libboost-mpi1.55-dev but it is not going to be installed Depends: libboost-mpi-python1.55-dev but it is not going to be installed Depends: libboost-python1.55-dev but it is not going to be installed Depends: libboost-regex1.55-dev but it is not going to be installed E: Unable to correct problems, you have held broken packages.
« Последнее редактирование: 09 Ноябрь 2016, 09:57:44 от makssun »

Оффлайн Длиннорогий

  • Активист
  • *
  • Сообщений: 257
    • Просмотр профиля

Оффлайн makssun

  • Автор темы
  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
Нужно
Код: [Выделить]
apt install build-essential

build-essential is already the newest version.
The following package was automatically installed and is no longer required:
  libdb5.1
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Код: Bash
  1. sudo apt-get -f install
  2.  
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн makssun

  • Автор темы
  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
Код: Bash
  1. sudo apt-get -f install
  2.  

 sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Код: Bash
  1. sudo apt-get update
  2. sudo apt-get install libboost1.55-all-dev --reinstall
  3.  

ИЛИ

Код: Bash
  1. sudo apt-get purge libboost1.55-all-dev
  2. sudo apt-get autoremove --purge
  3. sudo apt-get clean
  4. sudo apt-get update
  5. sudo apt-get install libboost1.55-all-dev
  6.  
« Последнее редактирование: 09 Ноябрь 2016, 14:06:45 от EvangelionDeath »
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн makssun

  • Автор темы
  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
Вот на последнюю команду выдало, и на пред. примерно тоже самое:
The following packages have unmet dependencies:
 libboost1.55-all-dev : Depends: libboost-iostreams1.55-dev but it is not going to be installed
                        Depends: libboost-mpi1.55-dev but it is not going to be installed
                        Depends: libboost-mpi-python1.55-dev but it is not going to be installed
                        Depends: libboost-python1.55-dev but it is not going to be installed
                        Depends: libboost-regex1.55-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Как это победить?

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
makssun, измените источник пакетов на мейн сервер, после чего:
Код: Bash
  1. sudo apt-get clean
  2. sudo apt-get update
  3. sudo apt-get install libboost1.55-all-dev --reinstall
  4.  
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн makssun

  • Автор темы
  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
makssun, измените источник пакетов на мейн сервер, после чего:
Код: Bash
  1. sudo apt-get clean
  2. sudo apt-get update
  3. sudo apt-get install libboost1.55-all-dev --reinstall
  4.  
Вот содержание /etc/apt/sources.list
deb http://archive.ubuntu.com/ubuntu trusty main universe
deb http://ua.archive.ubuntu.com/ubuntu breezy universe
deb http://ua.archive.ubuntu.com/ubuntu breezy-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu breezy-security universe
deb ftp://ftp.linux.kiev.ua/pub/Linux/Ubuntu/pool breezy main restricted universe multiverse
deb http://ru.archive.ubuntu.com/ubuntu/ jaunty universe
deb http://ru.archive.ubuntu.com/ubuntu/ jaunty-updates universe
deb http://ua.archive.ubuntu.com/ubuntu/ trusty universe multiverse
deb-src http://ua.archive.ubuntu.com/ubuntu/ trusty universe

Что еще можно добавить?

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
makssun, что это у вас за винигрет с версий ОС от 5.04 до 14.04

Как на 14.04 (ВДС) у меня выглядит файл:
Код: Bash
  1. deb http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
  2. deb-src http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
  3.  
  4. deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
  5. deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
  6.  
  7. deb http://us.archive.ubuntu.com/ubuntu/ trusty universe
  8. deb-src http://us.archive.ubuntu.com/ubuntu/ trusty universe
  9. deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe
  10. deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe
  11.  
  12. deb http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
  13. deb-src http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
  14. deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
  15. deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
  16.  
  17. deb http://us.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
  18. deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
  19.  
  20. deb http://security.ubuntu.com/ubuntu trusty-security main restricted
  21. deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
  22. deb http://security.ubuntu.com/ubuntu trusty-security universe
  23. deb-src http://security.ubuntu.com/ubuntu trusty-security universe
  24. deb http://security.ubuntu.com/ubuntu trusty-security multiverse
  25.  
  26.  

Если коротко - свое содержимое удаляете, мое вставляете (или удаляете в своем все строки, где нет trusty). и делаете команды с предыдущих постов
« Последнее редактирование: 09 Ноябрь 2016, 14:41:59 от EvangelionDeath »
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн victor00000

  • Старожил
  • *
  • Сообщений: 14922
  • Я не слышу.
    • Просмотр профиля
aptitude search libboost1.55-all-devaptitude search libboost1.55-all-devу меня есть.
~.o

Оффлайн makssun

  • Автор темы
  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
EvangelionDeath,
Огромное спасибо!
Все получилось, запустил компилляцию, час компиллило, завершило без ошибок.
Собсно, выдало в конце путь, по нему перехожу, там куча файлов, искомых нету.

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Пожалуйста, поставьте отметку на тему "Решено"
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

 

Страница сгенерирована за 0.093 секунд. Запросов: 24.