Форум русскоязычного сообщества Ubuntu


Автор Тема: Проблема со входом в систему  (Прочитано 413 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vesenin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Проблема со входом в систему
« : 10 Ноябрь 2016, 12:50:53 »
Друзья помогите, плиз, новичку!
Я пользуюсь второй год 14.04 Опыта решения проблем не имею. Так вот, недавно были продолжительные выходные, делать дома было нечего, читал мануалы по любимой убунте, кое что экспериментировал, вот один этих экспериментов обошелся мне дорого...
Началось всё с того, что я попытался создать нового пользователя на компе с помощью терминала, перезагрузился и увидел, что система вместо привычного мне автоматического входа теперь предлагает выбор пользователей вместе с вводом пароля. Ну уж нет, подумал я, мои домашние не потерпят такие нововведения, требуется немедленно возвращать всё на круги своя! Я тут же залез в консоль и набрал userdel новый пользователь.
Но! После перезагрузки с удивлением обнаружил, что это ненавистное приглашение выбора пользователей осталось на входе! Мало того, введенный верный пароль непозволил загрузиться! Экран просто моргнул и вновь предложил выбирать пользователя или гостя. Тогда я попробовал, войти хотя бы как гость - реакция системы такая же, моргнул экран и вновь предложение выбора.
Недолго думая, переключился в консоль, ввел имя и пароль - всё работает! Ура! Набираю startx, а не тут то было! Ругается!
Чё делать? Где рыть?
Кстати, посоветовался с коллегой по убунте, а он мне только признался, что его ноут на 12.04 иногда выдавал похожий финт. То есть выбрасывал при загрузке окно приглашения выбора пользователей и стоп, кароч, всё точно также же как и у меня!
Он рассказал, что в качестве решения делал так: Ctrl + Alt + F1 следом Ctrl + Alt + F7 возвращался в графический режим и, якобы, только после такого "танца" набранный пароль срабатывал, графический режим загружался и он так и не стал разбираться в причинах, поскольку мучал этот недуг его крайне редко.
Я не гордый, попробовал сделать точно так же. Оказалось, что в моем случае это бесполезно. Пароль не принимается и фсё!
Итак, есть ли какие мысли где следует рыть? Заранее всем спасибо!

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: Проблема со входом в систему
« Ответ #1 : 10 Ноябрь 2016, 13:18:04 »
vesenin, да.
1) вы упражнялись не только в создании нового пользователя.
2) проблемы либо в драйвере видео карты, либо в конфигах. Поиск по форуму =) .ICEauthority, .Xauthority (Ctrl+Alt+F1 - логинимся, удаляем эти 2 файла, Ctrl+Alt+F7 и пробуем залогинится в графическом режиме)
« Последнее редактирование: 10 Ноябрь 2016, 13:20:14 от EvangelionDeath »
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн vesenin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Проблема со входом в систему
« Ответ #2 : 10 Ноябрь 2016, 14:00:28 »
Спасибо за помощь в форумном поиске.  :( Сам же ж вроде шерстил, шерстил, а не нашел...
Да, кстати, вопросы с драйвером видеокарты были при установке, но я считал, что всё ужо позади  :)
Вечером поковыряюсь, о результатах отпишусь.

Пользователь добавил сообщение 10 Ноябрь 2016, 22:12:20:
Совет ни помог.
1. Все удалил также, как и предполагалось мануалом. Все равно продолжаются возвраты на окно выбора пользователя.
2. Ошибки какие то нашлись по выводу команды, я бросился проверять права на указанный файл, но в строчках аккуратно прописан vesenin а не root Значит, совет также мимо. Увы

Help!

Пользователь добавил сообщение 10 Ноябрь 2016, 22:36:48:
Мало того, до всех этих моих манипуляций драйвер моей видеокарты работал стабильно. Теперь же иксы начали отваливаться уже после пары минут рассматривания окошка с выбором пользователя.
Хелп!
« Последнее редактирование: 11 Ноябрь 2016, 09:00:41 от vesenin »

Оффлайн τοΖεη

  • Заслуженный пользователь
  • Администратор
  • Старожил
  • *
  • Сообщений: 8603
    • Просмотр профиля
Re: Проблема со входом в систему
« Ответ #3 : 11 Ноябрь 2016, 17:01:24 »
vesenin, видеодрайвер переустанавливали?
Какой драйвер используете сейчас?
lspci | grep VGAчто говорит?
# find / -iname '*τοΖεη*'
# /God's_Universe/Book_Of_Life_aka_LordJC_protected/τοΖεη
Subject description -->> Not an ideal but s@ved 4eVer. Final destination -->> Kingdom Of Heaven

Оффлайн yumisst

  • Любитель
  • *
  • Сообщений: 77
    • Просмотр профиля
Re: Проблема со входом в систему
« Ответ #4 : 11 Ноябрь 2016, 17:42:19 »
по-моему нужно удалить файл из домашней директории /home/юзер/.Xauthority

Оффлайн vesenin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Проблема со входом в систему
« Ответ #5 : 12 Ноябрь 2016, 20:51:41 »
Друзья, извините конечно, я наверное поступаю не совсем патриотично по отношению к любимой убунте. Сегодня снес свою 14.04.5 и установил финальную лте версию. В данный момент тестирую. Пока полет нормальный.

Еще раз позволю себе описать историю моей проблемы.
Уже пару лет у меня на стационарном компе стояла 14.04 Помню тогда, с её установкой возникли определенные проблемы с драйверами. А именно, предустановленный свободный драйвер видеокарты падал спустя непродолжительное время работы, на экране возникала рябь, управление компом напрочь терялось. Желание юзать Ubuntu привело к пониманию, что спасти положение может только установка тестированного проприетарного драйвера. Система любезно предложила именно такой, и я его, в итоге, и установил.
Достаточно долго Ubuntu радовала пользователей. Серьезных сбоев не было. Только обновления безопасности своевременно загружались и устанавливались. Помню, только в Юнити, иногда происходили подозрительные подрагивания картинки.

А недавно я ковырялся в терминале. Можно сказать это было достаточно глупо, поскольку я не "журналировал" свои действия, самоуверенно считая себя достаточно грамотным пользователем. Ничего не обновлял, не перенастраивал. Больше читал МАНы, двигался по системе и всё. НО! После перезагрузки обнаружил проблему с перебрасыванием на окно выбора пользователя. Первая мысль была о том, что система "повторила предыдущий вариант загрузки", поскольку как я писал выше, перед этим я попытался внедрить нового пользователя. В конце концов, я убедился, что причина в чем то другом. Самостоятельно выхода я так и не нашел, обратился сюда, на форум, спасибо EvangelionDeath в тот час я искренно посчитал, что непонятно почему, но моя проблема всё таки в .Xauthority

Вечером добрался до компа, сразу удалил файл. Перещел на экран входа - вижу, сдвигов нет.
Я вернулся в консоль ещё раз, думаю мож не получилось удалить? Нет, вижу система подтверждает что файл не обнаружен.
Выхода нет, пришлось воспользоваться вторым способом. Вывод strace -f -o /tmp/x.log startx показал наличие ошибок, по мануалу говорится, мол, не важно, что же там за ошибки. И я, увидев запись error не стал дальше разбираться!
Проверяю права на файл, система сообщает, что управляется он вовсе не рутом, а vesenin.
Ступор. Комментариев нет. Чё делать?

Пообщался с товарищем, он предложил взглянуть на проблему просто: не знаю, что же произошло в системе, но ведь что то ОДНОЗНАЧНО произошло. А по этой причине можно идти двумя путями: либо ковыряться выясняя причину, либо попробовать просто обновить дистрибутив. Форум молчал, нужно было что то делать.
Я избрал второй вариант. Надеюсь 16.04 не подкачает.
Всем большое спасибо за участие, самому очень жаль, что мой опыт так мало послужит остальному сообществу! Пусть ваши машины не дают сбоев!


Пользователь добавил сообщение 12 Ноябрь 2016, 23:13:31:
Не долго радовался... На свежеустановленной системе появилась таже самая проблема.

Что делать, люди?!?
« Последнее редактирование: 12 Ноябрь 2016, 23:13:31 от vesenin »

Оффлайн vesenin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Проблема со входом в систему
« Ответ #6 : 16 Ноябрь 2016, 17:25:48 »
Да уж народ, увы общительностью наш форум не блещет...
Продолжу свою темку, ради новичка какого, попавшего грабли на подобные описанным тут.
Итак, история моих танцев продолжается следующим образом. Как я писал уже выше, сначала я попробовал обновиться до версии 16.04. И на втором включении, история в точности повторилась. Выбросило окно выбора пользователей и всё зациклилось...
Думаю, что же могло послужить причиной? Может что то произошло с драйвером видеокарты? Решил попытаться поработать на родном убунтовском. Для этого, откатился на свободный драйвер - бесполезно. Всё повторилось в точности. При загрузке вместо автоматического входа в систему выбрасывает в окно выбора пользователей и паролем ничего уже не лечится. Какие ещё версии?
Порылся по теме на форумах, народ предполагает, что одной из возможных причин возникновения такой проблемы могло послужить отсутствие свободного места на разделе с системой. Поковырялся - нет, у меня со свободным местом проблем нет.
Ну думаю, всё, просто не знаю как быть дальше! Тупик! Ничего не получается! Неужели придется перебираться на другой дистрибутив?
Ну думаю, я ж верующий человек! Взмолился: Боже Небесный помоги!
И что вы думаете? Приходит свежая мысль, поскольку проверять програмное обеспечение я уже даже не знаю с какого боку, а почему бы мне не проверить железо! Смотрю торчит в юсб разьеме, блюту адаптер!  :P Кто то из домашних втыркнул и забыл! А он мне, между прочим нервы ох как помотал, когда я его сам пытался в своё время пристроить в систему! Эта железка память грузит просто удивительно!
Итак, я удалил эту блютушку и переустановил любимую 14.04. (Такой я уж консервативный.)
Работает! Вчера доустановил нужный набор программ, перенес файлы. Работает!
Посмотрю конечно на дальнейшее поведение, но пока - проблем нет!  :)

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3096
  • Ubuntu Mate 16.04 х64
    • Просмотр профиля
Re: Проблема со входом в систему
« Ответ #7 : 16 Ноябрь 2016, 18:00:53 »
vesenin, вы так и продолжаете игнорировать вопросы:
- что у вас за видеокарта
- какой драйвер сейчас используется
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Intel 535 120GB/Ubuntu 16.04 Mate
HP 625: AMD Athlon P320, 4GB DDR3 1333MHz, AMD HD4250, Seagate Momentus/Ubuntu 14.04 Mate

Оффлайн vesenin

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: Проблема со входом в систему
« Ответ #8 : 16 Ноябрь 2016, 22:36:42 »
Извините. Последнее время не хватает времени.
Видео на компе GeForce 6150SE nForce 430
Переустановил систему, сразу использовал свободный драйвер (с юнити он не дружит), когда убедился, что система работает стабильно, поставил использовавшийся у меня прежде version 304.132 из nvidea-304
Полет нормальный! Думаю вопрос можно будет закрыть.

 

Страница сгенерирована за 0.059 секунд. Запросов: 24.