Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Проблема с зависимостями  (Прочитано 312 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Mialder

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Проблема с зависимостями
« : 12 Ноябрь 2016, 18:55:45 »
Доброго времени суток! Помогите, пожалуйста решить проблему - при попытке скачать и установить любой пакет через терминал, он выдает сообщение о том что имеется неудовлетворенная зависимость у уже установленного пакета. Только это не неудовлетворенная зависимость - система просто хочет обновить одну программу, которую мне обновлять не нужно. Есть ли способ обойти данное неудобство?

ТС не появлялся на Форуме более полугода по состоянию на 14/07/2019 (последняя явка: 04/01/2017). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 14 Июль 2019, 03:42:25 от zg_nico »

Оффлайн Pilot6

  • Старожил
  • *
  • Сообщений: 13495
  • Xubuntu 18.04
    • Просмотр профиля
Re: Проблема с зависимостями
« Ответ #1 : 12 Ноябрь 2016, 18:57:21 »
Что за пакет, что за зависимость предлагаете угадать?
Я в личке не консультирую. Вопросы задавайте на форуме.

Оффлайн Mialder

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Проблема с зависимостями
« Ответ #2 : 12 Ноябрь 2016, 19:01:35 »
Хочет обновить программу гитар про.  Но мне её обновлять нельзя)

Axa-Ru

  • Гость
Re: Проблема с зависимостями
« Ответ #3 : 12 Ноябрь 2016, 19:16:44 »
Mialder, можно запретить обновление конкретной программы
sudo apt-mark hold package_name

Оффлайн Mialder

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Проблема с зависимостями
« Ответ #4 : 04 Январь 2017, 13:07:14 »
Не помогло. После закрепления, ошибка всё равно появляется, только теперь, при попытке что либо установить не происходит обновление - действие просто отменяется. Отменил закрепление. Вот какая ситуация в терминале, на примере libreoffice
(Нажмите, чтобы показать/скрыть)
При чём вот это
(Нажмите, чтобы показать/скрыть)
появляется при попытке установить любую программу. Ввожу apt-get -f install и мой гитар про благополучно обновляется до самой новой версии. Которая у меня не работает. Если закрепляю версию - не происходит ничего. Система пытается обновиться, у неё ничего не получается и она забивает на это дело)

Оффлайн Vir0id

  • Участник
  • *
  • Сообщений: 244
  • Выкини комп из окна или окна из компа
    • Просмотр профиля
Re: Проблема с зависимостями
« Ответ #5 : 05 Январь 2017, 08:44:55 »
Гитар про сливается из подключенной репы или из стантартной? Если из подключенной, то отключи ее и делай манипуляции без этой репы, что бы не обновлялась твоя программа

 

Страница сгенерирована за 0.164 секунд. Запросов: 23.