Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: ошибка при работе с капистрано  (Прочитано 650 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн akhur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
ошибка при работе с капистрано
« : 22 Ноябрь 2016, 17:56:43 »
(Нажмите, чтобы показать/скрыть)

как исправить? Ничего толкового не нашел...(


ТС не появлялся на Форуме более трех месяцев по состоянию на 02/02/2020 (последняя явка: 29/10/2019). Модератором раздела принято решение закрыть тему.
--zg_nico
« Последнее редактирование: 02 Февраль 2020, 20:58:00 от zg_nico »

Оффлайн bezbo

  • Старожил
  • *
  • Сообщений: 1443
    • Просмотр профиля
Re: ошибка при работе с капистрано
« Ответ #1 : 22 Ноябрь 2016, 19:25:04 »
gem install capistrano

Оффлайн akhur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Re: ошибка при работе с капистрано
« Ответ #2 : 22 Ноябрь 2016, 19:38:21 »
Error installing capistrano:
   capistrano requires Ruby version >= 2.0.

Оффлайн Dot-mitsu

  • Активист
  • *
  • Сообщений: 299
    • Просмотр профиля
Re: ошибка при работе с капистрано
« Ответ #3 : 22 Ноябрь 2016, 22:40:13 »
Error installing capistrano:
   capistrano requires Ruby version >= 2.0.
Проверяйте версию Ruby

Оффлайн akhur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Re: ошибка при работе с капистрано
« Ответ #4 : 23 Ноябрь 2016, 05:26:07 »
версия 1.9.1 , а как обновится до 2 <=

toZen

  • Гость
Re: ошибка при работе с капистрано
« Ответ #5 : 23 Ноябрь 2016, 07:34:44 »
akhur,
sudo apt update ; sudo apt upgradeИли, скачать дэбку прямо с хранилища и запустить установщик в хомяке.
Например:
cd ~/Downloadswget http://mirrors.kernel.org/ubuntu/pool/universe/c/capistrano/capistrano_2.12.0-1_all.debsudo dpkg -i *.deb

Оффлайн akhur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Re: ошибка при работе с капистрано
« Ответ #6 : 23 Ноябрь 2016, 18:30:01 »
/usr/lib/ruby/1.9.1/rubygems/dependency.rb:247:in `to_specs': Could not find capistrano (>= 0) amongst [bundler-1.13.6] (Gem::LoadError)
        from /usr/lib/ruby/1.9.1/rubygems/dependency.rb:256:in `to_spec'
        from /usr/lib/ruby/1.9.1/rubygems.rb:1231:in `gem'
        from /usr/local/bin/cap:22:in `<main>'

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1936
    • Просмотр профиля
Re: ошибка при работе с капистрано
« Ответ #7 : 23 Ноябрь 2016, 20:20:14 »
Версия ОС?
Версия руби?

Оффлайн akhur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Re: ошибка при работе с капистрано
« Ответ #8 : 23 Ноябрь 2016, 20:27:19 »
14.04
1.9.1

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1936
    • Просмотр профиля
Re: ошибка при работе с капистрано
« Ответ #9 : 23 Ноябрь 2016, 20:34:01 »
версию руби надо повысить.



sudo apt-add-repository ppa:brightbox/ruby-ng
sudo apt-get update
sudo apt-get install ruby2.2 ruby-switch
пакет ruby-switch нужен для управления версиями
ruby -v

Оффлайн akhur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Re: ошибка при работе с капистрано
« Ответ #10 : 23 Ноябрь 2016, 21:30:53 »
ruby 2.2.5p319 (2016-04-26 revision 54774) [x86_64-linux-gnu]
еще вот эта ошибка осталсь

/usr/local/bin/cap:23:in `load': cannot load such file -- /usr/share/rubygems-integration/1.9.1/gems/capistrano-2.12.0/bin/cap (LoadError)
        from /usr/local/bin/cap:23:in `<main>'

Оффлайн ARTGALGANO

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1936
    • Просмотр профиля
Re: ошибка при работе с капистрано
« Ответ #11 : 23 Ноябрь 2016, 22:28:02 »

ruby-switch --checkвозможно еще
apt-get install rubygemsкак ставили капистрано?

Оффлайн akhur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Re: ошибка при работе с капистрано
« Ответ #12 : 23 Ноябрь 2016, 22:51:28 »
Currently using: ruby2.2
------------------------

ruby   -> /usr/bin/ruby2.2
gem   -> /usr/bin/gem2.2

Настраивается пакет rubygems (1.8.25-1bbox3~trusty1) …
update-alternatives: ошибка: альтернативный путь /usr/bin/gem1.8 не существует
dpkg: ошибка при обработке пакета rubygems (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 2
При обработке следующих пакетов произошли ошибки:
 rubygems
E: Sub-process /usr/bin/dpkg returned an error code (1)


Пользователь добавил сообщение 24 Ноябрь 2016, 17:24:18:
как исправить?)
« Последнее редактирование: 24 Ноябрь 2016, 17:24:18 от akhur »

Оффлайн akhur

  • Автор темы
  • Новичок
  • *
  • Сообщений: 31
    • Просмотр профиля
Re: ошибка при работе с капистрано
« Ответ #13 : 13 Май 2017, 09:33:34 »
проблема все еще актуальна

 

Страница сгенерирована за 0.158 секунд. Запросов: 23.