Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Не ставится apache2 в ubuntu server 16.04  (Прочитано 1344 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн matveevds

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Не ставится apache2 в ubuntu server 16.04
« : 24 Ноябрь 2016, 07:19:48 »
Пытаюсь настроить сетевую установку по инструкции - https://help.ubuntu.ru/wiki/%D1%83%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0_ubuntu_%D0%BF%D0%BE_%D1%81%D0%B5%D1%82%D0%B8
Но не получается поставить apache2, ругается на зависимости пакетов

matveevds@ubuntuserver:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04 LTS
Release:        16.04
Codename:       xenial


matveevds@ubuntuserver:~$ sudo apt-get install -f apache2
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 apache2 : Зависит: apache2-bin (= 2.4.18-2ubuntu3.1) но он не будет установлен
           Зависит: apache2-utils (>= 2.4)
           Зависит: apache2-data (= 2.4.18-2ubuntu3.1) но он не будет установлен
           Рекомендует: ssl-cert но он не будет установлен
 gcc-5 : Зависит: cpp-5 (= 5.4.0-6ubuntu1~16.04.2) но он не будет установлен
         Зависит: gcc-5-base (= 5.4.0-6ubuntu1~16.04.2) но 5.4.0-6ubuntu1~16.04.4 будет установлен
         Зависит: libcc1-0 (>= 5.4.0-6ubuntu1~16.04.2) но он не будет установлен
         Зависит: binutils (>= 2.26.1) но он не будет установлен
         Зависит: libgcc-5-dev (= 5.4.0-6ubuntu1~16.04.2) но он не будет установлен
         Зависит: libisl15 (>= 0.15) но он не будет установлен
         Зависит: libmpc3 но он не будет установлен
         Рекомендует: libc6-dev (>= 2.13-0ubuntu6) но он не будет установлен
 libstdc++6 : Зависит: gcc-5-base (= 5.4.0-6ubuntu1~16.04.2) но 5.4.0-6ubuntu1~16.04.4 будет установлен
 linux-image-extra-4.4.0-47-generic : Зависит: linux-image-4.4.0-47-generic но он не будет установлен
 linux-image-generic : Зависит: linux-image-4.4.0-47-generic но он не будет установлен
                       Рекомендует: thermald но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
Хелп.
Думаю нужно откатить обновления некоторых пакетов? Или нет?

Оффлайн victor00000

  • Забанен
  • Старожил
  • *
  • Сообщений: 15570
  • Глухонемой (Deaf)
    • Просмотр профиля
Re: Не ставится apache2 в ubuntu server 16.04
« Ответ #1 : 24 Ноябрь 2016, 09:15:04 »
что делать... :(
Нельзя друзья, дулу - AnrDaemon видите?
~.o

Оффлайн EvangelionDeath

  • Администратор
  • Старожил
  • *
  • Сообщений: 3433
  • Ubuntu Budgie 18.04 х64
    • Просмотр профиля
Re: Не ставится apache2 в ubuntu server 16.04
« Ответ #2 : 25 Ноябрь 2016, 10:57:32 »
matveevds, говорят, что помагает:
Код: (bash) [Выделить]
sudo apt-get update
sudo apt-get dist-upgrade
Fujitsu UH552: Intel Core i3-3217U, 16GB DDR3 1600MHz, Intel HD4000, Samsung SSD 860 EVO 250GB/Ubuntu Budgie 18.04

 

Страница сгенерирована за 0.146 секунд. Запросов: 25.