Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: [решено] libqt4-core libqt4-gui и ubuntu-16.04  (Прочитано 1813 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн pulchra

  • Автор темы
  • Участник
  • *
  • Сообщений: 117
    • Просмотр профиля
[решено] libqt4-core libqt4-gui и ubuntu-16.04
« : 29 Ноябрь 2016, 06:59:39 »
Возникла тут необходимость установить в систему 16.04 пакеты libqt4-core libqt4-gui (понадобилось оно для установки словаря yarxi). Как оказалось, для 16.04 обычным sudo apt-get install установить эти пакеты не получится. Воспользовался способом указанным на http://askubuntu.com/questions/766615/how-to-install-libqt4-core-and-libqt4-gui-on-ubuntu-16-04/766629

Делал в такой последовательности:
Установил зависимости для libqt4-core libqt4-gui
sudo apt-get install libqt4-designer libqt4-opengl libqt4-svg libqtgui4 libqtwebkit4
Создал скрипт для правки строки зависимостей deb пакетов:
gedit edit-deb-control.sh
В открывшемся редакторе gedit вставил такой код
#!/bin/bash

EDITOR=gedit

if [[ -z "$1" ]]; then
  echo "Syntax: $0 debfile"
  exit 1
fi

DEBFILE="$1"
TMPDIR=`mktemp -d /tmp/deb.XXXXXXXXXX` || exit 1
OUTPUT=`basename "$DEBFILE" .deb`.modfied.deb

if [[ -e "$OUTPUT" ]]; then
  echo "$OUTPUT exists."
  rm -r "$TMPDIR"
  exit 1
fi

dpkg-deb -x "$DEBFILE" "$TMPDIR"
dpkg-deb --control "$DEBFILE" "$TMPDIR"/DEBIAN

if [[ ! -e "$TMPDIR"/DEBIAN/control ]]; then
  echo DEBIAN/control not found.

  rm -r "$TMPDIR"
  exit 1
fi

CONTROL="$TMPDIR"/DEBIAN/control

MOD=`stat -c "%y" "$CONTROL"`
$EDITOR "$CONTROL"

if [[ "$MOD" == `stat -c "%y" "$CONTROL"` ]]; then
  echo Not modfied.
else
  echo Building new deb...
  dpkg -b "$TMPDIR" "$OUTPUT"
fi

rm -r "$TMPDIR"
Сохранил.

Скачал отсюда https://launchpad.net/ubuntu/xenial/+package/libqt4-core https://launchpad.net/ubuntu/xenial/+package/libqt4-gui пакеты libqt4-core_4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu8_i386.deb и libqt4-gui_4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu8_i386.deb (пакеты нужно поместить в папку где располагается edit-deb-control.sh).

Следом в терминале выполнил:
sh edit-deb-control.sh libqt4-core_4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu8_i386.deb у меня заработало сразу, но если выдаст ошибку то может помочь назначение на файл исполнения как программы sudo chmod +x edit-deb-control.sh
В открывшемся редакторе заменил строку Depends наDepends: libxss1,libaudio2,libasound2,libqt4-designer,libqt4-opengl,libqt4-svg,libqtgui4,libqtwebkit4,libqt4-network Сохранил, закрыл. В каталоге появился новый файл libqt4-core_4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu8_i386.modfied.deb.

Его установил в gui режиме через gdebi. Можно и в терминале: gdebi libqt4-core_4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu8_i386.modfied.debтоже проделал для libqt4-gui_4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu8_i386.deb. Ну уже следом установил нужный мне словарь, установив дополнительно шрифт ttf-sazanami-mincho_20040629-8ubuntu1_all.deb (вязял тут http://packages.ubuntu.com/precise/all/ttf-sazanami-mincho/download).


Оффлайн pulchra

  • Автор темы
  • Участник
  • *
  • Сообщений: 117
    • Просмотр профиля
Re: [решено] libqt4-core libqt4-gui и ubuntu-16.04
« Ответ #1 : 02 Май 2018, 07:20:14 »
После переустановки системы снова возникла необходимость в установке пакетов libqt4-core libqt4-gui для словаря yarxi. Описанный выше способ оказался работающим, только ссылки на пакеты необходимо использовать другие (старые ссылки уже "битые")
libqt4-core: https://ubuntu.pkgs.org/14.04/ubuntu-universe-i386/libqt4-core_4.8.5+git192-g085f851+dfsg-2ubuntu4_i386.deb.html
libqt4-gui: https://ubuntu.pkgs.org/14.04/ubuntu-updates-universe-i386/libqt4-gui_4.8.5+git192-g085f851+dfsg-2ubuntu4.1_i386.deb.html
шрифт  ttf-sazanami-mincho: https://packages.debian.org/ru/wheezy/hppa/ttf-sazanami-mincho

При правке зависимостей в пакетах libqt4-core и libqt4-gui в терминале необходимо указывать их действительные имена, т.е., например, для libqt4-core не libqt4-core_4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu8_i386.deb а libqt4-core_4.8.5+git192-g085f851+dfsg-2ubuntu4_i386.deb .

 

Страница сгенерирована за 0.064 секунд. Запросов: 24.