Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: не устанавливается Wine  (Прочитано 496 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sergio2

  • Автор темы
  • Участник
  • *
  • Сообщений: 167
    • Просмотр профиля
не устанавливается Wine
« : 03 Декабрь 2016, 21:58:33 »
Из "центра приложений" не устанавливается Wine

неудовлетворённые зависимости:

wine1.6: Depends: wine1.6-amd64 (= 1:1.6.2-0ubuntu4) но 1:1.6.2-0ubuntu4 должен быть установлен
         Depends: wine1.6-i386 (= 1:1.6.2-0ubuntu4) но это виртуальный пакет

Не подскажите, что нужно сделать? (Ubuntu 14.04.5 LTS 4.4.0-51-generic)
sudo apt-get install -f    -не помогло.

Спасибо.
Celeron 2.53GHz (1 Core), Motherboard: Phoenix, Chipset: Intel 82875P/E7210 + ICH5/ICH5R, Memory: 1024MB

Оффлайн bezbo

  • Активист
  • *
  • Сообщений: 630
    • Просмотр профиля
Re: не устанавливается Wine
« Ответ #1 : 03 Декабрь 2016, 22:23:17 »
dpkg --add-architecture i386

Оффлайн sergio2

  • Автор темы
  • Участник
  • *
  • Сообщений: 167
    • Просмотр профиля
Re: не устанавливается Wine
« Ответ #2 : 04 Декабрь 2016, 12:01:36 »
ksn@intel64:~$ dpkg --add-architecture i386
dpkg: ошибка: не удалось создать новый файл «/var/lib/dpkg/arch-new»: Отказано в доступе
ksn@intel64:~$ sudo dpkg --add-architecture i386
[sudo] password for ksn:
ksn@intel64:~$

 :-\
Celeron 2.53GHz (1 Core), Motherboard: Phoenix, Chipset: Intel 82875P/E7210 + ICH5/ICH5R, Memory: 1024MB

Оффлайн svtv1

  • Старожил
  • *
  • Сообщений: 2652
  • Это Я
    • Просмотр профиля
Re: не устанавливается Wine
« Ответ #3 : 04 Декабрь 2016, 12:23:05 »
sergio2,
Попробуй установить из терминала
http://linux.2baranga.org/2015/12/ustanovka-wine-1-8-cherez-novyj-repozitorij-v/
в 16.10 и 16.04 версия wine 1.8 работает.
По поводу не совместимости тут
https://forum.ubuntu.ru/index.php?topic=284655.0
« Последнее редактирование: 04 Декабрь 2016, 12:25:06 от svtv1 »
"Если достаточно долго сидеть возле реки - мимо проплывет труп твоего врага"

Оффлайн sergio2

  • Автор темы
  • Участник
  • *
  • Сообщений: 167
    • Просмотр профиля
Re: не устанавливается Wine
« Ответ #4 : 04 Декабрь 2016, 13:21:16 »
Спасибо. Честно говоря, с этого началось. 1.8 уже стояла и работала. Только-что переустановил систему (после обычного обновления слетел компиз, починить не удалось из-за битых пакетов). До этого система стояла больше года. Теперь такая беда случилась на второй день  :( почему-то wine не поставился. Как задолбали эти битые пакеты!!!! Пытался найти способ избежать этих hold пакетов. После установки прог из добавленных репоз. отключал эти репы. Не помогло.
Это https://forum.ubuntu.ru/index.php?topic=284655.0 попробую чуть позже.
Вообще, это пожалуй единственная проблема которая мешает мне жить в Ubuntu. Миллион програм, а этот досадный косяк ну ни чем не лечится!

Пользователь добавил сообщение 04 Декабрь 2016, 14:42:47:
sudo apt-get --fix-broken install
...обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
sudo rm /var/lib/apt/lists/* -vf
(Нажмите, чтобы показать/скрыть)

Совет 1 не помог
Совет 2 не помог
Совет 3 и 4... Пакеты, имеющие неудовлетворённые зависимости:
 wine1.8 : Зависит: wine1.8-i386 (= 1:1.8.0-0ubuntu1)
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Бред какой... переставлять ОС опять?
« Последнее редактирование: 04 Декабрь 2016, 14:42:47 от sergio2 »
Celeron 2.53GHz (1 Core), Motherboard: Phoenix, Chipset: Intel 82875P/E7210 + ICH5/ICH5R, Memory: 1024MB

 

Страница сгенерирована за 0.056 секунд. Запросов: 24.